Bug 513676 - Printer prints solid black page - Epson stylus color 200
Summary: Printer prints solid black page - Epson stylus color 200
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: foomatic
Version: 11
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-07-24 17:33 UTC by Andrew
Modified: 2009-10-14 01:59 UTC (History)
4 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2009-10-14 01:59:32 UTC


Attachments (Terms of Use)
/var/log/cups/error_log (part) (33.38 KB, text/plain)
2009-07-24 17:33 UTC, Andrew
no flags Details
Ghostscript 8.64 output for Epson Stylus Color 200 (692.66 KB, application/octet-stream)
2009-07-27 12:03 UTC, Tim Waugh
no flags Details
Ghostscript 8.15.1 output for Epson Stylus Color 200 (436.62 KB, application/octet-stream)
2009-07-30 14:08 UTC, Tim Waugh
no flags Details
Ghostscript 8.15.2 output for Epson Stylus Color 200 (504.81 KB, application/octet-stream)
2009-07-31 09:24 UTC, Tim Waugh
no flags Details
Ghostscript 8.15.4 output for Epson Stylus Color 200 (504.97 KB, application/octet-stream)
2009-07-31 13:57 UTC, Tim Waugh
no flags Details
Ghostscript 8.60 output for Epson Stylus Color 200 (294.16 KB, application/octet-stream)
2009-07-31 17:34 UTC, Tim Waugh
no flags Details

Description Andrew 2009-07-24 17:33:41 UTC
Created attachment 355077 [details]
/var/log/cups/error_log  (part)

Description of problem:
Printing test page produces totally black image, other than small circular motif 2/3 down page. Printing from open office produces totally black page.
Printer in use as black only and has been working on fedora 5 until I upgraded to fed 11. (clean install)
I downloaded the mj500c.ppd driver with same results. This is probably the same driver as foomatic.
I dont know if this is a foomatic, cups or system config issue.
I attach a cut of the last section of cups error log.
 


Version-Release number of selected component (if applicable):
cups-1:1.4-0.rc1.10.f11 (i586)
foomatic-4.0.2-4fc11 (i586)
system_config_printer-1.1.8-6fcll (i586)

How reproducible:
every time

Steps to Reproduce:
1.select print self test page or print test page
2.
3.
  
Actual results:
Printer produces solid black block.

Expected results:
text

Additional info:

Comment 1 Tim Waugh 2009-07-27 12:03:28 UTC
Created attachment 355267 [details]
Ghostscript 8.64 output for Epson Stylus Color 200

Here is the output I get for your printer from a newly created queue on Fedora 11.  Print it like this:

lp -dStylus-COLOR-200 -oraw mj500c-a4-gs8.64.prn

Please confirm that this exhibits the incorrect behaviour you describe.  We can then try to narrow down which version of ghostscript broke the driver and look for the fix.

Comment 3 Andrew 2009-07-27 13:53:12 UTC
Hi
The file you sent prints solid black as before - I cancelled the print after half a page to save some ink.
I tried printing some text from fedora 8 live cd (gnome), using foomatic database driver and generic postscript driver with same results, all black. If this gives any clues.

Comment 4 Tim Waugh 2009-07-30 14:08:42 UTC
Created attachment 355679 [details]
Ghostscript 8.15.1 output for Epson Stylus Color 200

I doubt it was the generic PostScript driver you were using -- that printer model does not understand PostScript.

How about this file?  Print it as raw, as before.

Comment 5 Andrew 2009-07-30 14:53:04 UTC
The file 8.15 prints a test page. As I am using a black printer head/cartridge the color wheel appears mostly black but the radial lines and text look good.
The text is correctly produced in boxed areas with shadow lines.
Interpreter Information
PostScript: Level 3
Version: 3010 (81501)
Etc etc and in Bold.. Printed Using CUPS v1.1.x
Success.

Comment 6 Tim Waugh 2009-07-31 09:24:05 UTC
Created attachment 355784 [details]
Ghostscript 8.15.2 output for Epson Stylus Color 200

How about this one?  So far we've tried Fedora 11 and Fedora Core 5, but this one is from Fedora Core 6.  It's a new version of CUPS, and a new test page format, but a similar version of ghostscript.

Comment 7 Andrew 2009-07-31 12:56:17 UTC
File 8.15.2 (fedora 6) prints a test page which is correct for black print head (Black color wheel). Printed text is good.
As mentioned I tried a fedora 8 live cd with the foomatic driver with ghostscript 8.6-5.fc8 which produced the totally black page problem so perhaps it's a change from fedora 7 or 8 ghostscript that's the issue ?

Comment 8 Andrew 2009-07-31 12:59:02 UTC
sorry a typo- fedora 8 ghostscript was 8.60-5.fc8

Comment 9 Tim Waugh 2009-07-31 13:57:02 UTC
Created attachment 355815 [details]
Ghostscript 8.15.4 output for Epson Stylus Color 200

Here is the output I get from Fedora 7.  Please try it.  I really hope this one fails because otherwise we'll have to try a binary search between 8.15.4 and 8.60 to find the change that broke it, which might take quite a while.

Comment 10 Andrew 2009-07-31 14:48:27 UTC
File 8.15.4 prints the test page, unfortunately. So it looks to be a later problem.

Comment 11 Tim Waugh 2009-07-31 17:34:36 UTC
Created attachment 355834 [details]
Ghostscript 8.60 output for Epson Stylus Color 200

Just to definitively narrow it down to ghostscript, here is the output of ghostscript-8.60 from Fedora 8, processing exactly the same input file as on Fedora 7.

What result does this give?

Comment 12 Andrew 2009-08-01 12:17:30 UTC
The file for ghostscript 8.60 fails with the solid black print.
Hope this helps.

Comment 13 Andrew 2009-08-02 15:36:45 UTC
Additional information

Searching the internet for related items I came across

http://www.linuxprinting.org/show_driver.cgi?driver=mj500c&fromprinter=Epson-Stylus_Color_200

which refers to the mj500c driver and ghostscript 'broken' this links to a bug
http://bugs.ghostscript.com/show_bug.cgi?id=689595

This bug does not appear to be the same as my issue but could be related.
Following the suggestion of trying gutenprint (although the printer is not supported) I installed gutenprint-cups and tried a gutenprint driver for the epson stylus color. (not the 200) This fails to print. I then tried the alternative Epson Stylus Color Foomatic/stcolor, driver name STCOLOR.PPD Driver version 1.1. This produces a test page and I can successfully print spreadsheets and documents in black.
As a workaround this works for me for the black print head.

As a matter if interest as the ghostscript bug refers to incorrect colours I searched and found my printer colour print head and cartridge although it has not been used for years. Trying the test pages with the working gs prn files you sent produces only a colour wheel with incorrect colours and no text. Trying a test page with the stcolor driver (via system config) produces blue text (no black) So it looks as if the driver has other issues as well. bugs.ghostscript list a possible patch. I don't wish to unnecessarily use up your valuable time with this, but I could try any patches/tests from them or yourself if it's any help to fix this.

Comment 14 Tim Waugh 2009-08-04 11:18:04 UTC
OK, will adjust foomatic so that it recommends the stcolor driver for this model.  The mj500c driver is more badly broken than I had realised.

Comment 15 Till Kamppeter 2009-08-04 14:50:27 UTC
foomatic-db fixed upstream in the BZR repository rev 968. Thanks for the bug report.

Comment 16 Hin-Tak Leung 2009-08-04 19:41:05 UTC
Hi Tim - the driver has been out of tree in ESP ghostscript (8.15.X) until Till merged ESP-specific changes to trunk around the 8.57 time frame; so to bisect you'll probably need to either backport from 8.57 or forward port from 8.15...

Till: comment 13 stated that document (B/W) printing works with the stcolor driver (which presumably implies color does not?).

Comment 17 Hin-Tak Leung 2009-08-04 19:46:07 UTC
(In reply to comment #16)
> Till: comment 13 stated that document (B/W) printing works with the stcolor
> driver (which presumably implies color does not?).  

Actually the user's comment on the gs bug report (
http://bugs.ghostscript.com/show_bug.cgi?id=689595#c25) stated that color is wrong for the stcolor driver.

Comment 18 Andrew 2009-08-05 11:09:53 UTC
I think I should clarify the colour issue. Firstly this printer has a black print head and a 3 colour print head which need to be exchanged for black only or colour printing. I can't guarantee that the colour print head is functioning correctly as I have no way of testing it and its old. It used to work (win 95) before I moved to Fedora core 1 in 2004. I normally only use black and cannot recall if colour ever worked with fedora 1 or 5. Fedora 11 broke the black, hence the bug report.

Printing the printer test pages with the colour head 
raw file mj500c cups v1.1.x interpreter version 3010 (81501)
produces the following:
octagonal color wheel ONLY, No text, no radial lines.
Colour wheel as follows – index letters not printed
M	light blue
C	dark blue*
W	white (not inked)
B	dark blue*
G	dark blue*
R	dark blue*
K	white (not inked)
Y	pink

raw file mj500c cupsv1.2.x interpreter version 3010 (81502)
circular color wheel ONLY, No text, no radial lines or gray ramp
Colour wheel as follows – index letters not printed
M	light blue
C	dark blue*
B	dark blue*
G	dark blue*
R	dark blue*
Y	pink

stcolor.ppd driver version 1.1 cups 1.4rc1. Printer 'print test page' via system config printer properties
All text in dark blue. Small colour wheel three colour dark blue, pink, light blue. Shade bar mainly dark blue.
Trying the printer 'print self test' option gives CUPS server error, There was an error during the CUPS operation: 'client-error-document-format-not-supported'.

Comment 19 Hin-Tak Leung 2009-08-13 02:23:09 UTC
This really has got nothing to to with either foomatic or cups. Both mj500c and stcolor are ghostscript compiled-in drivers, so the precise ghostscript versions, including redhat-custom patches corresponding to the three tests, are needed. i.e. the output of 'rpm -q ghostscript'. I suppose it is the last one (the '1.4rc1' I don't even have an estimate - the others are obviously 8.15.1-x and 8.15.2-x).

The symptoms look like what I already said ( http://bugs.ghostscript.com/show_bug.cgi?id=689595#c21 ): a few colors map to the same ink-code... I just didn't know what that ink code was, but it looks like it is dark blue ink :-). My patch (http://bugs.ghostscript.com/show_bug.cgi?id=689595#c19 ) should separate the dark blue inks into different colors, but likely results in a different e.g. M->C, B->G, R->M kind of problem - hence I asked if somebody had the actual printer to give the patch a try... I'll think a little about what the broken scan means first.

Comment 20 Tim Waugh 2009-08-13 09:01:53 UTC
Hin-Tak:

GOOD: ghostscript-8.15.4-3.fc7
BAD:  ghostscript-8.60-5.fc8

But for Fedora we're just not going to use that driver, so this report will be closed when a foomatic update reflects that.

Comment 21 Fedora Update System 2009-08-21 11:12:54 UTC
foomatic-4.0.2-6.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/foomatic-4.0.2-6.fc11

Comment 22 Fedora Update System 2009-08-22 00:59:17 UTC
foomatic-4.0.2-6.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update foomatic'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-8843

Comment 23 Fedora Update System 2009-08-25 04:28:33 UTC
foomatic-4.0.2-7.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update foomatic'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-8843

Comment 24 Fedora Update System 2009-09-03 00:32:10 UTC
foomatic-4.0.3-1.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update foomatic'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-8843

Comment 25 Andrew 2009-10-05 14:41:33 UTC
Tested update. Works around the old driver issue for black printing. As expected.

Comment 26 Fedora Update System 2009-10-14 01:59:09 UTC
foomatic-4.0.3-1.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.