Bug 513680 - [patch] kernel 2.6.31 don't boot with my laptop
[patch] kernel 2.6.31 don't boot with my laptop
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-24 13:54 EDT by dominique
Modified: 2009-11-02 17:59 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-02 17:59:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
2.6.31.boot (944 bytes, text/plain)
2009-08-29 00:59 EDT, dominique
no flags Details
dmesg.txt (42.86 KB, text/plain)
2009-09-15 09:58 EDT, dominique
no flags Details
dmesg kernel-2.6.31.4-80.fc12 (46.03 KB, text/plain)
2009-10-14 12:06 EDT, Jens Falsmar Oechsler
no flags Details
lspci -vv (30.83 KB, text/plain)
2009-10-14 12:07 EDT, Jens Falsmar Oechsler
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Linux Kernel 14129 None None None Never

  None (edit)
Description dominique 2009-07-24 13:54:11 EDT
Description of problem:
I have installed fedora rawhide on a test partition, and after the update (I have disable all F11 repo and enable rawhide repo + rpm-fusion free and nonfree rawhide) when I want to boot on a 2.6.31 kernel, I see the progression bar, but after nothing appear...
I test with 2.6.31-0.76.rc3.git4.fc12.x86_64 and 2.6.31-0.81.rc3.git4.fc12.x86_64 kernel for same result.
After reboot my laptop, I boot on my F11, mount ./ of rawhide to see the log, but there are no log in /var/log for time when I want booting on 2.6.31 kernel...
On /boot partition of rawhide I see a strange thing:
config-2.6.29.4-167.fc11.x86_64 is a "type Document texte brut" , and i can boot on this
but
config-2.6.31-0.76.rc3.git4.fc12.x86_64 and config-2.6.31-0.81.rc3.git4.fc12.x86_64 are noted as
Type: sous-titre MPSub

For test I install the latest 2.6.30 kernel for F12, after uninstall 2.6.31 kernel, and with this 2.6.30 kernel I can boot.

After I re-install the latest 2.6.31 kernel for F12 (2.6.31-0.86.rc3.git5.fc12.x86_64) and it don't boot,I have no progress bar and no log in /var/log for time when I boot.
My laptop is an Toshiba X200, core(TM)2 duo centrino T7500 2.20GHz, with nvidia card 8700M GT, 4Go ram and DD Hitachi Sata Travelstar 7K200 120Go.
Do you help me?
Comment 1 Alexandre Roumiantsev 2009-08-13 03:52:14 EDT
Same problem:
After I update from rawhide repo to F12 the 2.6.31 kernel (2.6.31-0.125.4.2.rc5.git2.fc12.x86_64 and some previous) it don't boot,I have no progress bar and no log in /var/log for time when I boot.
My laptop is an ASUS F3K, AMD64 Athlonx2, with ATI Rageon X2300 card , 4Go ram
Comment 2 dominique 2009-08-19 02:49:40 EDT
Hi
For test I do one thing...
I download from www.kernel.org the 2.6.31-rc6-git4 kernel and I install it.(compile, make ...)
And there are same problem, also I think 2.6.31 kernel don't like my laptop...
This kernel is an r.c., not mature, with bug, and if you use this kernel for your F12 alpha DVD, I can not use it...
Why did not use the 2.6.30 kernel?
Comment 3 dominique 2009-08-29 00:59:15 EDT
Created attachment 359135 [details]
2.6.31.boot
Comment 4 dominique 2009-08-29 01:01:41 EDT
I install the 2.6.31-0.185.rc7.git6.fc12.x86_64, and with this I have an interactive start-up.
see the 2.6.31.boot.txt attachment.
Comment 5 info@kobaltwit.be 2009-09-04 07:33:41 EDT
Same problem here with kernel 2.6.31-0.190.rc8.fc12.i686.PAE.

My laptop is a Macbook Pro, upgraded from Fedora 11 to rawhide using yum.

The default FC11 kernel (2.6.29-xxx), which is still installed after the upgrade, works fine.

When I boot the system and choose the 2.6.31 kernel in grub, the screen goes black with a rapidly blinking cursor in the top left corner. While I wait, the fans of my laptop kick into high gear, but nothing else happens. I don't risk waiting 2 minutes with roaring fans, as I don't know if I risk overheating the system, so I can't tell if something will happen eventually like with dominique.

If more info is required, just ask.
Comment 6 info@kobaltwit.be 2009-09-04 09:19:13 EDT
Never mind my comment #5. After some more digging, it turns out my grub.conf was trying to load a non-existent initrd.

For some reason, the new initrds are named initrd-generic-<version>.img instead of initrd-<version>.img. I didn't notice while manually adding the required entry in grub.conf.
Fixing the entry fixed my boot issue.

Sorry for the noise.
Comment 7 dominique 2009-09-13 02:13:01 EDT
If that can help you, I took 2 photos of problem:
Photo1: boot of 2.6.31 kernel:
http://pix.toile-libre.org/?img=1252817142.jpg

Photo2: errors when I do CTRL+ALT+DEL (when I reboot):
http://pix.toile-libre.org/?img=1252818460.jpg
Comment 8 dominique 2009-09-15 09:58:07 EDT
Yeepeeeee....
I can boot on a 2.6.31 kernel (2.6.31-12.fc12) by add "acpi=off) in boot option...
See the dmseg.txt attachment
Comment 9 dominique 2009-09-15 09:58:59 EDT
Created attachment 361090 [details]
dmesg.txt
Comment 10 dominique 2009-09-17 01:48:50 EDT
HI...
I send a bug report to kernel.org (http://bugzilla.kernel.org/show_bug.cgi?id=14129) and he send me a link with a patch (http://lkml.org/lkml/2009/7/20/426).
I rebuild a 2.6.31 kernel (2.6.31-14.fc12) with this patch, but that don't work, same result as previously.
Can you make a patch for acpi working with my laptop? (toshiba X200)
Comment 11 dominique 2009-09-18 01:31:15 EDT
For problem with acpi with my laptop, I search on the web, and find this thread:

http://patchwork.kernel.org/patch/39735/


I don't know if it is the solution, but maybe that can help you.
Comment 12 dominique 2009-09-20 14:30:19 EDT
For test I do another think.
I use Fedora 11, and to see if the patch of fedora is not the origin of
problem, I take a 2.6.31 kernel (here:
http://www.kernel.org/pub/linux/kernel/v2.6/linux-2.6.31.tar.bz2) and I compile
and install it to my Fedora 11.
This kernel don't boot, except if I add acpi=off on boot.(same result as
previously...).
I am not a programmer, and I don't made a patch.
But if I understand the log, the problem is with LNXVIDEO and LNXSYSTM...
Comment 13 dominique 2009-10-06 01:46:37 EDT
Hi...
Rafael, from kernel.org made a patch, and with that kernel 2.6.31 boot without acpi=off (I have tested with 2.6.31.1-58.fc12.x86_6 kernel).
See here:
http://bugzilla.kernel.org/show_bug.cgi?id=14129

The patch is here:
http://bugzilla.kernel.org/attachment.cgi?id=23269
Comment 14 dominique 2009-10-11 02:24:17 EDT
For the patch, I see on kernel.org it will be include in the future 2.6.32 kernel, but not in the 2.6.31...
Could you add this patch in the fedora kernel?
Comment 15 Chuck Ebbert 2009-10-13 07:36:58 EDT
Patch is here now, still not in the Linus tree though:

http://git.kernel.org/?p=linux/kernel/git/lenb/linux-acpi-2.6.git;a=commitdiff_plain;h=497fb54f578efd2b479727bc88d5ef942c0a1e2d
Comment 16 Jens Falsmar Oechsler 2009-10-14 12:05:55 EDT
Not sure if its the same issue but my laptop hangs for several minutes on boot with 2.6.31 unless I add acpi=off. 

I was hoping kernel-2.6.31.4-80.fc12 had fixed it since it says "fixed boot hang with ACPI for some systems" in changelog but its the same.


Without quiet parameter the output shown when it hangs includes
async/0 used greatest stack depth: 3904 bytes left
ACPI: EC: missing confirmations, switch off interrupt mode.

ACPI Warning: \_SB_.PCI0.SATA.PRT0._GTF: Return type mismatch - found Integer, expected Buffer 20090521 nspredef-940
ata1.00: _GTF unexpected object type 0x1

After a while it will manage to continue with init.
Comment 17 Jens Falsmar Oechsler 2009-10-14 12:06:45 EDT
Created attachment 364772 [details]
dmesg kernel-2.6.31.4-80.fc12
Comment 18 Jens Falsmar Oechsler 2009-10-14 12:07:13 EDT
Created attachment 364773 [details]
lspci -vv
Comment 20 Chuck Ebbert 2009-10-16 06:14:55 EDT
In 2.6.31.4-85.fc12

Note You need to log in before you can comment on or make changes to this bug.