Bug 513768 - avahi-discover requires GTK, should move to avahi-ui-tools
Summary: avahi-discover requires GTK, should move to avahi-ui-tools
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: avahi
Version: rawhide
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Lennart Poettering
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 554812 (view as bug list)
Depends On:
Blocks: 516998 554812 554813
TreeView+ depends on / blocked
 
Reported: 2009-07-25 15:15 UTC by W. Michael Petullo
Modified: 2010-01-25 20:10 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 554812 554813 (view as bug list)
Environment:
Last Closed: 2010-01-25 20:10:47 UTC
Type: ---


Attachments (Terms of Use)

Description W. Michael Petullo 2009-07-25 15:15:26 UTC
Description of problem:
Every time

Version-Release number of selected component (if applicable):
avahi-tools-0.6.25-3.fc11.i586

How reproducible:
Every time

Steps to Reproduce:
Notice that avahi-discover requires GTK. If this tool was moved to avahi-ui-tools, then avahi-tools would no longer require GTK. This is desirable on small systems.
  
Actual results:
$ avahi-discover 
Sorry, to use this tool you need to install Avahi, pygtk and python-dbus.
Error: libgtk-x11-2.0.so.0: cannot open shared object file: No such file or directory

Expected results:
Tools that require GTK should be in avahi-tools-ui

Additional info:

Comment 1 Lennart Poettering 2010-01-12 20:02:59 UTC
I don't think it is appropriate to move files like this between packages in released distros, so I am not going to fix this in F11, sorry. Moving to rawhide.

Comment 2 Lennart Poettering 2010-01-12 20:03:52 UTC
*** Bug 554812 has been marked as a duplicate of this bug. ***

Comment 3 Lennart Poettering 2010-01-25 20:10:47 UTC
Fixed in rawhide.


Note You need to log in before you can comment on or make changes to this bug.