This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 513771 - virsh/virt-manager fail to provide sound card to guest
virsh/virt-manager fail to provide sound card to guest
Status: CLOSED DUPLICATE of bug 508317
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Veillard
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-25 12:43 EDT by Jón Fairbairn
Modified: 2009-08-11 12:50 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-11 12:50:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jón Fairbairn 2009-07-25 12:43:40 EDT
Description of problem:
If a guest is configured via virt-manager with a sound card (or via virsh define; the xml contains <sound model='es1370'/>) and then started either with sudo virsh start or virt-manager, no sound card appears on the guest.


Version-Release number of selected component (if applicable):
libvirt-0.6.2-12.fc11.x86_64

How reproducible:
Completely

Steps to Reproduce:
1. Install a vm, giving it a soundcard
2. Start the vm with virt-manager
3. type lspci into a shell on the guest
4. look for a soundcard in the listing

Actual results:
A list of pci devices none of which is a sound card

Expected results:
A list containing a sound card

Additional info:

The log for such a  vm shows it is started with:

LC_ALL=C PATH=/sbin:/usr/sbin:/bin:/usr/bin /usr/bin/qemu-kvm -S -M pc -m 512 -smp 1 -name Ubuntu_live -uuid 18f873f4-eeab-7e46-1c45-58ff70b57206 -monitor pty -pidfile /var/run/libvirt/qemu//Ubuntu_live.pid -boot d -drive file=/home2/jf/ubuntu-8.04.2-desktop-i386.iso,if=ide,media=cdrom,index=2 -net nic,macaddr=54:52:00:41:ee:74,vlan=0 -net tap,fd=17,vlan=0 -serial pty -parallel none -usb -usbdevice tablet -vnc 127.0.0.1:0 

ie no -soundhw, which might be a hint.

I have a pulseaudio daemon running and can paplay stuff
through it.

My host machine is headless, so to get a graphical display
on it I use vnc. Although I've granted myself all the
relevant polkit permissions and selinux access, I can't
usefully define my own vms; if I use virsh, I have to

connect qemu:///system

before starting vms will work (I get domain didn't show
up errors otherwise).
Comment 1 Mark McLoughlin 2009-08-11 12:50:02 EDT
Thanks for the report

libvirt currently disables sound cards when using svirt, see bug #508317

*** This bug has been marked as a duplicate of bug 508317 ***

Note You need to log in before you can comment on or make changes to this bug.