Bug 513799 - Intel Link 5300 WiFi cannot established encrypted connection
Intel Link 5300 WiFi cannot established encrypted connection
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: wireless-tools (Show other bugs)
11
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-25 20:22 EDT by Michael
Modified: 2010-06-28 09:49 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-28 09:49:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
uname, iwconfig, lspci, dmesg excerpt (8.03 KB, text/plain)
2009-07-25 20:22 EDT, Michael
no flags Details

  None (edit)
Description Michael 2009-07-25 20:22:56 EDT
Created attachment 355166 [details]
uname, iwconfig, lspci, dmesg excerpt

Description of problem:
-----------------------
Intel WiFi card model Link 5300 on Fedora 11 cannot establish connection with encrypted networks. Card scans and locates all surrounding networks, but when connecting takes long time, whereafter a dialogue asking for passkey appears. This is repeated a number of times until connection fails. DE is KDE4, using NetworkManager and plasma network widget. 


How reproducible:
-----------------
Highly. Any attempt to connect to any encrypted network using KDE4's network manager (plasma widget) will result in the described issue. 


Additional info:
----------------
Not isolated to only the 5000-series card or iwlagn, f.i. an identical bug for the 3945 chipset is posted here: https://bugzilla.redhat.com/show_bug.cgi?id=458452

Might be a known issue in other distros too. See f.i. this Mandriva bug report, http://www.nabble.com/-Bug-43441--kernel%2C-NEW%3A-wifi-iwl3945-barely-connects-td19276900.html#a19276908, where it is investigated and apparently solved.

Also possibly related, RedHat advices users of Intel chipset wifis to disable hardware accelerated encryption: https://bugzilla.redhat.com/show_bug.cgi?id=468967
Comment 1 Michael 2009-07-25 20:45:56 EDT
Similar (if not identical) bug: https://bugzilla.redhat.com/show_bug.cgi?id=446015
Comment 2 Michael 2009-07-25 20:50:44 EDT
Possibly related (seemingly similar) bug from F10: https://bugzilla.redhat.com/show_bug.cgi?id=458452
Comment 3 John W. Linville 2009-07-27 09:24:30 EDT
What sort of encryption are you using?  Are you absolutely sure that you are using the correct credentials (i.e. WEP key or WPA password)?

Have you tried logging into a GNOME session and using NetworkManager there?  And/or have you tried establishing a connection by disabling NetworkManager and using iwconfig and/or wpa_supplicant directly?
Comment 4 Michael 2009-07-28 11:05:02 EDT
I am certain I am using the correct credentials. I am running a KDE only system so I have not tried running a GNOME session. I have tried several Live CDs though, and both Fedora and OpenSUSE display the same problem, while Mandriva 2009.1 MLO (KDE4 live cd) successfully manages to establish connection to secure wifi networks.

This also seems to be a widespread and common issue, and probably a complex one depending on the interplay of several components. While is predominantly seems to be an Intel wifi issue, there are indications (forum threads etc) of it also being a problem with other wifi chipsets. 

For a wider discussion and description, please see the original FedoraForum thread: http://forums.fedoraforum.org/showthread.php?t=227035
Comment 5 John W. Linville 2009-07-28 11:34:20 EDT
Honestly, you seem to be finding every reference to every problem with every distribution for the past few years and figuring that they are all the exact same thing that you are seeing now with F11 on your box.  This isn't helpful.

The questions in comment 3 have an implied 'if not, then please do so and tell me the results' on the end of them.  Pointing at some random thread didn't provide those answers for me.

FWIW, I connect to encrypted networks (both WEP and WPA) with F11, NetworkManager, and iwl5300 everyday -- please don't presume that the problem you are experiencing is universal.
Comment 6 Michael 2009-07-28 14:46:20 EDT
I seem to be rubbing you the wrong way in my attempt to be helpful and provide research. It is a little bit "damned if you do, damned if you don't" when one's asked to make bug reports, being asked to try to do one's best beforehand, to be helpful and informative, and then shot down for it. Makes me very hesitant to post any bug reports in the future. Still, I apologise. 

However, while not having made any claims as to universality, I do think that your reply goes the other way around too: because it works at your rig doesn't mean that your luck is universal. 

If I can provide any better information, please tell me what would be needed and I will do my best.
Comment 7 Edouard Bourguignon 2009-08-02 17:11:27 EDT
I have similar problem
Comment 8 Bug Zapper 2010-04-28 05:20:01 EDT
This message is a reminder that Fedora 11 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 11.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '11'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 11's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 11 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 9 Bug Zapper 2010-06-28 09:49:48 EDT
Fedora 11 changed to end-of-life (EOL) status on 2010-06-25. Fedora 11 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.