This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 513818 - pulseaudio fails with video playback in recent kernel
pulseaudio fails with video playback in recent kernel
Status: CLOSED DUPLICATE of bug 506075
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
11
i686 Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-26 06:45 EDT by cam
Modified: 2009-08-03 04:16 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-03 04:16:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Log file excerpt from start of pulseaudio problems to the time it quits after CPU overload (6.01 KB, text/plain)
2009-07-26 06:45 EDT, cam
no flags Details

  None (edit)
Description cam 2009-07-26 06:45:32 EDT
Created attachment 355186 [details]
Log file excerpt from start of pulseaudio problems to the time it quits after CPU overload

Pulseaudio initially seems to work but after a short while, or maybe under CPU load, the sound breaks up and stops, volume controls become ineffective. The CPU load seems to peak at this time and pulseaudio logs errors.

Seen using kernel kernel-2.6.29.6-213.fc11.i586
Goes away on reverting to kernel kernel-2.6.29.4-167.fc11.i586
I think it's also OK with kernel-2.6.29.5-191.fc11.i586

How reproducible: 100%


Steps to Reproduce:
1. using kernel-2.6.29.6-213.fc11.i586, pulseaudio, snd_intel8x0
2. start flash video playback (eg. youtube content)
3. wait approx 20 sec, sound breaks up and messages logged 
  
Actual results: broken sound, ineffective volume control, CPU load rises


Expected results: smooth playback


Additional info: the login sound often stutters on this system, a while back it worked perfectly but has since returned to the stuttering state.
Comment 1 Joel 2009-07-28 17:06:02 EDT
Is this a duplicate of:

https://bugzilla.redhat.com/show_bug.cgi?id=506075

?
Comment 2 cam 2009-07-28 18:04:40 EDT
(In reply to comment #1)
> Is this a duplicate of:
> 
> https://bugzilla.redhat.com/show_bug.cgi?id=506075
> 
> ?  

Some of the symptoms are the same (log messages) but the other bug doesn't mention serious problems with the sound quality, or that pulseaudio crashes, or the volume control not working.
Comment 3 Lubomir Rintel 2009-08-03 04:16:49 EDT
(In reply to comment #2)

> Some of the symptoms are the same (log messages) but the other bug doesn't
> mention serious problems with the sound quality, or that pulseaudio crashes, or
> the volume control not working.  

Those are all caused by the overruns (pulseaudio commits suicide after it consumes excessive number of cpu time, which disconnects the volume applet).

*** This bug has been marked as a duplicate of bug 506075 ***

Note You need to log in before you can comment on or make changes to this bug.