When trying to use up2date, I got the following warning:
Test install failed failed because of package conflicts:
package Gtk-Perl-0.7008-ximian.1 (which is newer than Gtk-Perl-0.7008-1) is
If the version on my system is newer than the version that RHN has, then I
should not have been offered the package to upgrade.
Steps to reproduce:
1) Install Red Hat Linux 6.2
2) Update to the latest errata _except_ only update to RPM v3.0.5 You won't be
able to install the ucd-snmp update, and will only be able to update to
up2date-2.1.x, the 2nd to last gnorpm updates, and a couple of others.
3) Install Ximian GNOME 1.4, including packages from the Ximian Preview Channel
4) Upgrade to Fairfax beta3
5) Run rhn_register and register the system
6) Run up2date, choose select all packages and try to upgrade
7) See the error message :)
This defect is considered MUST-FIX for Fairfax.
our gnome packages have a higher epoch than ximians.
Assigned to the owner of component
After a little more testing, I can make this error occur when I only select
Gtk-Perl or eel. I could probably recreate this error with several other packages.
Neither the Gtk-Perl nor the eel package from Ximian, nor the ones from RHL
Rawhide, have an epoch, sorry Adrian :/
*** This bug has been marked as a duplicate of 51760 ***