Bug 513895 - new IME does not show up in ibus-setup
new IME does not show up in ibus-setup
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Peng Huang
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-26 21:06 EDT by Jens Petersen
Modified: 2010-01-11 01:50 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-11 01:50:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jens Petersen 2009-07-26 21:06:39 EDT
Description of problem:
When I install a new IME it does not show up immediately in ibus-setup.

Version-Release number of selected component (if applicable):
ibus-1.1.0.20090612-1.fc11

How reproducible:
every time

Steps to Reproduce:
1. yum install ibus-chewing
2. run ibus-setup to add chewing IME
  
Actual results:
2. Chewing IME does not appear in the list of IMEs.

Expected results:
2. Chewing IME to be available without restarting ibus.
Comment 1 Ding-Yi Chen 2009-08-18 19:45:51 EDT
I cannot reproduce this. BTW, I've made a new ibus-chewing version for F-11.
wanna try it?

Regards,
Ding-Yi Chen
Comment 2 niklas.laxstrom+bro@gmail.com 2009-10-04 06:49:16 EDT
This happened for me too, there was nothing before restasting ibus-daemon. And after wards there was anthy, tamil, and other! This is very weird since I have installed at least anthy, table, table-additional rawcode and expected see more options like something for Russian.
Comment 3 Peng Huang 2009-12-22 05:00:14 EST
It is system limit. We have to restart ibus to apply changes.
In upstream, I add some code to poll changes of engines, and show a notification balloon to ask user restart ibus. I will build it for fedora soon.
Comment 4 Peng Huang 2009-12-24 23:02:42 EST
Fixed in ibus-1.2.0.20091225-1.fc13

Note You need to log in before you can comment on or make changes to this bug.