Bug 513911 - Duplex printing as user fails; status is "/usr/lib/cups/filter/foomatic-rip failed"; succeeds as root
Summary: Duplex printing as user fails; status is "/usr/lib/cups/filter/foomatic-rip f...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: hplip
Version: 11
Hardware: x86_64
OS: Linux
low
high
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 516078
Blocks: 516998
TreeView+ depends on / blocked
 
Reported: 2009-07-27 04:30 UTC by Stephen Haffly
Modified: 2009-08-31 23:30 UTC (History)
2 users (show)

Fixed In Version: 3.9.8-12.fc11
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-08-31 23:30:45 UTC


Attachments (Terms of Use)
Firefox web page printed to PDF file to use with evince (430.86 KB, application/pdf)
2009-07-27 04:30 UTC, Stephen Haffly
no flags Details
Debug output before reinstalling Fedora 11 (94.53 KB, text/plain)
2009-07-27 23:23 UTC, Stephen Haffly
no flags Details
Debug output before reinstalling Fedora 11 but after reinstalling hplip (80.55 KB, text/plain)
2009-07-27 23:25 UTC, Stephen Haffly
no flags Details
Debug output after reinstalling Fedora 11 x86_64 (86.53 KB, text/plain)
2009-07-27 23:26 UTC, Stephen Haffly
no flags Details
Foomatic log for test page (3.09 KB, application/octet-stream)
2009-07-27 23:30 UTC, Stephen Haffly
no flags Details
foomatic ps for test page (1.37 MB, application/postscript)
2009-07-27 23:32 UTC, Stephen Haffly
no flags Details
foomatic log for pdf document (4.16 KB, application/octet-stream)
2009-07-27 23:33 UTC, Stephen Haffly
no flags Details
foomatic ps for pdf document (1.27 MB, application/postscript)
2009-07-27 23:34 UTC, Stephen Haffly
no flags Details
Screen capture of SELINUX troubleshooter (94.84 KB, image/png)
2009-08-11 19:20 UTC, Stephen Haffly
no flags Details

Description Stephen Haffly 2009-07-27 04:30:28 UTC
Created attachment 355227 [details]
Firefox web page printed to PDF file to use with evince

Description of problem:  Printing with a new HP OfficeJet Pro 8500 a909a with duplexer, duplex printing fails when I try to print multi-page documents as a user.  This happens with both Firefox and Evince.  In every case, the first page prints, then the job aborts and the job status is "stopped".  Viewing the job status using the CUPS web browser interface reveals that the state contains this line:

"/usr/lib/cups/filter/foomatic-rip failed".

After trying many different things, I opened Evince as su and attempted to print from there.  When I did so, the document completed printing as expected.

The problem is then that the normal user cannot print duplex.


Version-Release number of selected component (if applicable):

[root@emerald foomatic]# rpm -qa hpijs
hpijs-3.9.2-4.fc11.x86_64
[root@emerald foomatic]# rpm -qa hplip
hplip-3.9.2-4.fc11.x86_64
[root@emerald foomatic]# rpm -qa hplip-libs
hplip-libs-3.9.2-4.fc11.x86_64
[root@emerald foomatic]# rpm -qa hplip-gui
hplip-gui-3.9.2-4.fc11.x86_64
[root@emerald foomatic]# rpm -qa cups
cups-1.4-0.rc1.10.fc11.x86_64


How reproducible:

Start Fedora 11 (with all available updates)
Open Firefox and browse to a page which I want to print
Use the print dialog to configure for duplex (either long edge or short edge) printing on the Page Setup tab
Attempt to print
Job prints first page, then stops.

Start evince
Open multiple page PDF document
Use the print dialog to configure for duplex (either long edge or short edge) printing on the Page Setup tab
attempt to print
Job prints first page, then stops.

Open terminal window and enter su -
execute Firefox to open browser in root mode
Browse to multi-page document
Attempt to print as above
Document prints fully.

Open Evince in the same session
Open multiple page PDF document
Configure for duplex printing as above and attempt to print
Document prints fully.


Steps to Reproduce:
1. Start Fedora 11 (with all available updates)
2. Open Firefox and browse to a page which I want to print
3. Use the print dialog to configure for duplex (either long edge or short edge) printing on the Page Setup tab
4. Attempt to print
5. Job prints first page, then stops.

6. Start evince
7. Open multiple page PDF document
8. Use the print dialog to configure for duplex (either long edge or short edge) printing on the Page Setup tab
9. attempt to print
10. Job prints first page, then stops.
  
Actual results:
Documents print only first page and job aborts.

Expected results:
Documents should print all pages using duplexer.

Additional info:
Jobs will all print single-sided with no problems.  I rate the problem as high because it affects the functionality and purpose for which I purchased the printer severely.

This thread on Fedora Forum may have a clue for a fix, but I am not sure what permissions should exist with the /usr/lib/cups folder and contained elements:

 http://forums.fedoraforum.org/showthread.php?t=227137

I am attaching one PDF document which is a web page printed to file from Firefox.  That is how I discovered that it was not limited to Firefox.

Comment 1 Tim Waugh 2009-07-27 11:45:35 UTC
First, thanks for reporting the bug.

I don't think it's to do with which user submitted the job -- much more likely is that there is a configuration difference between the root and non-root users leading to slightly different jobs being submitted.

The main problem seems to be that foomatic-rip has stopped while processing the job.  There was an update released last week to address just such a problem:
  https://admin.fedoraproject.org/updates/F11/FEDORA-2009-7828

So what does 'rpm -q foomatic' say?

Comment 2 Stephen Haffly 2009-07-27 13:52:34 UTC
[root@emerald ~]# rpm -q foomatic
foomatic-4.0.2-4.fc11.x86_64

It looks like it fails with the most up-to-date foomatic as well.

Comment 3 Stephen Haffly 2009-07-27 13:54:08 UTC
Single sided printing is no problem.  If the foomatic update fixed that, then the duplex printing might still be a separate issue that was not addressed.

Comment 4 Tim Waugh 2009-07-27 14:11:03 UTC
Now please edit /etc/foomatic/filter.conf and add this line:

debug: 1

Print a test page, and attach /tmp/foomatic-rip.log and /tmp/foomatic-rip.ps.  Thanks.

Comment 5 Stephen Haffly 2009-07-27 23:23:49 UTC
Created attachment 355328 [details]
Debug output before reinstalling Fedora 11

Comment 6 Stephen Haffly 2009-07-27 23:25:21 UTC
Created attachment 355329 [details]
Debug output before reinstalling Fedora 11 but after reinstalling hplip

Comment 7 Stephen Haffly 2009-07-27 23:26:37 UTC
Created attachment 355330 [details]
Debug output after reinstalling Fedora 11 x86_64

Comment 8 Stephen Haffly 2009-07-27 23:30:50 UTC
Created attachment 355331 [details]
Foomatic log for test page

Comment 9 Stephen Haffly 2009-07-27 23:32:17 UTC
Created attachment 355332 [details]
foomatic ps for test page

Comment 10 Stephen Haffly 2009-07-27 23:33:28 UTC
Created attachment 355333 [details]
foomatic log for pdf document

Comment 11 Stephen Haffly 2009-07-27 23:34:48 UTC
Created attachment 355334 [details]
foomatic ps for pdf document

Comment 12 Stephen Haffly 2009-07-27 23:39:08 UTC
I reinstalled Fedora 11 in order to rule out the possibility that it was because of a / partition formatted ext4 that might have been causing the problem.  I reinstalled Fedora 11 x86_64 on an ext3 formatted / partition this time.  /boot and /home had already been ext3 from the prior installation.

I have attached several documents.  The debug ones were generated by the debug assistant that popped up after print jobs failed.

The foomatic ones were generated in accordance with your instructions.  I hope that one or more of these can help you to track down where duplex printing is failing.

Comment 13 Tim Waugh 2009-07-28 10:20:41 UTC
Thanks.

The problem is that hpijs is segfaulting.

Comment 14 Tim Waugh 2009-07-28 10:33:33 UTC
Seems to already be fixed in 3.9.6b.  The handling of Quality:SpeedMech was wrong when duplex was enabled.  Test update to come...

Comment 15 Tim Waugh 2009-07-28 12:06:04 UTC
You can turn off foomatic debugging now -- edit /etc/foomatic/filter.conf and remove the line 'debug: 1'.

Comment 16 Fedora Update System 2009-07-29 21:29:11 UTC
hplip-3.9.6b-3.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update hplip'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-6959

Comment 17 Stephen Haffly 2009-07-30 22:02:05 UTC
I installed the update, and it appears to be working well.  Thank you for all of your help.

I will provide feedback once I finish this update.

Comment 18 Fedora Update System 2009-08-05 00:29:28 UTC
hplip-3.9.6b-5.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update hplip'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-6959

Comment 19 Fedora Update System 2009-08-07 04:58:45 UTC
hplip-3.9.8-2.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update hplip'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-6959

Comment 20 Stephen Haffly 2009-08-11 19:18:58 UTC
With hplip-3.9.6b-5.fc11, I was able to print with no problems.

With hplip-3.9.8-2.fc11, I cannot print at all. Apparently, it and SELINUX are not getting along.  I am attaching a screen capture of the SELINUX troubleshooter.

Comment 21 Stephen Haffly 2009-08-11 19:20:12 UTC
Created attachment 357066 [details]
Screen capture of SELINUX troubleshooter

Comment 22 Stephen Haffly 2009-08-11 19:43:16 UTC
processing since
Tue 11 Aug 2009 03:39:36 PM EDT 
"/usr/lib/cups/backend/hp failed"

Additional information to the fault specified in comments 20 and 21.

It will print when I use the browser interface to CUPS to configure network printing.

It will not print via USB.

Comment 23 Tim Waugh 2009-08-12 08:58:23 UTC
That's bug #516078.

Comment 24 Fedora Update System 2009-08-15 21:42:35 UTC
hplip-3.9.8-4.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update hplip'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-6959

Comment 25 Fedora Update System 2009-08-19 23:17:43 UTC
hplip-3.9.8-6.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update hplip'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-6959

Comment 26 Fedora Update System 2009-08-25 22:13:32 UTC
hplip-3.9.8-9.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update hplip'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-6959

Comment 27 Fedora Update System 2009-08-27 02:10:46 UTC
hplip-3.9.8-10.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update hplip'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-6959

Comment 28 Fedora Update System 2009-08-28 21:57:27 UTC
hplip-3.9.8-12.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update hplip'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-6959

Comment 29 Fedora Update System 2009-08-31 23:29:58 UTC
hplip-3.9.8-12.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.