Bug 513941 - KPPP selinux output for dial-up modem
Summary: KPPP selinux output for dial-up modem
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: ppp
Version: 11
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Jiri Skala
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-07-27 08:04 UTC by Marc
Modified: 2014-11-09 22:31 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-11-24 15:53:14 UTC
Type: ---


Attachments (Terms of Use)
Selinux alert KPPP dial-up modem (2.56 KB, text/plain)
2009-07-27 08:04 UTC, Marc
no flags Details
pppd2.tdb file search (6.19 KB, text/plain)
2009-10-12 08:07 UTC, Marc
no flags Details

Description Marc 2009-07-27 08:04:23 UTC
Created attachment 355243 [details]
Selinux alert KPPP dial-up modem

When I tried to set-up a dial-up modem via KPPP, the enclosed selinux report popped-up.  The modem seems to have set-up okay (I queried the modem and it gave output), but I haven't connected to the ISP until I know what the selinux problem might be.  Enclosed is the output.

Comment 1 David Le Sage 2009-08-27 04:32:15 UTC
I can confirm that this is still happening in the Fedora 12 alpha build.

Comment 2 Jiri Skala 2009-10-08 19:43:32 UTC
Hi,
please check for /var/run/pppd2.tdb existence. Remove it if the file exists and let me know.

I was able to reproduce this bug when I've started ppp via script and then I've tried it via NetworkManager. NM failed due to pppd2.tdb existence. I've removed it. This fixed the problem. I'd like to know if I reproduced the same thing.

Thanks

Jiri

Comment 3 Marc 2009-10-09 08:02:36 UTC
Will test over the weekend and report findings next Monday.

Comment 4 Marc 2009-10-12 08:07:12 UTC
Created attachment 364439 [details]
pppd2.tdb file search

Hello,

I searched through the run folder for the pppd2.tdb file, but nothing was found (note: the ppp folder was empty).  I also did a search of the file system in case the file was elsewhere, but the search produced zero results.  I enclose a text file of a list of the contents of the run folder together with the latest output from selinux for this KPPP issue.  Could this file be somewhere I've overlooked, perhaps?

Thanks,

Marc.

Comment 5 Marc 2009-11-24 08:47:19 UTC
Hello,

I've just installed F12 (currently with no updates added) and the selinux pop-up message no longer appears.  However, what does appear when the KPPP program is opened is a warning message advising that the /etc/resolv.conf file is missing and that the system administrator needs to be advised.  Fortunately, I have a small knowledge of commands and, via root in the terminal, I was able to use the touch command (touch /etc/resolv.conf) to create the file in etc.  When I then re-opened the KPPP program, there was no /etc/resolv.conf warning message.

As I knew a little about how to create a file via root, I was able to fix the problem, but there may well be others who cannot do this, so, perhaps, this could be fixed in the next KDE network update.

Comment 6 Jiri Skala 2009-11-24 09:32:28 UTC
Thank you Marc for your information. As I wrote above I wasn't able to reproduce messaged SElinux bugs except '/var/run/pppd2.tdb existence'.

Thanks to your experience with F12 I have a question to Dan - Are you still sure that other bugs (#531374, #507103 and other) are due to fd leaking? I've changed nothing to the release because I'm not able to reproduce it and nobody tested my scratch build patched fd 'issue'.
On the contrary I don't understand users that have added to closed (duplicate) bug when the bug is closed ... 

Jiri

Comment 7 Daniel Walsh 2009-11-24 15:53:14 UTC
Lets close this bug for now and see if it reappears.


Note You need to log in before you can comment on or make changes to this bug.