Bug 51398 - OV511+ webcam not working after upgrading to 2.4.3-12
OV511+ webcam not working after upgrading to 2.4.3-12
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Pete Zaitcev
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2001-08-10 02:17 EDT by Frank Bodewes
Modified: 2007-04-18 12:35 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-10-08 14:12:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Fix for xawtv/webcam for USB cameras (439 bytes, patch)
2001-08-16 13:35 EDT, Pete Zaitcev
no flags Details | Diff
Cusomer example (local copy) (147.86 KB, image/jpeg)
2001-08-19 00:41 EDT, Pete Zaitcev
no flags Details
Bad colors at the start of a sequence (17.33 KB, image/jpeg)
2001-08-19 00:42 EDT, Pete Zaitcev
no flags Details
Possibly relevant differences (59.01 KB, patch)
2001-08-19 00:51 EDT, Pete Zaitcev
no flags Details | Diff
copy of /proc/bus/usb/devices (1.50 KB, text/plain)
2001-08-19 04:01 EDT, Frank Bodewes
no flags Details
copy of .webcamrc (354 bytes, text/plain)
2001-08-19 04:06 EDT, Frank Bodewes
no flags Details
ISO alignment for 32 in ohci (766 bytes, patch)
2001-08-19 14:30 EDT, Pete Zaitcev
no flags Details | Diff

  None (edit)
Description Frank Bodewes 2001-08-10 02:17:29 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98)

Description of problem:
Used a OV511+ USB webcam with RH7.1 on kernel 2.4.2-2. This works OK. 
After upgrading my kernel with up2date to 2.4.3-12, the webcam is still 
recognized, but gives only blackish and greenish blocked images, not 
related to anything the camera sees.

How reproducible:

Steps to Reproduce:
1. Reboot system
2. Select old kernel in Lilo (2.4.2-2)
3. Webcam is working
4. Reboot system
5. Select new kernel in Lilo (2.4.3-12)
6. Webcam gives no images

Actual Results:  During bootup there seems to be no difference in the 
loading of modules (usb, usb-ohci, hub and ov511), but when an image is 
captured when booted the 2.4.2-2 kernel I get quite nice images and when 
an image is captured when booting the 2.4.3-12 kernel, I get blocked 
images (black/green). These blocked images do not seem to have any 
relation to what the camera sees (totally black or a lot of light keep 
generating the same blocked images).

Expected Results:  The cam should be working also in kernel 2.4.3-12

Additional info:

Using a P200MMX without a USB controller on-board. Using a PCI-USB 
controller (Sitecom) based on a OPti-chip. Using two PCI-NIC's. Both the 
NIC's and the USB-controller share the same interrupt, but both NIC's are 
working OK.
Comment 1 Pete Zaitcev 2001-08-10 17:20:29 EDT
Please tell what webcam software is used.
Xawtv in particular is troublesome, I have
to run patched versions with bigger initial sync timeout.
By a miracle it works with some kernel versions.
Comment 2 Frank Bodewes 2001-08-11 15:28:38 EDT
I use the 'webcam' software which is included in the xawtv-package.
Comment 3 Pete Zaitcev 2001-08-16 13:35:03 EDT
Created attachment 28153 [details]
Fix for xawtv/webcam for USB cameras
Comment 4 Pete Zaitcev 2001-08-16 13:52:49 EDT
Oops, please ignore that attachement. Kraxel had it
integrated into current xawtv (I just checked the
SRPM in 7.2 tree - pure xawtv-3.54).
Comment 5 Frank Bodewes 2001-08-16 17:35:13 EDT
I upgraded to xawtv-3.54-2 (it did cost me quite some time to find that rpm. 
What is the usual place to find things like this? - I'm quite a newbie), but 
the result is still the same. You can take a look at:
to see a sample image.
Comment 6 Frank Bodewes 2001-08-17 02:32:44 EDT
My feeling is that is has something to do with the USB or OV511 part....
I made three other pictures to do some comparison: 
2.4.2-2 kernel xawtv 3.54-2)
2.4.2-2 kernel xawtv 3.54-4)
2.4.3-12 kernel xawtv 3.54-4)
In the latest picture, you could still see some correct info (if you look 

Comment 7 Pete Zaitcev 2001-08-19 00:23:41 EDT
I cannot reproduce the blocky effect so far,
but the image is incorrectly green for 2.4.3-12.
Something is fishy - investigating.

The block effect looks like a compression
(which, naturally, is not supported by Linux).
Perhaps 2.4.3-12 initializes more (or less),
and trips a compression mode in the particular webcam.

Requestor please attach a copy of /proc/bus/usb/devices.
Comment 8 Pete Zaitcev 2001-08-19 00:40:47 EDT
OK. The green hue disappears if webcam runs for
a few frames. I saw that effect before and it
seems unrelated.

640x480 works.

I would like to see .webcamrc (don't forget to
remove any FTP passowrds) - in addition to /proc/bus/usb/devices.
Comment 9 Pete Zaitcev 2001-08-19 00:41:57 EDT
Created attachment 28394 [details]
Cusomer example (local copy)
Comment 10 Pete Zaitcev 2001-08-19 00:42:58 EDT
Created attachment 28395 [details]
Bad colors at the start of a sequence
Comment 11 Pete Zaitcev 2001-08-19 00:47:32 EDT
Differences from customer config (test rig at Cheasapike)
 1. IRQ not shared
 2. UHCI instead of OHCI
P6/233MMX SMP - same
Comment 12 Pete Zaitcev 2001-08-19 00:51:36 EDT
Created attachment 28396 [details]
Possibly relevant differences
Comment 13 Frank Bodewes 2001-08-19 04:01:22 EDT
Created attachment 28402 [details]
copy of /proc/bus/usb/devices
Comment 14 Frank Bodewes 2001-08-19 04:06:57 EDT
Created attachment 28403 [details]
copy of .webcamrc
Comment 15 Frank Bodewes 2001-08-19 04:09:16 EDT
Hmm, might be of influence: I did not mention the type of webcam before. It is 
a Trust webc@m 300.
Comment 16 Pete Zaitcev 2001-08-19 12:31:46 EDT
Can you do self-compiled kernels with changes for testing,
or do you need a binary RPM?
Comment 17 Pete Zaitcev 2001-08-19 14:30:23 EDT
Created attachment 28418 [details]
ISO alignment for 32 in ohci
Comment 18 Pete Zaitcev 2001-08-19 14:32:36 EDT
Current hypotesis: shift from virt_to_bus to proper PCI macros
uncovered an alignment problem in ohci. The spec says ISO TDs
must be aligned on 32 (all other TDs are aligned on 16).
Comment 19 Frank Bodewes 2001-08-19 17:44:59 EDT
Hmm, having troubles compiling modules, kernel compiles OK, RPM would be easy
Comment 20 Pete Zaitcev 2001-08-24 17:16:50 EDT
Can you try kernel-2.4.7-2.i386.rpm from ftp.redhat.com,
/pub/redhat/linux/rawhide/i386/RedHat/RPMS ?
Comment 21 Pete Zaitcev 2001-09-14 21:01:00 EDT
Frank, I'm needinfo-ing the bug because I am waiting the report
of Rawhide's kernel from you.
Comment 22 Frank Bodewes 2001-10-07 15:59:41 EDT
Sorry for not replying earlier, I have been on quite a long holiday in the 
outback of Australia and I haven't seen a computer for quite a while.......

I tried to find kernel-2.4.7-2.i386.rpm, but I only found kernel-2.4.9-
0.18.i386.rpm. I tried to install, but it failed some dependecies. Should I try 
the 2.4.9 version (and resolve the dependencies) or should I try to get the 
2.4.7 version?
Comment 23 Pete Zaitcev 2001-10-07 17:31:32 EDT
Force the installation on 2.4.9. It must not harm your existing
kernels anyways. The rpm install only stores it into /boot and
/lib/modules. After than you add it to /etc/lilo.conf manually.
The only danger is to make sure you do not run out of space
in /boot.
Comment 24 Frank Bodewes 2001-10-08 14:12:07 EDT

The webcam is working with the new kernel! Thanks for your patience and 
support. Do you know wat caused the problem?

Comment 25 Pete Zaitcev 2001-10-08 14:24:37 EDT
The attached fix for ISO alignment was integrated into
mainstream Linux.

Taking the latest Rawhide was a testing action.
Officially we suggest to use RHN and up2date to fetch
latest kernels for the supported distribution.
The latest 7.1 update today is still 2.4.3-12,
so you either have to wait until a 2.4.7 based update
rolls out for 7.1, or take rawhide, or download 2.4.3-12
SRPM, apply the fix usb.243-12.iso_align.diff,
and recompile. Most of the users prefer not to bother with
recompiles and wait for updates.

Note You need to log in before you can comment on or make changes to this bug.