Bug 514000 - Aureon 5.1 MkII can't do 5.1 anymore
Aureon 5.1 MkII can't do 5.1 anymore
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: alsa-lib (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Jaroslav Kysela
Fedora Extras Quality Assurance
: Regression, Reopened
Depends On:
Blocks: F12Target
  Show dependency treegraph
 
Reported: 2009-07-27 11:41 EDT by Bastien Nocera
Modified: 2010-01-26 05:39 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-26 05:39:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
pulseaudio-aureon-log.txt (127.65 KB, text/plain)
2009-08-03 09:38 EDT, Bastien Nocera
no flags Details
pulseaudio -vvvvv (143.07 KB, text/plain)
2009-10-12 01:52 EDT, Michal Hlavinka
no flags Details
gnome-volume-control screenshot (47.71 KB, image/png)
2009-10-12 01:53 EDT, Michal Hlavinka
no flags Details
pavucontrol screenshot (27.94 KB, image/png)
2009-10-12 01:55 EDT, Michal Hlavinka
no flags Details
output of alsa-info (25.48 KB, text/plain)
2009-10-13 14:05 EDT, Michal Hlavinka
no flags Details

  None (edit)
Description Bastien Nocera 2009-07-27 11:41:46 EDT
On pulseaudio-0.9.16-2.test2.fc12.i586:

    index: 1
	name: <alsa_card.usb-0ccd_USB_Audio-00>
	driver: <module-alsa-card.c>
	owner module: 18
	properties:
		alsa.card = "1"
		alsa.card_name = "Aureon5.1MkII"
		alsa.long_card_name = "TerraTec Aureon5.1MkII at usb-0000:00:1d.2-1, full speed"
		alsa.driver_name = "snd_usb_audio"
		device.bus_path = "pci-0000:00:1d.2-usb-0:1:1.0"
		sysfs.path = "/devices/pci0000:00/0000:00:1d.2/usb4/4-1/4-1:1.0/sound/card1"
		udev.id = "usb-0ccd_USB_Audio-00"
		device.bus = "usb"
		device.vendor.id = "0ccd"
		device.vendor.name = "TerraTec Electronic GmbH"
		device.product.id = "0028"
		device.product.name = "Aureon 5.1 MkII"
		device.serial = "0ccd_USB_Audio"
		device.string = "1"
		device.description = "Aureon 5.1 MkII"
		module-udev-detect.discovered = "1"
		device.icon_name = "audio-card-usb"
	profiles:
		output:analog-stereo: Analog Stereo Output (priority 501000)
		output:analog-stereo+input:analog-stereo: Analog Stereo Duplex (priority 506010)
		input:analog-stereo: Analog Stereo Input (priority 5010)
		off: Off (priority 0)
	active profile: <output:analog-stereo+input:analog-stereo>
	sinks:
		alsa_output.usb-0ccd_USB_Audio-00.analog-stereo/#1: Aureon 5.1 MkII Analog Stereo
	sources:
		alsa_output.usb-0ccd_USB_Audio-00.analog-stereo.monitor/#2: Monitor of Aureon 5.1 MkII Analog Stereo
		alsa_input.usb-0ccd_USB_Audio-00.analog-stereo/#3: Aureon 5.1 MkII Analog Stereo

On pulseaudio-0.9.15-14.fc11.x86_64:
    index: 7
	name: <alsa_card.usb_device_ccd_28_noserial_if0_sound_card_0>
	driver: <module-alsa-card.c>
	owner module: 28
	properties:
		alsa.card = "2"
		alsa.card_name = "USB Audio"
		alsa.long_card_name = "USB Audio at usb-0000:00:1d.7-1.3, full speed"
		alsa.driver_name = "snd_usb_audio"
		device.bus = "usb"
		device.vendor.id = "0ccd"
		device.vendor.name = "TerraTec Electronic GmbH"
		device.product.id = "0028"
		device.product.name = "Aureon 5.1 MkII"
		device.serial = "0ccd_USB_Audio"
		device.bus_path = "/devices/pci0000:00/0000:00:1d.7/usb1/1-1/1-1.3/1-1.3:1.0/sound/card2"
		hal.udi = "/org/freedesktop/Hal/devices/usb_device_ccd_28_noserial_if0_sound_card_0"
		hal.product = "USB Audio Sound Card"
		hal.card_id = "USB Audio"
		device.string = "2"
		device.description = "Aureon 5.1 MkII"
		device.icon_name = "audio-card-usb"
	profiles:
		output-analog-stereo+input-analog-stereo: Output Analog Stereo + Input Analog Stereo (priority 81010)
		output-analog-stereo+input-iec958-stereo: Output Analog Stereo + Input Digital Stereo (IEC958) (priority 81005)
		output-analog-stereo: Output Analog Stereo (priority 51000)
		output-iec958-stereo+input-analog-stereo: Output Digital Stereo (IEC958) + Input Analog Stereo (priority 80510)
		output-iec958-stereo+input-iec958-stereo: Output Digital Stereo (IEC958) + Input Digital Stereo (IEC958) (priority 80505)
		output-iec958-stereo: Output Digital Stereo (IEC958) (priority 50500)
		output-analog-surround-41+input-analog-stereo: Output Analog Surround 4.1 + Input Analog Stereo (priority 30710)
		output-analog-surround-41+input-iec958-stereo: Output Analog Surround 4.1 + Input Digital Stereo (IEC958) (priority 30705)
		output-analog-surround-41: Output Analog Surround 4.1 (priority 700)
		output-analog-surround-50+input-analog-stereo: Output Analog Surround 5.0 + Input Analog Stereo (priority 30710)
		output-analog-surround-50+input-iec958-stereo: Output Analog Surround 5.0 + Input Digital Stereo (IEC958) (priority 30705)
		output-analog-surround-50: Output Analog Surround 5.0 (priority 700)
		output-analog-surround-51+input-analog-stereo: Output Analog Surround 5.1 + Input Analog Stereo (priority 30810)
		output-analog-surround-51+input-iec958-stereo: Output Analog Surround 5.1 + Input Digital Stereo (IEC958) (priority 30805)
		output-analog-surround-51: Output Analog Surround 5.1 (priority 800)
		input-analog-stereo: Input Analog Stereo (priority 30010)
		input-iec958-stereo: Input Digital Stereo (IEC958) (priority 30005)
		off: Off (priority 0)
	active profile: <output-analog-surround-51+input-analog-stereo>
	sinks:
		alsa_output.usb_device_ccd_28_noserial_if0_sound_card_0/#7: Aureon 5.1 MkII
	sources:
		alsa_output.usb_device_ccd_28_noserial_if0_sound_card_0.monitor/#29: Monitor of Aureon 5.1 MkII
		alsa_input.usb_device_ccd_28_noserial_if0_sound_card_0/#30: Aureon 5.1 MkII
Comment 1 Lennart Poettering 2009-07-27 19:15:50 EDT
Please provide output of pulseaudio -vvvvv when the detection of the profiles fail.
Comment 2 Bastien Nocera 2009-08-03 09:38:40 EDT
Created attachment 356026 [details]
pulseaudio-aureon-log.txt

with kernel-2.6.31-0.118.rc5.fc12.i686
Comment 3 Lennart Poettering 2009-08-03 15:09:25 EDT
Smells as if your alsa-lib userspace wouldn't match the kernel
Comment 4 Bastien Nocera 2009-08-04 09:47:57 EDT
Upgraded alsa-lib, and it doesn't fix it.
Comment 5 Lennart Poettering 2009-08-04 10:29:43 EDT
Hmm, does "aplay -D plug:surround51:0 -f CD < /dev/urandom" work?
Comment 6 Bastien Nocera 2009-08-05 09:13:41 EDT
used :1, otherwise it would have played on the internal card, and it works fine:

$ aplay -D plug:surround51:1 -f CD < /dev/urandom
Playing raw data 'stdin' : Signed 16 bit Little Endian, Rate 44100 Hz, Stereo
(white noise on all 5 speakers)

Tested with:
alsa-lib-1.0.20-2.fc12.i686
kernel-2.6.31-0.125.rc5.git2.fc12.i686
pulseaudio-0.9.16-5.test4.fc12.i686
Comment 7 Lennart Poettering 2009-08-07 20:33:00 EDT
Basten, which udev version is this? We need udev-145-3 at least.
Comment 8 Lennart Poettering 2009-08-07 20:34:24 EDT
next version in rawhide will make that dep on udev-145-3 explicit.
Comment 9 Lennart Poettering 2009-08-13 10:46:31 EDT
So you say you have alsa, udev and the kernel fully upgraded?

Will assign to alsa-lib then, since on your machine opening surround51:xxx for the card results in a device that doesn't accept 6ch, which makes no sense.

The interesting log output is this:

D: alsa-util.c: Trying surround51:0 with SND_PCM_NO_AUTO_FORMAT ...
D: alsa-util.c: Managed to open surround51:0
D: alsa-util.c: snd_pcm_hw_params_set_channels(6) failed: Invalid argument

Opening surround51:0 must result in a snd_pcm_t that accepts 6 channels. If it doesn't the mapping is broken in ALSA.
Comment 10 Bastien Nocera 2009-09-09 10:54:27 EDT
Now on my main desktop:

alsa-lib-1.0.21-1.fc12.i686
pulseaudio-0.9.16-13.test7.fc12.x86_64
udev-145-7.fc12.x86_64
kernel 2.6.31-0.204.rc9.fc12.x86_64

pacmd output:
   index: 0
	name: <alsa_card.usb-0ccd_USB_Audio-00>
	driver: <module-alsa-card.c>
	owner module: 4
	properties:
		alsa.card = "2"
		alsa.card_name = "Aureon5.1MkII"
		alsa.long_card_name = "TerraTec Aureon5.1MkII at usb-0000:00:1d.7-1.3, full speed"
		alsa.driver_name = "snd_usb_audio"
		device.bus_path = "pci-0000:00:1d.7-usb-0:1.3:1.0"
		sysfs.path = "/devices/pci0000:00/0000:00:1d.7/usb1/1-1/1-1.3/1-1.3:1.0/sound/card2"
		udev.id = "usb-0ccd_USB_Audio-00"
		device.bus = "usb"
		device.vendor.id = "0ccd"
		device.vendor.name = "TerraTec Electronic GmbH"
		device.product.id = "0028"
		device.product.name = "Aureon 5.1 MkII"
		device.serial = "0ccd_USB_Audio"
		device.string = "2"
		device.description = "Aureon 5.1 MkII"
		module-udev-detect.discovered = "1"
		device.icon_name = "audio-card-usb"
	profiles:
		output:analog-stereo: Analog Stereo Output (priority 6000)
		output:analog-stereo+input:analog-stereo: Analog Stereo Duplex (priority 6060)
		input:analog-stereo: Analog Stereo Input (priority 60)
		off: Off (priority 0)
	active profile: <output:analog-stereo+input:analog-stereo>
	sinks:
		alsa_output.usb-0ccd_USB_Audio-00.analog-stereo/#0: Aureon 5.1 MkII Analog Stereo
	sources:
		alsa_output.usb-0ccd_USB_Audio-00.analog-stereo.monitor/#0: Monitor of Aureon 5.1 MkII Analog Stereo
		alsa_input.usb-0ccd_USB_Audio-00.analog-stereo/#1: Aureon 5.1 MkII Analog Stereo

Still no 5.1

$ cat /proc/asound/cards 
 0 [Q9000          ]: USB-Audio - QuickCam Pro 9000
                      Logitech, Inc. QuickCam Pro 9000 at usb-0000:00:1d.7-2, high speed
 1 [ICH7           ]: ICH4 - Intel ICH7
                      Intel ICH7 with AD1981B at irq 23
 2 [Aureon51MkII   ]: USB-Audio - Aureon5.1MkII
                      TerraTec Aureon5.1MkII at usb-0000:00:1d.7-1.3, full speed

$ aplay -D plug:surround51:2 -f CD < /dev/urandom
ALSA lib conf.c:4626:(snd_config_expand) Expand error (walk): File exists
ALSA lib confmisc.c:1286:(snd_func_refer) Unable to find definition 'cards.USB-Audio.pcm.surround51.0:CARD=2'
ALSA lib conf.c:4153:(_snd_config_evaluate) function snd_func_refer returned error: No such file or directory
ALSA lib conf.c:4632:(snd_config_expand) Evaluate error: No such file or directory
ALSA lib pcm.c:2211:(snd_pcm_open_noupdate) Unknown PCM surround51:2
aplay: main:608: audio open error: No such file or directory
Comment 11 Jaroslav Kysela 2009-09-09 12:02:47 EDT
(In reply to comment #10)
> Now on my main desktop:
> 
> alsa-lib-1.0.21-1.fc12.i686

...

> ALSA lib pcm.c:2211:(snd_pcm_open_noupdate) Unknown PCM surround51:2
> aplay: main:608: audio open error: No such file or directory  

This bug is fixed in alsa-lib-1.0.21-3.fc12 package.
Comment 12 Bastien Nocera 2009-09-09 13:36:14 EDT
Update alsa-lib, but it still doesn't list 5.1 as an option (at least it has 5.0 and 4.1 outputs):
    index: 0
	name: <alsa_card.usb-0ccd_USB_Audio-00>
	driver: <module-alsa-card.c>
	owner module: 4
	properties:
		alsa.card = "2"
		alsa.card_name = "Aureon5.1MkII"
		alsa.long_card_name = "TerraTec Aureon5.1MkII at usb-0000:00:1d.7-1.3, full speed"
		alsa.driver_name = "snd_usb_audio"
		device.bus_path = "pci-0000:00:1d.7-usb-0:1.3:1.0"
		sysfs.path = "/devices/pci0000:00/0000:00:1d.7/usb1/1-1/1-1.3/1-1.3:1.0/sound/card2"
		udev.id = "usb-0ccd_USB_Audio-00"
		device.bus = "usb"
		device.vendor.id = "0ccd"
		device.vendor.name = "TerraTec Electronic GmbH"
		device.product.id = "0028"
		device.product.name = "Aureon 5.1 MkII"
		device.serial = "0ccd_USB_Audio"
		device.string = "2"
		device.description = "Aureon 5.1 MkII"
		module-udev-detect.discovered = "1"
		device.icon_name = "audio-card-usb"
	profiles:
		output:analog-stereo: Analog Stereo Output (priority 6000)
		output:analog-stereo+input:analog-stereo: Analog Stereo Duplex (priority 6060)
		output:analog-stereo+input:iec958-stereo: Analog Stereo Output + Digital Stereo (IEC958) Input (priority 6055)
		output:analog-surround-41: Analog Surround 4.1 Output (priority 800)
		output:analog-surround-41+input:analog-stereo: Analog Surround 4.1 Output + Analog Stereo Input (priority 860)
		output:analog-surround-41+input:iec958-stereo: Analog Surround 4.1 Output + Digital Stereo (IEC958) Input (priority 855)
		output:analog-surround-50: Analog Surround 5.0 Output (priority 700)
		output:analog-surround-50+input:analog-stereo: Analog Surround 5.0 Output + Analog Stereo Input (priority 760)
		output:analog-surround-50+input:iec958-stereo: Analog Surround 5.0 Output + Digital Stereo (IEC958) Input (priority 755)
		output:analog-surround-51: Analog Surround 5.1 Output (priority 800)
		output:analog-surround-51+input:analog-stereo: Analog Surround 5.1 Output + Analog Stereo Input (priority 860)
		output:analog-surround-51+input:iec958-stereo: Analog Surround 5.1 Output + Digital Stereo (IEC958) Input (priority 855)
		output:iec958-stereo: Digital Stereo Duplex (IEC958) (priority 5500)
		output:iec958-stereo+input:analog-stereo: Digital Stereo (IEC958) Output + Analog Stereo Input (priority 5560)
		output:iec958-stereo+input:iec958-stereo: Digital Stereo (IEC958) Output + Digital Stereo (IEC958) Input (priority 5555)
		input:analog-stereo: Analog Stereo Input (priority 60)
		input:iec958-stereo: Digital Stereo (IEC958) Input (priority 55)
		off: Off (priority 0)
	active profile: <output:analog-surround-50+input:iec958-stereo>
	sinks:
		alsa_output.usb-0ccd_USB_Audio-00.analog-surround-50/#0: Aureon 5.1 MkII Analog Surround 5.0
	sources:
		alsa_output.usb-0ccd_USB_Audio-00.analog-surround-50.monitor/#0: Monitor of Aureon 5.1 MkII Analog Surround 5.0
		alsa_input.usb-0ccd_USB_Audio-00.iec958-stereo/#3: Aureon 5.1 MkII Digital Stereo (IEC958)

This works:
$ aplay -D plug:surround51:2 -f CD < /dev/urandom
Comment 13 Lennart Poettering 2009-09-09 17:08:54 EDT
(In reply to comment #12)
> Update alsa-lib, but it still doesn't list 5.1 as an option (at least it has
> 5.0 and 4.1 outputs):

It does! 

>   output:analog-surround-51: Analog Surround 5.1 Output (priority 800)
>   output:analog-surround-51+input:analog-stereo: Analog Surround 5.1 Output +
> Analog Stereo Input (priority 860)
>   output:analog-surround-51+input:iec958-stereo: Analog Surround 5.1 Output +
> Digital Stereo (IEC958) Input (priority 855)

These are the 5.1 profiles. You get 5.1 out, 5.1 out plus 2.0 in, and 5.1 out plus spdif in. Looks complete to me.
Comment 14 Bastien Nocera 2009-09-09 21:05:45 EDT
Duh, yes. I guess I was using a broken tool to see if it was available...

pavucontrol didn't list the 5.1 output, but gnome-volume-control did. Selecting 5.1 in gnome-volume-control and launching pavucontrol gets me an empty drop-down entry.

pavucontrol-0.9.8-1.fc11.x86_64

pavucontrol-0.9.9-0.test1.fc12.1 fixed this, so closing.
Comment 15 Michal Hlavinka 2009-10-12 01:51:31 EDT
I can reproduce this *sometimes* with:
rpm -qa | grep -i -e pulse -e alsa :
alsa-lib-1.0.21-3.fc12.x86_64
xine-lib-pulseaudio-1.1.16.3-4.fc12.x86_64
pulseaudio-module-x11-0.9.19-1.fc12.x86_64
alsa-plugins-pulseaudio-1.0.21-2.fc12.i686
pulseaudio-libs-0.9.19-1.fc12.x86_64
pulseaudio-libs-glib2-0.9.19-1.fc12.x86_64
pulseaudio-0.9.19-1.fc12.x86_64
alsa-utils-1.0.21-2.fc12.x86_64
alsa-lib-1.0.21-3.fc12.i686
pulseaudio-utils-0.9.19-1.fc12.x86_64
pulseaudio-module-bluetooth-0.9.19-1.fc12.x86_64
kde-settings-pulseaudio-4.3-10.1.noarch
alsa-plugins-pulseaudio-1.0.21-2.fc12.x86_64
pulseaudio-libs-0.9.19-1.fc12.i686

sometimes all profiles are listed, but sometimes only stereo is listed
Comment 16 Michal Hlavinka 2009-10-12 01:52:26 EDT
Created attachment 364421 [details]
pulseaudio -vvvvv
Comment 17 Michal Hlavinka 2009-10-12 01:53:18 EDT
Created attachment 364422 [details]
gnome-volume-control screenshot
Comment 18 Michal Hlavinka 2009-10-12 01:55:20 EDT
Created attachment 364424 [details]
pavucontrol screenshot
Comment 19 Michal Hlavinka 2009-10-12 02:00:13 EDT
the log in comment #16 is from situation when this happend:
(pulseaudio -k)
pulseaudio -vvvvv 2>&1 | tee pulse.log
plug in usb sound card
start pavucontrol
Comment 20 Lennart Poettering 2009-10-12 18:24:08 EDT
The interesting lines are this ones:

D: alsa-mixer.c: Looking at profile output:analog-surround-51
D: alsa-mixer.c: Checking for playback on Analog Surround 5.1 (analog-surround-51)
D: alsa-util.c: Trying surround51:1 with SND_PCM_NO_AUTO_FORMAT ...
I: (alsa-lib)confmisc.c: Unable to find definition 'cards.USB-Audio.pcm.surround51.0:CARD=1'
I: (alsa-lib)conf.c: function snd_func_refer returned error: No such file or directory
I: (alsa-lib)conf.c: Evaluate error: No such file or directory
I: (alsa-lib)pcm.c: Unknown PCM surround51:1
I: alsa-util.c: Error opening PCM device surround51:1: No such file or directory

So the problem seems to be that the alsa config is incomplete?

Raassigning to alsa-libs.
Comment 21 Jaroslav Kysela 2009-10-13 03:50:30 EDT
Could you attach output from 'alsa-info.sh --no-upload' when things does not work?
Comment 22 Michal Hlavinka 2009-10-13 14:05:05 EDT
Created attachment 364631 [details]
output of alsa-info
Comment 23 Adam Williamson 2009-10-23 12:31:11 EDT
This bug was discussed at the blocker review meeting today. We felt it wasn't severe enough to be worth holding up the release for, hence dropping it to F12Target. If it's not fixed by release time it will be documented in Common Bugs. Bastien, if you really feel it should be a blocker please add it back to the list and we'll ask you into the next review meeting to discuss it.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 24 Bastien Nocera 2010-01-26 05:39:53 EST
It's working fine now. If people still see this bug, please file a separate one.

Note You need to log in before you can comment on or make changes to this bug.