Bug 514086 - ACLs need to be touched for controlC device last
ACLs need to be touched for controlC device last
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: udev (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 513714
  Show dependency treegraph
 
Reported: 2009-07-27 19:06 EDT by Lennart Poettering
Modified: 2009-07-29 08:17 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-29 08:17:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Lennart Poettering 2009-07-27 19:06:43 EDT
udev-acl should touch the ACLs for controlC devices last.

This patch fixes the problem:

http://0pointer.de/public/0001-enumeration-move-ALSA-control-devices-to-the-end-of-.patch

The patch is a result of a discussion with Kay. He didn't bless the patch itself yet but he did bless the general approach. Would be good if this could be merged into udev before the F12 alpha freeze, because otherwise we have broken ACL handling for audio.
Comment 1 Lennart Poettering 2009-07-27 21:17:08 EDT
patch now blessed by kay and commited to upstream git.
Comment 3 Harald Hoyer 2009-07-29 08:17:30 EDT
built udev-145-3.fc12

Note You need to log in before you can comment on or make changes to this bug.