This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 514097 - Audio does not work after update
Audio does not work after update
Status: CLOSED DUPLICATE of bug 506075
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
11
i686 Linux
low Severity high
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-27 20:20 EDT by N Coghill
Modified: 2009-07-29 10:41 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-29 10:41:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description N Coghill 2009-07-27 20:20:03 EDT
After the last update the audio no longer works properly.  Music in Rhythmbox or Movie Player plays for a few seconds and then cuts out.  The volume control in Movie player becomes grayed out with an "x" when the audio cuts out  .The volume control in GNOME does nothing at all.

The sound card is a Realtek AC97 onboard (nVidia nForce2) and it is the only sound card installed.  Removing alsa-plugins-pulseaudio seems to solve the playback problem, but the volume control in GNOME still does not work.
Comment 1 Lennart Poettering 2009-07-28 09:21:52 EDT
This sounds as if PA was quitting due to a driver problem. Please check syslog for any output related to pulseaudio!
Comment 2 N Coghill 2009-07-28 23:39:46 EDT
This is in the messages file.


Jul 28 20:33:46 nick-comp pulseaudio[2132]: alsa-sink.c: Increasing wakeup watermark to 30.00 ms
Jul 28 20:33:46 nick-comp pulseaudio[2132]: alsa-util.c: snd_pcm_avail() returned a value that is exceptionally large: 4294958108 bytes (24347835 ms).
Jul 28 20:33:46 nick-comp pulseaudio[2132]: alsa-util.c: Most likely this is a bug in the ALSA driver 'snd_intel8x0'. Please report this issue to the ALSA developers.
Jul 28 20:33:46 nick-comp pulseaudio[2132]: alsa-util.c: snd_pcm_dump():
Jul 28 20:33:46 nick-comp pulseaudio[2132]: alsa-util.c: Hardware PCM card 0 'NVidia nForce2' device 0 subdevice 0
Jul 28 20:33:46 nick-comp pulseaudio[2132]: alsa-util.c: Its setup is:
Jul 28 20:33:46 nick-comp pulseaudio[2132]: alsa-util.c:   stream       : PLAYBACK
Jul 28 20:33:46 nick-comp pulseaudio[2132]: alsa-util.c:   access       : MMAP_INTERLEAVED
Jul 28 20:33:46 nick-comp pulseaudio[2132]: alsa-util.c:   format       : S16_LE
Jul 28 20:33:46 nick-comp pulseaudio[2132]: alsa-util.c:   subformat    : STD
Jul 28 20:33:46 nick-comp pulseaudio[2132]: alsa-util.c:   channels     : 2
Jul 28 20:33:46 nick-comp pulseaudio[2132]: alsa-util.c:   rate         : 44100
Jul 28 20:33:46 nick-comp pulseaudio[2132]: alsa-util.c:   exact rate   : 44100 (44100/1)
Jul 28 20:33:46 nick-comp pulseaudio[2132]: alsa-util.c:   msbits       : 16
Jul 28 20:33:46 nick-comp pulseaudio[2132]: alsa-util.c:   buffer_size  : 16384
Jul 28 20:33:46 nick-comp pulseaudio[2132]: alsa-util.c:   period_size  : 16384
Jul 28 20:33:46 nick-comp pulseaudio[2132]: alsa-util.c:   period_time  : 371519
Jul 28 20:33:46 nick-comp pulseaudio[2132]: alsa-util.c:   tstamp_mode  : ENABLE
Jul 28 20:33:46 nick-comp pulseaudio[2132]: alsa-util.c:   period_step  : 1
Jul 28 20:33:46 nick-comp pulseaudio[2132]: alsa-util.c:   avail_min    : 16384
Jul 28 20:33:46 nick-comp pulseaudio[2132]: alsa-util.c:   period_event : 0
Jul 28 20:33:46 nick-comp pulseaudio[2132]: alsa-util.c:   start_threshold  : -1
Jul 28 20:33:46 nick-comp pulseaudio[2132]: alsa-util.c:   stop_threshold   : 1073741824
Jul 28 20:33:46 nick-comp pulseaudio[2132]: alsa-util.c:   silence_threshold: 0
Jul 28 20:33:46 nick-comp pulseaudio[2132]: alsa-util.c:   silence_size : 0
Jul 28 20:33:46 nick-comp pulseaudio[2132]: alsa-util.c:   boundary     : 1073741824
Jul 28 20:33:46 nick-comp pulseaudio[2132]: alsa-util.c:   appl_ptr     : 2492665
Jul 28 20:33:46 nick-comp pulseaudio[2132]: alsa-util.c:   hw_ptr       : 2473984
Jul 28 20:33:46 nick-comp pulseaudio[2132]: alsa-util.c: snd_pcm_delay() returned a value that is exceptionally large: 386004 bytes (2188 ms).
Jul 28 20:33:46 nick-comp pulseaudio[2132]: alsa-util.c: Most likely this is a bug in the ALSA driver 'snd_intel8x0'. Please report this issue to the ALSA developers.
Jul 28 20:33:46 nick-comp pulseaudio[2132]: alsa-util.c: snd_pcm_dump():
Jul 28 20:33:46 nick-comp pulseaudio[2132]: alsa-util.c: Hardware PCM card 0 'NVidia nForce2' device 0 subdevice 0
Jul 28 20:33:46 nick-comp pulseaudio[2132]: alsa-util.c: Its setup is:
Jul 28 20:33:46 nick-comp pulseaudio[2132]: alsa-util.c:   stream       : PLAYBACK
Jul 28 20:33:46 nick-comp pulseaudio[2132]: alsa-util.c:   access       : MMAP_INTERLEAVED
Jul 28 20:33:46 nick-comp pulseaudio[2132]: alsa-util.c:   format       : S16_LE
Jul 28 20:33:46 nick-comp pulseaudio[2132]: alsa-util.c:   subformat    : STD
Jul 28 20:33:46 nick-comp pulseaudio[2132]: alsa-util.c:   channels     : 2
Jul 28 20:33:46 nick-comp pulseaudio[2132]: alsa-util.c:   rate         : 44100
Jul 28 20:33:46 nick-comp pulseaudio[2132]: alsa-util.c:   exact rate   : 44100 (44100/1)
Jul 28 20:33:46 nick-comp pulseaudio[2132]: alsa-util.c:   msbits       : 16
Jul 28 20:33:46 nick-comp pulseaudio[2132]: alsa-util.c:   buffer_size  : 16384
Jul 28 20:33:46 nick-comp pulseaudio[2132]: alsa-util.c:   period_size  : 16384
Jul 28 20:33:46 nick-comp pulseaudio[2132]: alsa-util.c:   period_time  : 371519
Jul 28 20:33:46 nick-comp pulseaudio[2132]: alsa-util.c:   tstamp_mode  : ENABLE
Jul 28 20:33:46 nick-comp pulseaudio[2132]: alsa-util.c:   period_step  : 1
Jul 28 20:33:46 nick-comp pulseaudio[2132]: alsa-util.c:   avail_min    : 16384
Jul 28 20:33:46 nick-comp pulseaudio[2132]: alsa-util.c:   period_event : 0
Jul 28 20:33:46 nick-comp pulseaudio[2132]: alsa-util.c:   start_threshold  : -1
Jul 28 20:33:46 nick-comp pulseaudio[2132]: alsa-util.c:   stop_threshold   : 1073741824
Jul 28 20:33:46 nick-comp pulseaudio[2132]: alsa-util.c:   silence_threshold: 0
Jul 28 20:33:46 nick-comp pulseaudio[2132]: alsa-util.c:   silence_size : 0
Jul 28 20:33:46 nick-comp pulseaudio[2132]: alsa-util.c:   boundary     : 1073741824
Jul 28 20:33:46 nick-comp pulseaudio[2132]: alsa-util.c:   appl_ptr     : 2572045
Jul 28 20:33:46 nick-comp pulseaudio[2132]: alsa-util.c:   hw_ptr       : 2475544
Jul 28 20:33:51 nick-comp pulseaudio[2132]: ratelimit.c: 2955 events suppressed
Jul 28 20:33:51 nick-comp pulseaudio[2132]: asyncq.c: q overrun, queuing locally
Jul 28 20:33:51 nick-comp pulseaudio[2132]: asyncq.c: q overrun, queuing locally
Jul 28 20:33:51 nick-comp pulseaudio[2132]: asyncq.c: q overrun, queuing locally
Jul 28 20:33:51 nick-comp pulseaudio[2132]: asyncq.c: q overrun, queuing locally
Jul 28 20:33:51 nick-comp pulseaudio[2132]: asyncq.c: q overrun, queuing locally
Jul 28 20:33:51 nick-comp pulseaudio[2132]: asyncq.c: q overrun, queuing locally
Jul 28 20:33:51 nick-comp pulseaudio[2132]: asyncq.c: q overrun, queuing locally
Jul 28 20:33:51 nick-comp pulseaudio[2132]: asyncq.c: q overrun, queuing locally
Jul 28 20:33:51 nick-comp pulseaudio[2132]: asyncq.c: q overrun, queuing locally
Jul 28 20:33:51 nick-comp pulseaudio[2132]: asyncq.c: q overrun, queuing locally
Jul 28 20:33:51 nick-comp pulseaudio[2132]: asyncq.c: q overrun, queuing locally
Jul 28 20:33:56 nick-comp pulseaudio[2132]: ratelimit.c: 4358 events suppressed
Jul 28 20:34:01 nick-comp pulseaudio[2132]: ratelimit.c: 830 events suppressed
Jul 28 20:34:06 nick-comp pulseaudio[2132]: ratelimit.c: 714 events suppressed
Jul 28 20:34:11 nick-comp pulseaudio[2132]: ratelimit.c: 478 events suppressed
Jul 28 20:34:16 nick-comp pulseaudio[2132]: ratelimit.c: 711 events suppressed
Comment 3 N Coghill 2009-07-28 23:46:50 EDT
Also, after removing alsa-plugins-pulseaudio, Rhythmbox worked as I said earlier.  However, I later tested Movie player, vlc, and xine.  Those programs still had no working audio.  The audio did work before on all of those programs.  I have re-installed alsa-plugins-pulseaudio, and rebooted the computer, and it has gone back to not working in Rhythmbox either.
Comment 4 Pádraig Brady 2009-07-29 07:37:33 EDT
I see the same symptoms after I accepted the latest F11 kernel update (2.6.29.6-213.fc11.i586). This issue is also present in a 2.6.30 kernel
I installed from the testing repo. Here are some pertinent messages I think
from /var/log/messages:

Jul 29 12:17:26 localhost pulseaudio[24728]: alsa-sink.c: Increasing minimal latency to 1.00 ms
Jul 29 12:17:51 localhost pulseaudio[24728]: alsa-sink.c: Increasing minimal latency to 2.00 ms
Jul 29 12:17:51 localhost pulseaudio[24728]: alsa-util.c: snd_pcm_avail() returned a value that is exceptionally large: 4294964876 bytes (24347873 ms).
Jul 29 12:17:51 localhost pulseaudio[24728]: alsa-util.c: Most likely this is a bug in the ALSA driver 'snd_intel8x0'. Please report this issue to the ALSA developers.
Jul 29 12:17:51 localhost pulseaudio[24728]: alsa-util.c: snd_pcm_dump():
Jul 29 12:17:51 localhost pulseaudio[24728]: alsa-util.c: Hardware PCM card 0 'Intel ICH6' device 0 subdevice 0
Jul 29 12:17:51 localhost pulseaudio[24728]: alsa-util.c: Its setup is:
Jul 29 12:17:51 localhost pulseaudio[24728]: alsa-util.c:   stream       : PLAYBACK
Jul 29 12:17:51 localhost pulseaudio[24728]: alsa-util.c:   access       : MMAP_INTERLEAVED
Jul 29 12:17:51 localhost pulseaudio[24728]: alsa-util.c:   format       : S16_LE
Jul 29 12:17:51 localhost pulseaudio[24728]: alsa-util.c:   subformat    : STD
Jul 29 12:17:51 localhost pulseaudio[24728]: alsa-util.c:   channels     : 2
Jul 29 12:17:51 localhost pulseaudio[24728]: alsa-util.c:   rate         : 44100
Jul 29 12:17:51 localhost pulseaudio[24728]: alsa-util.c:   exact rate   : 44100 (44100/1)
Jul 29 12:17:51 localhost pulseaudio[24728]: alsa-util.c:   msbits       : 16
Jul 29 12:17:51 localhost pulseaudio[24728]: alsa-util.c:   buffer_size  : 16384
Jul 29 12:17:51 localhost pulseaudio[24728]: alsa-util.c:   period_size  : 16384
Jul 29 12:17:51 localhost pulseaudio[24728]: alsa-util.c:   period_time  : 371519
Jul 29 12:17:51 localhost pulseaudio[24728]: alsa-util.c:   tstamp_mode  : ENABLE
Jul 29 12:17:51 localhost pulseaudio[24728]: alsa-util.c:   period_step  : 1
Jul 29 12:17:51 localhost pulseaudio[24728]: alsa-util.c:   avail_min    : 16384
Jul 29 12:17:51 localhost pulseaudio[24728]: alsa-util.c:   period_event : 0
Jul 29 12:17:51 localhost pulseaudio[24728]: alsa-util.c:   start_threshold  : -1
Jul 29 12:17:51 localhost pulseaudio[24728]: alsa-util.c:   stop_threshold   : 1073741824
Jul 29 12:17:51 localhost pulseaudio[24728]: alsa-util.c:   silence_threshold: 0
Jul 29 12:17:51 localhost pulseaudio[24728]: alsa-util.c:   silence_size : 0
Jul 29 12:17:51 localhost pulseaudio[24728]: alsa-util.c:   boundary     : 1073741824
Jul 29 12:17:51 localhost pulseaudio[24728]: alsa-util.c:   appl_ptr     : 1294945
Jul 29 12:17:51 localhost pulseaudio[24728]: alsa-util.c:   hw_ptr       : 1277956
Jul 29 12:17:51 localhost pulseaudio[24728]: alsa-util.c: snd_pcm_delay() returned a value that is exceptionally large: 346164 bytes (1962 ms).
Jul 29 12:17:51 localhost pulseaudio[24728]: alsa-util.c: Most likely this is a bug in the ALSA driver 'snd_intel8x0'. Please report this issue to the ALSA developers.
Jul 29 12:17:51 localhost pulseaudio[24728]: alsa-util.c: snd_pcm_dump():
Jul 29 12:17:51 localhost pulseaudio[24728]: alsa-util.c: Hardware PCM card 0 'Intel ICH6' device 0 subdevice 0
Jul 29 12:17:51 localhost pulseaudio[24728]: alsa-util.c: Its setup is:
Jul 29 12:17:51 localhost pulseaudio[24728]: alsa-util.c:   stream       : PLAYBACK
Jul 29 12:17:51 localhost pulseaudio[24728]: alsa-util.c:   access       : MMAP_INTERLEAVED
Jul 29 12:17:51 localhost pulseaudio[24728]: alsa-util.c:   format       : S16_LE
Jul 29 12:17:51 localhost pulseaudio[24728]: alsa-util.c:   subformat    : STD
Jul 29 12:17:51 localhost pulseaudio[24728]: alsa-util.c:   channels     : 2
Jul 29 12:17:51 localhost pulseaudio[24728]: alsa-util.c:   rate         : 44100
Jul 29 12:17:51 localhost pulseaudio[24728]: alsa-util.c:   exact rate   : 44100 (44100/1)
Jul 29 12:17:51 localhost pulseaudio[24728]: alsa-util.c:   msbits       : 16
Jul 29 12:17:51 localhost pulseaudio[24728]: alsa-util.c:   buffer_size  : 16384
Jul 29 12:17:51 localhost pulseaudio[24728]: alsa-util.c:   period_size  : 16384
Jul 29 12:17:51 localhost pulseaudio[24728]: alsa-util.c:   period_time  : 371519
Jul 29 12:17:51 localhost pulseaudio[24728]: alsa-util.c:   tstamp_mode  : ENABLE
Jul 29 12:17:51 localhost pulseaudio[24728]: alsa-util.c:   period_step  : 1
Jul 29 12:17:51 localhost pulseaudio[24728]: alsa-util.c:   avail_min    : 16384
Jul 29 12:17:51 localhost pulseaudio[24728]: alsa-util.c:   period_event : 0
Jul 29 12:17:51 localhost pulseaudio[24728]: alsa-util.c:   start_threshold  : -1
Jul 29 12:17:51 localhost pulseaudio[24728]: alsa-util.c:   stop_threshold   : 1073741824
Jul 29 12:17:51 localhost pulseaudio[24728]: alsa-util.c:   silence_threshold: 0
Jul 29 12:17:51 localhost pulseaudio[24728]: alsa-util.c:   silence_size : 0
Jul 29 12:17:51 localhost pulseaudio[24728]: alsa-util.c:   boundary     : 1073741824
Jul 29 12:17:51 localhost pulseaudio[24728]: alsa-util.c:   appl_ptr     : 1365505
Jul 29 12:17:51 localhost pulseaudio[24728]: alsa-util.c:   hw_ptr       : 1278964
Jul 29 12:17:56 localhost pulseaudio[24728]: ratelimit.c: 11248 events suppressed
Jul 29 12:18:01 localhost pulseaudio[24728]: ratelimit.c: 11608 events suppressed
Jul 29 12:18:06 localhost pulseaudio[24728]: ratelimit.c: 10199 events suppressed
Jul 29 12:18:08 localhost pulseaudio[24728]: alsa-sink.c: Increasing wakeup watermark to 20.00 ms
Jul 29 12:18:11 localhost pulseaudio[24728]: ratelimit.c: 3952 events suppressed
Jul 29 12:19:16 localhost pulseaudio[24728]: ratelimit.c: 557 events suppressed
Jul 29 12:19:16 localhost pulseaudio[24728]: alsa-sink.c: Increasing minimal latency to 4.00 ms
Jul 29 12:19:17 localhost pulseaudio[24728]: alsa-sink.c: Increasing minimal latency to 8.00 ms
Jul 29 12:19:17 localhost pulseaudio[24728]: alsa-sink.c: Increasing minimal latency to 16.00 ms
Jul 29 12:19:17 localhost pulseaudio[24728]: alsa-sink.c: Increasing minimal latency to 26.00 ms
Jul 29 12:19:17 localhost pulseaudio[24728]: alsa-sink.c: Increasing wakeup watermark to 15.99 ms
Jul 29 12:19:17 localhost pulseaudio[24728]: alsa-sink.c: Increasing minimal latency to 36.00 ms
Jul 29 12:19:21 localhost pulseaudio[24728]: ratelimit.c: 9086 events suppressed
Jul 29 12:19:26 localhost pulseaudio[24728]: ratelimit.c: 11796 events suppressed
Jul 29 12:19:31 localhost pulseaudio[24728]: ratelimit.c: 11832 events suppressed
Jul 29 12:19:35 localhost pulseaudio[24728]: alsa-sink.c: Increasing wakeup watermark to 25.99 ms
Jul 29 12:19:35 localhost pulseaudio[24728]: alsa-sink.c: Increasing minimal latency to 46.00 ms
Jul 29 12:20:32 localhost pulseaudio[24728]: ratelimit.c: 8490 events suppressed
Jul 29 12:20:32 localhost pulseaudio[24728]: alsa-sink.c: Increasing wakeup watermark to 35.99 ms
Jul 29 12:20:37 localhost pulseaudio[24728]: ratelimit.c: 21107 events suppressed
Jul 29 12:20:42 localhost pulseaudio[24728]: ratelimit.c: 12403 events suppressed
Jul 29 12:20:47 localhost pulseaudio[24728]: ratelimit.c: 16324 events suppressed
Jul 29 12:20:48 localhost pulseaudio[24728]: alsa-sink.c: Increasing minimal latency to 56.00 ms
Jul 29 12:20:48 localhost pulseaudio[24728]: alsa-sink.c: Increasing wakeup watermark to 45.99 ms
Jul 29 12:20:52 localhost pulseaudio[24728]: ratelimit.c: 16376 events suppressed
Jul 29 12:20:53 localhost pulseaudio[24728]: cpulimit.c: Received request to terminate due to CPU overload.
Comment 5 Lennart Poettering 2009-07-29 10:41:23 EDT

*** This bug has been marked as a duplicate of bug 506075 ***

Note You need to log in before you can comment on or make changes to this bug.