Bug 5141 - PGP5 select doesn't work properly in rpm 3.0.2
Summary: PGP5 select doesn't work properly in rpm 3.0.2
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm   
(Show other bugs)
Version: 5.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-09-15 00:48 UTC by advax
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-09-15 16:06:11 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description advax 1999-09-15 00:48:35 UTC
PGP 5.0i installs with binaries "pgp", "pgpk" and symlinks
"pgpv", "pgps", "pgpe".

rpm-3.0.2/lib/signature.c around line 100 tests first for
"pgp" so thinks it has found 2.6.3, and fails if this is
PGP 5

Having fixed this by switching the test order --checksig
worked.

The manpage still seems to allow signature and pgp_name
in ~/.rpmrc though these are now not understood

Andrew Daviel <advax@triumf.ca>

Comment 1 advax 1999-09-15 01:01:59 UTC
sorry - was seeing an old manpage re. .rpmrc comment - AD

Comment 2 Jeff Johnson 1999-09-15 16:06:59 UTC
Fixed in rpm-3.0.3 (available in Raw Hide).


Note You need to log in before you can comment on or make changes to this bug.