Bug 51412 - sawfish doesn't display cyrillic characters
Summary: sawfish doesn't display cyrillic characters
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: sawfish (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-10 11:23 UTC by Leonid Kanter
Modified: 2007-04-18 16:35 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-15 19:45:56 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot (147.23 KB, image/png)
2001-08-10 11:25 UTC, Leonid Kanter
no flags Details
this patch solves the problem (872 bytes, patch)
2001-08-10 11:28 UTC, Leonid Kanter
no flags Details | Diff
patch applied (898 bytes, patch)
2001-08-15 19:45 UTC, Havoc Pennington
no flags Details | Diff

Description Leonid Kanter 2001-08-10 11:23:33 UTC
Description of Problem:

sawfish doesn't display cyrillic characters in 'fixed' font

How Reproducible:

always

Steps to Reproduce:
1. start GNOME with LANG=ru_RU.koi8r

Actual Results:

you'll see "?" in sawfish menu and in control-center

Expected Results:

cyrillic characters must be there

Additional Information:

Comment 1 Leonid Kanter 2001-08-10 11:25:07 UTC
Created attachment 27233 [details]
screenshot

Comment 2 Leonid Kanter 2001-08-10 11:28:32 UTC
Created attachment 27234 [details]
this patch solves the problem

Comment 3 Glen Foster 2001-08-10 20:01:49 UTC
We (Red Hat) should really try to fix this before next release.

Comment 4 Havoc Pennington 2001-08-15 19:45:50 UTC
Created attachment 28014 [details]
patch applied

Comment 5 Havoc Pennington 2001-08-15 19:47:02 UTC
sawfish 0.38-8 should fix this

Comment 6 Eugene Kanter 2001-08-15 21:23:00 UTC
Would be possible for you to explain the reason for a difference betwen 
proposed and applied patches?

Comment 7 Havoc Pennington 2001-08-15 21:27:33 UTC
Sure, the font name I put in is the one we use in gnome-terminal as well, which
works in Japanese. I'm not sure the one in the other patch will work, though it
probably does; I just went with the one I know is tested.

The real fix is probably to call gettext() on these font names and have them
translated to something nice per-locale. This is what we recently did to
gnome-terminal. I'm not sure how to do that for the lisp half of the patch
though, and there's no way we'll get them translated by the next release anyhow.


Note You need to log in before you can comment on or make changes to this bug.