This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 51419 - PS/2 wheelmice might not be made by Microsoft
PS/2 wheelmice might not be made by Microsoft
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: mouseconfig (Show other bugs)
7.3
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Brent Fox
David Lawrence
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-10 08:38 EDT by Göran Uddeborg
Modified: 2007-03-26 23:47 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:48:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Göran Uddeborg 2001-08-10 08:38:40 EDT
I have a PS/2 wheelmouse from Logitech.  When rerunning mouseconfig
recently, I thought I couldn't find any appropriate entry for it.  After
digging a bit I realised I should have choosen "Microsoft IntelliMouse
(PS/2)" to get the correct values in /etc/sysconfig/mouse and
/etc/X11/XF86Config*.

From bug report 31111 I realise I'm not the only one who have misunderstood
the menu.  Maybe a more generic description of the mouse type would help. 
"Generic IntelliMouse (PS/2)" perhaps, or maybe "IntelliMouse wheelmouse
(PS/2)"?
Comment 1 Mike A. Harris 2002-02-11 00:29:44 EST
There does seem to be some confusion with respect to mouse configuration
indeed.  One particular peoblem I've noticed is the confusion between
the "brand" of mouse a person has, and the "protocol" that mouse uses in
XFree86 and gpm.  There are many different protocols various mice use
to communicate with the computer.  Every mouse has a favoured protocol
that the vendor has developed it to use as the default, and in addition
to that, many mice support other common mouse protocols also, so as to
have better compatibility.

Mice running under XFree86 and gpm are configured based on the protocol
that they use, and not on the company who made the mouse.  For example,
most Logitech mice natively speak one of the logitech mouse protocols,
however they also speak one or more of the microsoft mouse protocols
as well.  It is often possible to configure a logitech mouse to use
one of several protocols.  It does however look a bit odd to an end
user to tell X they're using an Intellimouse PS/2 (IMPS/2) which is
a Microsoft mouse, when in fact they're using a Logitech USB mouse.
The thing is, that Logitech mouse is using the IMPS/2 _protocol_ to
communicate with the computer, and that is what is being configured,
rather than the make/model.

I've found that most mice nowadays will use the IMPS2 protocol, and
work better generally if configured to use that protocol.

Our utilities should probably be updated to reflect the current types
of hardware on the market, and use defaults that are most likely to work
for a given type of mouse.  Since we do not have every piece of hardware
out there however, we rely on users bug reports and their solutions in
order to set up most of our default settings for stuff like this.
 
Just thought I'd add this blurb to the report as I stumbled across it.
Comment 2 Brent Fox 2002-10-10 14:16:08 EDT
I have just completed a text mode interface for redhat-config-mouse, which means
that mouseconfig will be deprecated in the next release of Red Hat Linux.  

Therefore, I will not be putting any development time towards fixing mouseconfig
bugs, so I'm closing this as 'wontfix'.
Comment 3 Göran Uddeborg 2002-10-10 15:44:43 EDT
Understood.  No point working with a dying tool.

My intention was to confirm this by closing the bug.  But it seems this is no
longer possible for me as a reporter.  (The documentation page,
https://bugzilla.redhat.com/bugzilla/bug_status.cgi, still says it should have
been thoug.)
Comment 4 Red Hat Bugzilla 2006-02-21 13:48:05 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.