Bug 5142 - Red Hat's perl 5.005_03 distribution is missing NDBM_File
Red Hat's perl 5.005_03 distribution is missing NDBM_File
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: perl (Show other bugs)
6.0
All Linux
high Severity high
: ---
: ---
Assigned To: Crutcher Dunnavant
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-09-14 21:08 EDT by ricardo
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-01-15 10:02:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ricardo 1999-09-14 21:08:58 EDT
NDBM_File is a standard module included in the regular perl
distribution (5.005_03 and earlier). NDBM_File cannot even
be installed as a separate module like most other perl
modules, it can only be installed as part of the regular
perl distribution.

(For example, you have to get perl-5.00503.tar.gz and
install that (the full distribution) in order to get
NDBM_File.

So, the ONLY way to get NDBM_File on a Red Hat system is to
actually reinstall the full perl distribution, by rebuilding
everything... :-(

Please include NDBM_File support in RedHat's perl module, as
standard.

This is of critical need for anyone who is using legacy perl
code which might have previously used NDBM_File and then
absolutely does not work with RedHat's 6.0 perl distribution
because of the lack of NDBM_File support.

Ricardo Kleemann
ricardo@americasnet.com
Comment 1 Jeff Johnson 2000-01-15 10:02:59 EST
NDBM_File support is in perl-5.00503-6 and later from Red Hat 6.1. You may
still see problems with db1 vs. db2 format in older database files.

Note You need to log in before you can comment on or make changes to this bug.