Bug 514217 - koffice kword crash with formulas
Summary: koffice kword crash with formulas
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: koffice
Version: 11
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Andreas Bierfert
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-07-28 12:21 UTC by Ludwin Janvier
Modified: 2009-09-17 02:30 UTC (History)
5 users (show)

Fixed In Version: 1.6.4-1.fc10
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-15 07:53:14 UTC
Type: ---


Attachments (Terms of Use)
krash report (5.06 KB, text/plain)
2009-07-28 12:21 UTC, Ludwin Janvier
no flags Details
kcrash report with kdebase3 (5.12 KB, text/plain)
2009-07-28 15:02 UTC, Ludwin Janvier
no flags Details

Description Ludwin Janvier 2009-07-28 12:21:44 UTC
Created attachment 355402 [details]
krash report

Description of problem:
Why I try to insert a formula, kword is crashing.

Version-Release number of selected component (if applicable):
(fresh install of Fedora 11+updates)
Name       : koffice-kword
Arch       : i586
Epoch      : 2
Version    : 1.6.3
Release    : 21.20090306svn.fc11
Size       : 5.0 M
Repo       : installed
From repo  : enc11
Summary    : A frame-based word processor capable of professional standard documents
URL        : http://www.koffice.org/
License    : GPLv2+
Description: A frame-based word processor capable of professional standard documents.

How reproducible:
always

Steps to Reproduce:
1. launch kword with an empty doc
2. insert -> formula
3. Some windows are opening :
2 time : "unable to create io-slave: klauncher said: Unknown protocol 'fonts'. with Cancel/Skip/auto Skip buttons
4. select any button (2 times)
  
Actual results:
kword is crashing

On the terminal :
QGDict::hashKeyString: Invalid null key
KCrash: Application 'kword' crashing...


Expected results:
Not to crash

Additional info:

Comment 1 Rex Dieter 2009-07-28 12:48:34 UTC
rpm -q kdebase3 kdebase-runtime
please.

Comment 2 Rex Dieter 2009-07-28 12:50:03 UTC
In particular, kdebase3, if not installed, try

yum install kdebase3

and see if that helps.

Comment 3 Ludwin Janvier 2009-07-28 15:01:36 UTC
KDE3 wasn't installed. I did install it but this didn't solve the problem.

$ rpm -q kdebase3 kdebase-runtime
kdebase3-3.5.10-8.fc11.i586
kdebase-runtime-4.2.4-2.fc11.i586

kcrash gave a slightly different report, so I'm attaching it.

Comment 4 Ludwin Janvier 2009-07-28 15:02:14 UTC
Created attachment 355423 [details]
kcrash report with kdebase3

Comment 5 Rex Dieter 2009-07-28 20:57:48 UTC
Though I couldn't reproduce the crash, I think I've got this one nailed.

Got a test build going, please test if you can,
https://koji.fedoraproject.org/koji/buildinfo?buildID=123226

Comment 6 Fedora Update System 2009-08-26 19:31:41 UTC
lyx-1.6.4-1.fc11,koffice-1.6.3-24.20090306svn.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/lyx-1.6.4-1.fc11,koffice-1.6.3-24.20090306svn.fc11

Comment 7 Fedora Update System 2009-08-27 22:52:23 UTC
lyx-1.6.4-1.fc10, koffice-1.6.3-24.20090306svn.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update lyx koffice'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-9052

Comment 8 Fedora Update System 2009-08-27 22:55:24 UTC
lyx-1.6.4-1.fc11, koffice-1.6.3-24.20090306svn.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update lyx koffice'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-9077

Comment 9 Fedora Update System 2009-09-15 07:52:59 UTC
lyx-1.6.4-1.fc11, koffice-1.6.3-24.20090306svn.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2009-09-15 07:57:10 UTC
lyx-1.6.4-1.fc10, koffice-1.6.3-24.20090306svn.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2009-09-17 02:30:05 UTC
lyx-1.6.4-1.el5, koffice-1.6.3-24.20090306svn.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.