Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 51422 - (neomagic) Wrong Hz or external monitor "kicks" out
(neomagic) Wrong Hz or external monitor "kicks" out
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: Xconfigurator (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks: 82781
  Show dependency treegraph
 
Reported: 2001-08-10 09:09 EDT by Need Real Name
Modified: 2007-04-18 12:35 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-04-05 07:07:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Requested files. Taken from roswell (12.44 KB, application/x-zip-compressed)
2001-09-03 04:36 EDT, Need Real Name
no flags Details
This are the XFree files that Mandrake8.0 creates. - Don't know if they are usefull to you at all? (6.29 KB, application/x-zip-compressed)
2001-09-03 04:37 EDT, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2001-08-10 09:09:25 EDT
Description of Problem:
Xconfigurator and XF86Config on RH can not configure the NeoMagic256zx and IBM P70 external monitor correctly. I.e. the Hz is wrong (60Hz and not 85Hz as it should be) or the monitor kicks out. - Mandrake 8.0 do all this correctly. The Roswell beta has the same problem as RH 7.1

How Reproducible:
Every time

Steps to Reproduce:
1.Dock the IBM TP 600x
2.Install RH and try to configure X
3.Run Xconfigurator

Actual Results:
The monitor kicks out or you get 60Hz on the external monitor

Expected Results:
That the monitor works fine in 1024x768x24bpp in 85Hz

Additional Information:
I have a IBM TP 600X and an IBM P70 external monitor. 
RH 7.1 detects the gfx card fine and the monitor too during the install procedure. But it fails to run the X server test. 
Hmmm I continue with the installation. And afterwards runs Xconfigurator. It too detects the gfx card and monitor, and SOME times I can get the XServer to start -but only in 60Hz. Damn! 
I decided to try Mandrake 8.0 and it too detects the gfx card and monitor and it starts X in 85Hz without any problems(!). X can also start when the computer is not docked. -But the mouse(and much more) does not work under MD8..... Damn! 

I guess that's why hate linux - naaaa I really don't, but this really sux. Why does MD8 Xconfig works while RH7.1 does not. I have looked at the XF86Config file on both systems but could not make RH work.

The new RH beta(roswell) have the same problem...
Comment 1 Mike A. Harris 2001-08-28 13:10:17 EDT
Can you attach your "lspci -v" and "lspci -vn" output?

Also, can you attach a copy of your config files, and XFree86 logfile
using the link below?
Comment 2 Need Real Name 2001-09-03 04:36:00 EDT
Created attachment 30674 [details]
Requested files. Taken from roswell
Comment 3 Need Real Name 2001-09-03 04:37:32 EDT
Created attachment 30675 [details]
This are the XFree files that Mandrake8.0 creates. - Don't know if they are usefull to you at all?
Comment 4 Mike A. Harris 2002-11-10 23:01:45 EST
Sorry this bug has sat idle for so long.  I hope to look into it sometime
in the future, however I'd like to note that zip file attachments or any
form of compressed file attachments are not friendly to casual browsing
of bug reports in bugzilla.  In future bug reports, please attach
all files as single uncompressed unarchived file attachments.

Thanks.
Comment 5 Mike A. Harris 2003-04-05 07:07:19 EST
Not sure what the problem was here.  I do not have any neomagic hardware,
nor specifications however.  I've been unable to locate any information
online while searching for users with similar problems.

If this problem persists after you upgrade to Red Hat Linux 9 with
XFree86 4.3.0, please file a bug report at http://bugs.xfree86.org
so that the neomagic driver maintainer can directly investigate the
problem.

Note You need to log in before you can comment on or make changes to this bug.