Bug 514228 - Guests are denied access to network
Guests are denied access to network
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Berrange
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-28 09:35 EDT by Gianluca Sforna
Modified: 2009-08-18 07:16 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-18 07:16:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gianluca Sforna 2009-07-28 09:35:30 EDT
It seems I can't assign to guests any ethernet device; in particular, the virt-manager VM creation wizard do not let me choose any network device, and if I try to assign it later via the "Add new hardware" button I get a traceback:

Traceback (most recent call last):
 File "/usr/share/virt-manager/virtManager/addhardware.py", line 288,
in forward
   if(self.validate(notebook.get_current_page()) != True):
 File "/usr/share/virt-manager/virtManager/addhardware.py", line 882,
in validate
   net = self.get_config_network()
 File "/usr/share/virt-manager/virtManager/addhardware.py", line 407,
in get_config_network
   return ["network", model.get_value(net.get_active_iter(), 0)]
TypeError: iter must be a GtkTreeIter


Additionally, using virsh to add:

   <interface type='bridge'>
     <mac address='54:52:00:49:73:9a'/>
     <source bridge='br0'/>
   </interface>

Leads to another trackback when starting the VM:
Traceback (most recent call last):
 File "/usr/share/virt-manager/virtManager/engine.py", line 493, in run_domain
   vm.startup()
 File "/usr/share/virt-manager/virtManager/domain.py", line 573, in startup
   self.vm.create()
 File "/usr/lib64/python2.6/site-packages/libvirt.py", line 287, in create
   if ret == -1: raise libvirtError ('virDomainCreate() failed', dom=self)
libvirtError: internal error Failed to add tap interface 'vnet%d' to
bridge 'br0' : No such device

Finally, here's what I've found in the virt-manager.log:
[Tue, 28 Jul 2009 12:54:16 virt-manager 3653] ERROR (proxies:400)
Introspect error on
:1.1:/org/freedesktop/Hal/devices/net_d2_eb_bc_ff_01_a7:
dbus.exceptions.DBusException: No device with id
/org/freedesktop/Hal/devices/net_d2_eb_bc_ff_01_a7
[Tue, 28 Jul 2009 12:54:16 virt-manager 3653] DEBUG (proxies:403)
Executing introspect queue due to error
[Tue, 28 Jul 2009 12:54:16 virt-manager 3653] ERROR (connection:218)
Exception in handler for D-Bus signal:
Traceback (most recent call last):
 File "/usr/lib/python2.6/site-packages/dbus/connection.py", line
214, in maybe_handle_message
   self._handler(*args, **kwargs)
 File "/usr/share/virt-manager/virtManager/connection.py", line 170,
in _net_phys_device_added
   if objif.QueryCapability("net"):
 File "/usr/lib/python2.6/site-packages/dbus/proxies.py", line 68, in __call__
   return self._proxy_method(*args, **keywords)
 File "/usr/lib/python2.6/site-packages/dbus/proxies.py", line 140, in __call__
   **keywords)
 File "/usr/lib/python2.6/site-packages/dbus/connection.py", line
630, in call_blocking
   message, timeout)
DBusException: org.freedesktop.Hal.NoSuchDevice: No device with id
/org/freedesktop/Hal/devices/net_d2_eb_bc_ff_01_a7
Comment 1 Mark McLoughlin 2009-08-11 13:08:35 EDT
Thanks for the report

What version of virt-manager, libvirt etc. is this?

Could you post the output of some of these commands?

  https://fedoraproject.org/wiki/Reporting_virtualization_bugs#Networking
Comment 2 Gianluca Sforna 2009-08-12 10:34:51 EDT
I'm on an updated F11:

rpm -qa |grep virt
python-virtinst-0.400.3-8.fc11.noarch
libvirt-python-0.6.2-13.fc11.x86_64
virt-manager-0.7.0-5.fc11.x86_64
virt-viewer-0.0.3-6.fc11.x86_64
libvirt-0.6.2-13.fc11.x86_64

output from the other commands:

[giallu@bingo ~]$ virsh net-list --all
Name                 State      Autostart
-----------------------------------------

[giallu@bingo ~]$ brctl show
bridge name	bridge id		STP enabled	interfaces
pan0		8000.000000000000	no	
	
[giallu@bingo ~]$ sysctl net.bridge.bridge-nf-call-iptables
net.bridge.bridge-nf-call-iptables = 1

[giallu@bingo ~]$ sudo iptables -L -v -n
Chain INPUT (policy ACCEPT 0 packets, 0 bytes)
 pkts bytes target     prot opt in     out     source               destination         
 391K  314M ACCEPT     all  --  *      *       0.0.0.0/0            0.0.0.0/0           state RELATED,ESTABLISHED 
    0     0 ACCEPT     icmp --  *      *       0.0.0.0/0            0.0.0.0/0           
   15  1296 ACCEPT     all  --  lo     *       0.0.0.0/0            0.0.0.0/0           
    0     0 ACCEPT     tcp  --  *      *       0.0.0.0/0            0.0.0.0/0           state NEW tcp dpt:22 
   20  6734 REJECT     all  --  *      *       0.0.0.0/0            0.0.0.0/0           reject-with icmp-host-prohibited 

Chain FORWARD (policy ACCEPT 0 packets, 0 bytes)
 pkts bytes target     prot opt in     out     source               destination         
    0     0 REJECT     all  --  *      *       0.0.0.0/0            0.0.0.0/0           reject-with icmp-host-prohibited 

Chain OUTPUT (policy ACCEPT 308K packets, 41M bytes)
 pkts bytes target     prot opt in     out     source               destination         

[giallu@bingo ~]$ ps -ef | grep dnsmasq
giallu    8143  7834  0 16:32 pts/2    00:00:00 grep dnsmasq

[giallu@bingo ~]$ ifconfig -a
eth0      Link encap:Ethernet  HWaddr 00:15:B7:72:9C:F2  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
          Memory:ffcc0000-ffce0000 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:102 errors:0 dropped:0 overruns:0 frame:0
          TX packets:102 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:20062 (19.5 KiB)  TX bytes:20062 (19.5 KiB)

pan0      Link encap:Ethernet  HWaddr 9A:2E:D8:7A:8C:4F  
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

wlan0     Link encap:Ethernet  HWaddr 00:1D:E0:95:7C:29  
          inet addr:192.168.1.102  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::21d:e0ff:fe95:7c29/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:399054 errors:0 dropped:0 overruns:0 frame:0
          TX packets:308394 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:322732892 (307.7 MiB)  TX bytes:51483631 (49.0 MiB)

wmaster0  Link encap:UNSPEC  HWaddr 00-1D-E0-95-7C-29-A0-C8-00-00-00-00-00-00-00-00  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

[giallu@bingo ~]$ cat /proc/sys/net/ipv4/ip_forward
0
Comment 3 Mark McLoughlin 2009-08-14 13:17:24 EDT
(In reply to comment #0)

> Additionally, using virsh to add:
> 
>    <interface type='bridge'>
>      <mac address='54:52:00:49:73:9a'/>
>      <source bridge='br0'/>
>    </interface>

(In reply to comment #2)

> [giallu@bingo ~]$ brctl show
> bridge name bridge id  STP enabled interfaces
> pan0  8000.000000000000 no 

You're trying to attach the interface to the 'br0' bridge, but there is no such bridge

If you follow the instructions here to set up the bridge, I think it should work:

  http://wiki.libvirt.org/page/Networking#Fedora.2FRHEL_Bridging
Comment 4 Gianluca Sforna 2009-08-15 13:04:32 EDT
Who is supposed to create the br0 or virbr0 interfaces?

I mean, I'm not really sure how I managed to get into this problem, but surely creating a KVM virtual machine with virt-manager should add a virtual ethernet adapter for the VM out of the box.

Right now, any new machine I create can't access the network which does not look right.
Comment 5 Mark McLoughlin 2009-08-18 06:50:35 EDT
(In reply to comment #4)
> Who is supposed to create the br0 or virbr0 interfaces?

The virbr0 interface is created by libvirtd and is available by default on all machines.

Try:

  $> virsh net-start default
  $> virsh net-autostart default

br0 OTOH must be created explicitly by the user using the instructions I posted above.
Comment 6 Gianluca Sforna 2009-08-18 06:56:09 EDT
Ok, then since I'm not really trying to use br0 but I would be happy enough with a OOTB experience, I'll try to get virbr0 working, which is apparently the problem I'm facing here:

# virsh net-start default
error: failed to get network 'default'
error: Network not found: no network with matching name

# service libvirtd status
libvirtd (pid  2008) is running...
Comment 7 Mark McLoughlin 2009-08-18 07:16:51 EDT
Sounds like the default network was deleted somehow

Pretty sure this isn't a real bug, it's working fine here

If you can reproduce how this came about, please do re-open

Thanks

Note You need to log in before you can comment on or make changes to this bug.