Bug 51423 - sysctl does not read back value after writing
sysctl does not read back value after writing
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: procps (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Aaron Brown
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-10 09:16 EDT by Patrick C. F. Ernzer
Modified: 2007-04-18 12:35 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-11 07:50:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Patrick C. F. Ernzer 2001-08-10 09:16:23 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.3) Gecko/20010803

Description of problem:
when setting a value with sysctl, it does not read back the value but
echoes the input back.

How reproducible:
Always

Steps to Reproduce:
1. [root@begot /root]# cat /proc/sys/kernel/shmall 
2097152
2. [root@begot /root]# sysctl -w kernel.shmall=banana 
kernel.shmall = banana
3. [root@begot /root]# cat /proc/sys/kernel/shmall 
2097152


Actual Results:  banana is not written to /proc/sys/kernel/shmall

Expected Results:  An error message by sysctl that the value that was given
by the user was not actually written. As in
[root@begot /root]# sysctl -w kernel.shmall=banana
attempt to set kernel.shmall = banana
value of kernel.shmall = 2097152

Additional info: this might count as a duplicate of bug 18820
Comment 1 Patrick C. F. Ernzer 2001-10-09 12:30:27 EDT
[root@begot root]# rpm -qf `which sysctl`
procps-2.0.7-11
[root@begot root]# cat /proc/sys/kernel/shmall
2097152
[root@begot root]# sysctl -w kernel.shmall=banana
kernel.shmall = banana
[root@begot root]# echo $?
0
[root@begot root]# cat /proc/sys/kernel/shmall
2097152
Comment 2 Daniel Walsh 2004-02-11 07:50:45 EST
Fixed in procps-3.1.15-4


Note You need to log in before you can comment on or make changes to this bug.