Bug 514241 - Evaluate the need for qemu's virtio_net TX mitigation timer
Evaluate the need for qemu's virtio_net TX mitigation timer
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: qemu (Show other bugs)
rawhide
All Linux
high Severity medium
: ---
: ---
Assigned To: Justin M. Forbes
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F12VirtTarget
  Show dependency treegraph
 
Reported: 2009-07-28 10:37 EDT by Mark McLoughlin
Modified: 2013-01-09 16:48 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-10 07:13:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
qemu-kvm-remove-virtio-net-tx-timer.patch (7.23 KB, patch)
2009-08-12 13:01 EDT, Mark McLoughlin
no flags Details | Diff

  None (edit)
Description Mark McLoughlin 2009-07-28 10:37:23 EDT
See bug #504647 where we removed the virtio_net TX mitigation timer for RHEL5.4

We need to re-do that benchmarking on a 2.6.31 kernel in order to evaluate whether removing would benefit Fedora 12

One major difference is that more recent kernels have higher resolution timers, so the timer would be 150us instead of 1ms
Comment 1 Mark McLoughlin 2009-08-12 13:01:09 EDT
Created attachment 357206 [details]
qemu-kvm-remove-virtio-net-tx-timer.patch

Here's a version of the RHEL5 patch which applies to Fedora 12
Comment 2 Fedora Admin XMLRPC Client 2010-03-09 11:54:10 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 3 Fedora Admin XMLRPC Client 2010-03-09 12:19:56 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 4 Dor Laor 2010-03-10 07:13:39 EST
I think we can close it since our default should be vhost and it's not relevant there

Note You need to log in before you can comment on or make changes to this bug.