Bug 514262 - Seemingly random NIC enumeration in RHEL6
Seemingly random NIC enumeration in RHEL6
Status: CLOSED DUPLICATE of bug 450590
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.0
All Linux
high Severity high
: rc
: ---
Assigned To: David Cantrell
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-28 11:41 EDT by Gary Case
Modified: 2012-10-01 14:25 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-22 20:28:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sosreport of system with eth0, eth4-7 (575.07 KB, application/x-bzip)
2009-07-28 11:51 EDT, Gary Case
no flags Details
udev and ifcfg-eth config files, captured post-install (864 bytes, application/x-gzip)
2009-07-28 16:01 EDT, Gary Case
no flags Details

  None (edit)
Description Gary Case 2009-07-28 11:41:54 EDT
Description of problem:
NICs are enumerated oddly in RHEL6. I'm using a Sun Ultra27 workstation to do my RHEL6 testing. When only the onboard NIC is present, it's assigned as eth0 and everything works fine. I installed a 4-port PCI NIC into the system to replicate a problem that Sun reported. When I brought the system back up, it detected the card's 4 ports as eth1-eth4 and behaved as expected. I then reinstalled the OS to check that behavior and now I have eth0 (onboard) and eth4-7 (PCI card). Where did 1-3 go?

Version-Release number of selected component (if applicable):
NetworkManager-0.7.1-4.git20090414.fc11.x86_64

More to come, including a sosreport, momentarily.
Comment 1 RHEL Product and Program Management 2009-07-28 11:49:21 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 2 Gary Case 2009-07-28 11:51:35 EDT
Created attachment 355429 [details]
sosreport of system with eth0, eth4-7
Comment 3 Bill Nottingham 2009-07-28 11:55:14 EDT
Original enumeration comes from anaconda.
Comment 4 Gary Case 2009-07-28 12:00:56 EDT
How reproducible:
Each boot post-install keeps the same unusual NIC ordering

Steps to Reproduce:
1. Install RHEL6 on a system with a 4-port NIC and an onboard NIC
2. Reboot after install
3. Observe the strange NIC ordering

Actual results:
Holes in NIC naming sequence

Expected results:
NICs enumerated in order

Additional info:
Comment 5 Gary Case 2009-07-28 12:01:39 EDT
Notting,

I'll try a few more installs to see if anaconda keeps this same ordering.

-Gary
Comment 6 Gary Case 2009-07-28 12:54:12 EDT
If I run ifconfig -a on the terminal during install, it shows eth0-eth4. After the reboot, I get eth0 and eth4-eth7.
Comment 7 Bill Nottingham 2009-07-28 13:22:12 EDT
What's the content of /etc/udev/rules.d/70-persistent-net.rules (and/or /etc/sysconfig/network-scripts/ifcf-g*) on the installed system

1) when anaconda finishes
2) after rebooting

?
Comment 8 Gary Case 2009-07-28 16:00:43 EDT
Okay. It looks like the ifcfg-* files are correct post-boot. They're called eth0-eth4 and their contents name them as eth0-eth4. It's the persistent net rules file and the output of NetworkManager that's wacky. I'm attaching a tarball with all the files.
Comment 9 Gary Case 2009-07-28 16:01:19 EDT
Created attachment 355460 [details]
udev and ifcfg-eth config files, captured post-install
Comment 10 Bill Nottingham 2009-07-28 16:08:41 EDT
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="00:00:00:00:00:00", ATTR{type}=="1", KERNEL=="eth*", NAME="eth3"

Yeah, that's broken.
Comment 11 Dan Williams 2009-07-29 12:15:11 EDT
Let me know how it goes; some devices may not have MAC addresses until they are given one.  In this case, it's best to write udev rules to assign a MAC to the device based on other hardware attributes (like pci bus location, USB serial number, etc), if it doesn't have the capability to store its MAC address in NVRAM.  Thus the MAC address is available to NetworkManager and ifup/ifdown.
Comment 12 David Cantrell 2010-01-22 20:28:13 EST

*** This bug has been marked as a duplicate of bug 450590 ***
Comment 13 David Cantrell 2012-10-01 14:25:24 EDT
*** Bug 839313 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.