This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 51431 - Networking goes stop working intermitently
Networking goes stop working intermitently
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
alpha Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-10 10:21 EDT by Need Real Name
Modified: 2007-04-18 12:35 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-06 12:46:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-08-10 10:21:44 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.3-12 i686)

Description of problem:
Soemtime after a while the network card sudently stop responding to the
outside. This happen with a 3Com PCI 3c905 Boomerang and with
a DEC 21140 (de3x5 and tulip driver).

How reproducible:
Sometimes

Steps to Reproduce:
1. Have some traffic on the network card and at "random it happens"
	

Expected Results:  Network should not go down. 

Additional info:

System was working fine with RedHat 6.2
Loggin at the console and trying to access the outside makes the network
start again. No error message on the console. No errors in syslog.

/proc/cpuinfo:
cpu                     : Alpha
cpu model               : EV56
cpu variation           : 7
cpu revision            : 0
cpu serial number       :
system type             : Rawhide
system variation        : Dodge
system revision         : 0
system serial number    : NI811017N0
cycle frequency [Hz]    : 531914893
timer frequency [Hz]    : 1200.00
page size [bytes]       : 8192
phys. address bits      : 40
max. addr. space #      : 127
BogoMIPS                : 923.40
kernel unaligned acc    : 0 (pc=0,va=0)
user unaligned acc      : 0 (pc=0,va=0)
platform string         : AlphaServer 4100 5/533 4MB
cpus detected           : 2
cpus active             : 2
cpu active mask         : 0000000000000003
Comment 1 Phil Copeland 2001-08-10 10:58:54 EDT
Humm
[root@dhcpd84 drm]# uname -a 
Linux dhcpd84.meridian.redhat.com 2.4.3-12 #1 Fri Jun 8 13:20:17 EDT 2001 alpha
unknown

[root@dhcpd84 drm]# uptime
  9:53am  up 2 days,  3:29,  5 users,  load average: 0.36, 0.81, 0.93

[root@dhcpd84 drm]# ifconfig eth0
eth0      Link encap:Ethernet  HWaddr 00:50:DA:B4:10:77  
          inet addr:172.16.47.84  Bcast:172.16.47.255  Mask:255.255.252.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:617891 errors:0 dropped:0 overruns:0 frame:0
          TX packets:23489 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:100 
          RX bytes:107012696 (102.0 Mb)  TX bytes:2693152 (2.5 Mb)
          Interrupt:27 Base address:0x8400 

[root@dhcpd84 drm]# lspci
00:08.0 Ethernet controller: 3Com Corporation 3c905B 100BaseTX [Cyclone] (rev
64)

Thyis machine seems to be stable and doesn't seem to drop it's networking at all
could you provide some additional info eg
are you using a hub or switch
do you use dhcp
have you tried using a different IP (guess that something out there on the net
might have the same ip as you)
are there any relevant messages in the kernel log? (dmesg)

Phil
=--=
Comment 2 Need Real Name 2001-08-10 11:12:05 EDT
[root@dilbert /root]# uname -a
Linux dilbert 2.4.3-12smp #1 SMP Fri Jun 8 13:04:54 EDT 2001 alpha unknown
[root@dilbert /root]# lspci
00:03.0 Ethernet controller: Digital Equipment Corporation DECchip 21140
[FasterNet] (rev 22)
00:04.0 Ethernet controller: 3Com Corporation 3c905 100BaseTX [Boomerang]

[root@dilbert /root]# ifconfig -a
eth0      Link encap:Ethernet  HWaddr 00:60:08:14:98:4A
          inet addr:142.120.93.213  Bcast:142.120.93.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:693648 errors:0 dropped:0 overruns:0 frame:0
          TX packets:621185 errors:0 dropped:0 overruns:0 carrier:0
          collisions:100405 txqueuelen:100
          RX bytes:169071632 (161.2 Mb)  TX bytes:508605447 (485.0 Mb)
          Interrupt:24 Base address:0x8080

Using static IP address. The network is a switched network (Cisco Catalyst, I
don't have the model number here).
This machine was running with RedHat 6.2 for almost 6 months and was stable
using the same IP address.

From dmesg:
3c59x.c:LK1.1.13 27 Jan 2001  Donald Becker and others.
http://www.scyld.com/network/vortex.html
See Documentation/networking/vortex.txt
eth0: 3Com PCI 3c905 Boomerang 100baseTx at 0x8080,  00:60:08:14:98:4a, IRQ 24
  product code 4b4b rev 00.0 date 06-06-97
  8K word-wide RAM 3:5 Rx:Tx split, autoselect/MII interface.
  MII transceiver found at address 24, status 786d.
  Enabling bus-master transmits and whole-frame receives.
eth0: scatter/gather enabled. h/w checksums disabled
eth0: first available media type: MII

The only things in syslog that seem pertinent are:
Aug 10 09:57:40 dilbert ntpd[479]: time reset -1.905140 s
Aug 10 09:57:40 dilbert ntpd[479]: synchronisation lost
Aug 10 09:58:41 dilbert ypbind[501]: broadcast: RPC: Can't encode arguments.
Comment 3 Phil Copeland 2001-08-10 11:38:16 EDT
Ok, so you have both network cards in there at the same time, humm,.. well your
lspci suggests they are ajacent to each other and on the same PCI bridge so I
wouldn't expect any change if you pulled one out. Are you using this machien as
a router? or do you run routed at all on this box?

Phil
=--=
Comment 4 Need Real Name 2001-08-10 11:58:31 EDT
They are both on the same PCI bridge (there is 2 PCI bridge on this machine)
The machine had only the Tulip card at the begginning and since we had this
trouble with it, we tryed adding a second network card (3com) and using it
instead of the one on the machine. Currently it's the 3Com that is active for
the other, the driver is not even loaded. The same problem occurs with any of
the 2 network card (using only 1 at time).
This machine doesn't run rooted. 
The machine main use is currently as a logging server (for Exceed clients).
Comment 5 Need Real Name 2001-08-14 11:06:40 EDT
I am having the same trouble with an Alphaserver 4100.  I have tried 4 
different network cards to no avail.  I seem to have the best luck with an old 
D-link Digital card out of one of our DEC Prioris boxes.  10Mb and it works %95 
of the time.  If it is a 100Mb card such as one that uses a tulip, 8139too, or 
eepro100 driver it will hang the system and sometimes never come back.  I have 
the problem when the module is loaded and it doesn't matter if the interface is 
up or not.  If I unload the module for the NIC it will run all day long with no 
problem. 

This is a basic load of 7.1 straight off of the CD's.  It is connected to a 
Cisco Catalyst 2924XL Switch and when it connects it does so at 100Mb Full 
Duplex.  I don't think it is the connection as it happens when the modules are 
loaded even if eth0 is down.

It is using a static ip with no conflicts.  There are no relevant messages in 
dmesg.  I have tried manually starting the connection and no change.

Let me know if you need anything specific.

Bill sends..............
Comment 6 Need Real Name 2001-08-16 14:36:42 EDT
The same system did deadlock once. When using the UP kernel the network seem
more stable (not completly stable from what I see in the log files about NTP and
desynchronizing with his server) and no deadlock so far.
Comment 7 Alan Cox 2003-06-06 12:46:02 EDT
Closing old Alpha bug

Note You need to log in before you can comment on or make changes to this bug.