Bug 51440 - No way to mount floppies through Nautilus
No way to mount floppies through Nautilus
Status: CLOSED NOTABUG
Product: Red Hat Public Beta
Classification: Retired
Component: nautilus (Show other bugs)
roswell
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-10 11:18 EDT by Owen Taylor
Modified: 2007-04-18 12:35 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-10 16:01:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Owen Taylor 2001-08-10 11:18:31 EDT
In nautilus, floppies are treated just like CD-ROMS - a icon
is only displayed on the desktop if the floppy is mounted.

Unfortunately, old-style floppy drives (as opposed to USB
floppies) don't support autodetection, so mounting has
to been done manually.

What gmc did was to always display a floppy icon on the desktop,
and you could right click and select mount, or select format
(which would run floppy-buddy)

Since NautilusVolumeMonitor only deals with volumes that are
there, this would probably have to be special cased, perhaps
as special desktop files like the trash can. FloppyBuddy has code 
in it to autodetect floppy drives that could be used.

This is a pretty serious problem, since the only way to mount
a floppy is by starting a shell and typing 'mount /mnt/floppy',
but its also a lot of work to fix.
Comment 1 Glen Foster 2001-08-10 16:01:54 EDT
We (Red Hat) should really try to fix this before next release.
Comment 2 Havoc Pennington 2001-08-14 19:30:38 EDT
It turns out that you can actually right-click on desktop and choose
Disks->Floppy. Kind of hard to find, but it does exist.

Note You need to log in before you can comment on or make changes to this bug.