Bug 51451 - ghostscript needs to be better about paper sizes
Summary: ghostscript needs to be better about paper sizes
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: ghostscript (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-10 16:01 UTC by Jonathan Kamens
Modified: 2007-04-18 16:35 UTC (History)
0 users

Fixed In Version: 7.07-x
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-11-07 12:31:44 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to make ghostscript better about selecting PCL paper sizes (4.47 KB, patch)
2001-08-10 16:02 UTC, Jonathan Kamens
no flags Details | Diff

Description Jonathan Kamens 2001-08-10 16:01:43 UTC
The attached patch for selecting paper sizes when generating output to PCL
devices has been submitted to, and accepted by, the ghostscript development
team.  I'd like to see it incorporated into the RedHat ghostscript release
before the ghostscript team puts out another release, so that I can stop
maintaining my own, customized version of the RedHat ghostscript package
with this patch in it.

The comments in the patch explain how it works.  Here's what the ghoscript
developers had to say about it:

>This patch looks fine. I agree with your logic regarding paper width
>deserving greater priority than paper height.
>
>I think it would be slightly better to put the paper sizes in an
>array, and iterate through it, rather than inlining all the code with
>the CHECK_PAPER_SIZE macro, but it's not a showstopper.
>
>My thinking is that this should be committed to HEAD only, as it is
>more of an enhancement than a bug fix, and that it carries the
>potential to change existing behavior unexpectedly. Since Jonathan
>doesn't have CVS access, I'm committing it now.

Comment 1 Jonathan Kamens 2001-08-10 16:02:23 UTC
Created attachment 27274 [details]
patch to make ghostscript better about selecting PCL paper sizes

Comment 2 Tim Waugh 2002-01-10 16:22:04 UTC
Thanks for the patch.



Note You need to log in before you can comment on or make changes to this bug.