Bug 51458 - Suspend to disk dosn't work with 2.4.7-0.12.1
Suspend to disk dosn't work with 2.4.7-0.12.1
Status: CLOSED WONTFIX
Product: Red Hat Raw Hide
Classification: Retired
Component: kernel (Show other bugs)
1.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-10 13:02 EDT by Michael Stefaniuc
Modified: 2015-01-04 17:01 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-29 23:26:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmidecode output of a C600 with 2.4.7-0.12.1 (3.50 KB, text/plain)
2001-08-10 13:04 EDT, Michael Stefaniuc
no flags Details
strace of apm --suspend (2.40 KB, text/plain)
2001-08-10 13:41 EDT, David Sainty
no flags Details
strace apm --suspend - this time as root! (2.42 KB, text/plain)
2001-08-10 15:16 EDT, David Sainty
no flags Details
linux-2.4.7-dmi.patch diff for 2.4.5-2.5 (766 bytes, patch)
2001-08-22 08:09 EDT, David Sainty
no flags Details | Diff

  None (edit)
Description Michael Stefaniuc 2001-08-10 13:02:34 EDT
Description of Problem:
With the 2.4.7-0.12.1 kernel the Dell C600 laptop (BIOS rev. A03 and A13)
dosn't go into suspend to disk mode when closing the display lid nor after
pressing <FN><Suspend>. It works fine with 2.4.7-0.11.1 and below


How Reproducible:
every time

Additional Information:
Output of http://people.redhat.com/arjanv/dmidecode.c
Comment 1 Michael Stefaniuc 2001-08-10 13:04:02 EDT
Created attachment 27293 [details]
dmidecode output of a C600 with 2.4.7-0.12.1
Comment 2 David Sainty 2001-08-10 13:39:36 EDT
Yup, same thing here, again Dell Latitude C600.  Providing strace of "apm
--suspend".
Comment 3 David Sainty 2001-08-10 13:41:52 EDT
Created attachment 27296 [details]
strace of apm --suspend
Comment 4 David Sainty 2001-08-10 15:16:29 EDT
Created attachment 27314 [details]
strace apm --suspend - this time as root!
Comment 5 David Sainty 2001-08-22 08:08:51 EDT
After much hunting through patches and compiling test kernels...  the
linux-2.4.7-dmi.patch had been modified between 0.11.1 and 0.13.1. The first two
new chunks cause the problem. 

Patch for 2.4.7-2.5 kernel attached, to remove these two chunks.


Comment 6 David Sainty 2001-08-22 08:09:57 EDT
Created attachment 28894 [details]
linux-2.4.7-dmi.patch diff for 2.4.5-2.5

Note You need to log in before you can comment on or make changes to this bug.