This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 514631 - Missing build dependencies bison and flex
Missing build dependencies bison and flex
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: augeas (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: David Lutterkort
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-29 18:14 EDT by Matthew Booth
Modified: 2013-04-30 19:41 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-05 18:28:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Patch to add missing build dependencies to augeas.spec.in (739 bytes, patch)
2009-07-29 18:14 EDT, Matthew Booth
no flags Details | Diff

  None (edit)
Description Matthew Booth 2009-07-29 18:14:49 EDT
Created attachment 355613 [details]
Patch to add missing build dependencies to augeas.spec.in

Description of problem:
augeas.spec.in doesn't specify bison and flex, which are required to build augeas.

Note that although the build process looks for yacc, it actually requires bison. byacc (Berkeley yacc), which is also in Fedora, does not work.

Version-Release number of selected component (if applicable):
7a3a89a03249c0d96153a1a100f9030345057003
Comment 1 Matthew Booth 2009-07-29 18:18:46 EDT
Sorry, just realised this should have gone in augeas's trac instance. However, I can't log into that, so I'll leave this open for the moment.
Comment 2 David Lutterkort 2009-08-05 18:28:37 EDT
The tarball for an Augeas release contains all the bison and flex generated files, so bison and flex are not needed when building the Augeas rpm.

Rerunning bison/flex during every build (including rpm builds) would lead to chaos, because of the different versions of bison/flex available in different distros/OS versions.

Note You need to log in before you can comment on or make changes to this bug.