Bug 514749 - RFE: IPv6 virtual network: support IPv6 routing, dhcpv6 & autoconf on virtual networks
RFE: IPv6 virtual network: support IPv6 routing, dhcpv6 & autoconf on virtual...
Status: CLOSED CURRENTRELEASE
Product: Virtualization Tools
Classification: Community
Component: libvirt (Show other bugs)
unspecified
All Linux
low Severity medium
: ---
: ---
Assigned To: Laine Stump
:
Depends On:
Blocks: libvirtTodoNetwork
  Show dependency treegraph
 
Reported: 2009-07-30 12:09 EDT by Daniel Berrange
Modified: 2011-06-08 11:54 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-25 10:06:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Berrange 2009-07-30 12:09:11 EDT
Description of problem:

We need to support configuration of IPv6 on virtual networks.

See

http://www.redhat.com/archives/libvir-list/2009-June/msg00067.html

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Peter Bieringer 2010-02-21 14:07:36 EST
ip6tables support is currently also missing, see https://bugzilla.redhat.com/show_bug.cgi?id=567124
Comment 2 Laine Stump 2011-01-03 11:09:07 EST
A series of patches to implement this feature has been pushed upstream:

https://www.redhat.com/archives/libvir-list/2010-December/msg00915.html

It will be in the 0.8.7 release of libvirt

commit 1ab80f32dd38462ef596c2af6b6d128a263ab0e5
    New virSocketAddr utility functions
commit 8322863fd59b8d5a6d13d9bfef0538d05e3f919f
    New virNetworkDef utility functions
commit cf7311892a282fe8de451fdb577dbcdb5d49cace
    Fix logging of failed iptables commands
commit 6e3e6db14fe80830cea3f427d8ff3fda7cc3f853
    Consistently return 0 on success, -1 on failure in bridge_driver.c
commit b23d417cc7d72f1a1f82053eb5fe1b47bd344007
    Pass prefix rather than netmask into iptables functions
commit 4713f074a5208599c1d1733c058e18c850527022
    Make virtual network netmasks optional
commit 20718b8bcbb0c1a15ca96083d2636a2445dde291
    Replace brSetInetAddress/brSetInetNetmask with brAddInetAddress
commit 008abeeeb9ffb0008433eb9933c0dc2263b75ac5
    make the <dhcp> element optional in network.rng
commit a950dd2a312b7263e221927f99f1e0e3f15eccc9
    Change virtual network XML parsing/formatting to support IPv6
commit ad48dfa15c2c7826d82905be13df7ff13d657588
    Support multiple IP addresses on one network in bridge_driver.c
commit 537e65e7b76aca61a6c367d06788810c6c980db5
    Update iptables.c to also support ip6tables.
commit 6ccce75240f2c8991be97b78f8a43ee7b6552733
    Turn on IPv6 support in the bridge_driver.c virtual network driver
commit 8090a56890457b192ff453a65f220c4b6617dc27
    Run radvd for virtual networks with IPv6 addresses
Comment 3 Laine Stump 2011-04-06 11:54:33 EDT
I just created Bug 694155, requesting support for configuring IPv6 virtual networks in virt-manager.
Comment 4 Trever Adams 2011-06-08 10:29:08 EDT
This actually doesn't seem to be fixed. At least in part because https://bugzilla.redhat.com/show_bug.cgi?id=501934 turns off IPv6 on the bridge devices. Even having fixed that, I cannot get it to apply the addresses (with my xml file hand edited). It also doesn't radvd, or other wise send autoconfiguration, to the vms.
Comment 5 Daniel Berrange 2011-06-08 11:54:32 EDT
bug 501934 is irrelevant, because that is referring to an older libvirt where IPv6 was not supported. In current libvirt when you add an Ipv6 address in the configuration of the network XML, it will *not* disable IPv6 on the bridge. If you have problems with IPv6 support, please file new bugzillas with detailed information on the problem, rather than commenting on old closed bugs, since the latter will generally be ignored.

Note You need to log in before you can comment on or make changes to this bug.