Bug 51475 - XFree86 4.x Locks under Gnome and KDE when scrolling or sliding the task bar.
XFree86 4.x Locks under Gnome and KDE when scrolling or sliding the task bar.
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-10 15:49 EDT by David Arigan
Modified: 2007-04-18 12:35 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-09 09:51:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Arigan 2001-08-10 15:49:53 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98)

Description of problem:
I am running a 96meg ram P200 with A 2mb Matrox Mystique at 1152x864 16bpp 
and 256mb swap partition.  My system locks on a fresh install after 
scrolling or sliding the task bar to the side. (My guess is any large move 
of video memory).  This has only appeared since running 7.1 and continues 
even after upgrading to Xfree86.org's latest release 4.1.0.

How reproducible:
Always

Steps to Reproduce:
1. Open a window
2. Use the scroll bar. - or -
3. Slide the task bar to the side.
	

Additional info:

I am an expert when it comes to any MS operating system but somewhat at at 
a loss when it comes to Linux (I am just trying to make the switch).  I 
can program in C/Assembly so if you need any addtional information I am 
sure I can supply it.
Comment 1 Alexei Podtelezhnikov 2001-08-10 21:06:34 EDT
I beleave this is due to lack of videoram on your system.
1152x864x2=1,990,656=almost entire 2 Mb. X might want some extra
space for buffering, textures, etc. Reduce resolution to
something like 800x600. Is the problem still there?
Comment 2 David Arigan 2001-08-12 14:43:58 EDT
I have tried that... but it didn't work.  I ran at 1152x864 16bpp on the 
previous version of XFree86 and it worked just fine.
Comment 3 Mike A. Harris 2001-08-18 20:11:29 EDT
Attach logs + configs
Comment 4 David Arigan 2001-08-22 08:52:55 EDT
It is definitely a problem with XFree86.  I installed Mandrake 8.0 with 4.x and 
the same problem occured.  I then installed Mandrake 8.9 with 3.3 and the 
problem was no longer found.  I am going to re-install Redhat (It is much 
better than Mandrake) and I will attach the log files... but I need to know 
which files and their locations.  Sorry... but I have been stuck in Dos/Windows 
land since the beggining of time (seemingly).
Comment 5 Mike A. Harris 2001-11-06 05:51:40 EST
It is most likely a 2D acceleration bug.  I need your info to
proceed though.  We can narrow it down if it is an XAA bug.
Comment 6 Mike A. Harris 2002-02-09 09:51:32 EST
I need your config file /etc/X11/XF86Config-4, your X server log
/var/log/XFree86.0.log, and your kernel log /var/log/messages to
proceed troubleshooting.  Once I have that, we can try different
configuration options to try and narrow things down.

I also recommend updating to XFree86-4.1.0-15 and our latest kernel
errata which were released not too long ago.

Thanks in advance.
Comment 7 Mike A. Harris 2002-07-29 21:49:50 EDT
Closing bug due to inactivity.

Note You need to log in before you can comment on or make changes to this bug.