Bug 514834 - "strace -f" exits before all children
"strace -f" exits before all children
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: strace (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Roland McGrath
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 516995
  Show dependency treegraph
 
Reported: 2009-07-30 19:24 EDT by John Reiser
Modified: 2009-09-22 11:03 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-22 11:03:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John Reiser 2009-07-30 19:24:28 EDT
Description of problem: "strace -f" exits before all children have completed.


Version-Release number of selected component (if applicable):
strace-4.5.18-2.fc11.x86_64


How reproducible: always


Steps to Reproduce:
1. rpm --install kernel-2.6.29.6-213.fc11.src.rpm
2. edit SPECS/kernel.spec for private build: "%define buildid .jfr"
3. ulimit -c 25000000  # allow core files upto 25MB for SIGSEGV, etc.
4. strace -f -o strace.out -e trace=file rpmbuild -bb --target x86_64 --with baseonly kernel.spec > rpm.out 2>&1 &

  
Actual results: strace quits sometime in the middle, leaving several levels of 'make' still running.  There were no core.<<pid>> files.  File strace.out had grown to 756MB (and there were many GB of space still available in the filesystem.)  The last several lines of one instance were:
-----
25890 lstat("sound/i2c/.snd-i2c.mod.o.tmp", {st_mode=S_IFREG|0644, st_size=22304, ...}) = 0
25890 lstat("sound/i2c/.snd-i2c.mod.o.cmd", 0x7fffd3d89250) = -1 ENOENT (No such file or directory)
25890 rename("sound/i2c/.snd-i2c.mod.o.tmp", "sound/i2c/.snd-i2c.mod.o.cmd") = 0
25884 --- SIGCHLD (Child exited) @ 0 (0) ---
-----
where process 25884 was:
25884 execve("/usr/bin/as", ["as", "-Qy", "--64", "-o", "net/ipv4/.tmp_mc_protocol.o", "net/ipv4/.tmp_mc_protocol.s"], [/* 125 vars */]) = 0



Expected results: Successful strace of entire process tree.


Additional info: Discovered while investigating bug #514830.
Comment 1 Andreas Schwab 2009-09-09 07:07:45 EDT
I cannot reproduce that.
Comment 2 Andreas Schwab 2009-09-22 11:03:19 EDT
Not reproducable.

Note You need to log in before you can comment on or make changes to this bug.