Bug 51485 - Entry and Text widgets do not recognise deadkeys defined in .Xmodmap
Entry and Text widgets do not recognise deadkeys defined in .Xmodmap
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: tcltk (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-10 17:04 EDT by Niall S Cearbhaill
Modified: 2007-04-18 12:35 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-05 00:43:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
This is a copy of my ".Xmodmap" file (8.07 KB, text/plain)
2001-08-10 17:06 EDT, Niall S Cearbhaill
no flags Details

  None (edit)
Description Niall S Cearbhaill 2001-08-10 17:04:23 EDT
Description of Problem:
When deadkeys are defined in .Xmodmap such as "apostrophe => dead_acute"
both the entry and text widget refuse to recognise it. Under RH6.2 the
result on pressing apostrophe followed by the letter a would be "a"
(aacute). However
under both RH7.0 and RH7.1 the rsult is oxb4 (the acute accent) followed
by a

Note: the problem is with the widgets. If wish is run on its own in a shell
the wish correctly interprets the keystrokes -- in the terminal!

How Reproducible:
I4m sending you my Xmodmap file. Load it in your account as ".Xmodmap"
logout from X, and log back in to X to activate it. In a terminal
or in gedit, verify that pressing apostrophe followed by a say, generates
the character a (aacute). Try it with a Tcl/Tk program with an entry widget
and see what happens

Steps to Reproduce:
1. set up supplied ".Xmodmap", logout and login again
2. check that apostrophe works as dead_acute (in a terminal
3. try it in a Tcl/Tk program with either an entry widget or a text widget

Actual Results:


Expected Results:


Additional Information:
	
Looking at the sources, I believe the error is in the routines  (commom
to both "entry" and "text" which map the ".Xmodmap" file to a table.
Comment 1 Niall S Cearbhaill 2001-08-10 17:06:51 EDT
Created attachment 27333 [details]
This is a copy of my ".Xmodmap" file
Comment 2 Trond Eivind Glomsrxd 2001-08-13 11:42:33 EDT
Have you tried the beta? It seems to be working for me with tcl-8.3.3-64
Comment 3 Trond Eivind Glomsrxd 2002-08-21 14:30:51 EDT
Closing due to lack of feedback.

Note You need to log in before you can comment on or make changes to this bug.