Bug 51493 - XFree86 4.1 - DRI w/riva 128 locks up & doesn't load
XFree86 4.1 - DRI w/riva 128 locks up & doesn't load
Status: CLOSED NOTABUG
Product: Red Hat Public Beta
Classification: Retired
Component: XFree86 (Show other bugs)
roswell
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-10 19:40 EDT by Byron Miller
Modified: 2007-04-18 12:35 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-10 19:40:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Byron Miller 2001-08-10 19:40:24 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2)
Gecko/20010726 Netscape6/6.1

Description of problem:
The default kernel for roswell doesn't correctly load agpart or the riva128
support (kudzu error or just back x configuration and kernel
configuration).  After recompiling a 2.4.7 kernel i can get the kernel
module to load (agpart and r128.o) but when using anything that utilizes
DRI the pc freezes up completely.

Dell C600 w/riva 128 mz laptop - local display and docked display has same
problem. local crt doesn't loose synch, but when docked screen goes black.
(music from dri games like tixracer still plays in a loop though).

i went back to 2.4.6 that ships with roswell and manually loaded the agpart
and riva 128 dri drivers and the same thing happens.

Appears to be a kernel bug or agpart may not like APM, APCI or something
similar that is enabled.

Is there any known bugs with agpart, riva 128 dri on laptops? I havn't been
able to try this with a previous version of redhat. Will attempt that later
on this weekend

How reproducible:
Always

Steps to Reproduce:
1.insmod agpart
2.insmod r128.o
3.startx
4. tuxracer  (glxinfo, gldedmo.. whatever uses dri)
lockup
	

Actual Results:  pc freezes

Expected Results:  expect output of video

Additional info:

Dell C600
Pentium III 1000 mhz
256 megs ram
ext3, XFree86, agpart, riva 128 dri drivers. (the load correctly though)
Docked & Undocked
Comment 1 Mike A. Harris 2001-08-11 07:14:35 EDT
Riva128 is Nvidia, which is not the r128.  Nvidia hardware is not supported
by DRI at this point because Nvidia does not provide the required technical
information to the open source community for drivers to be written, and
they do not release open source drivers themselves unfortunately.

The r128 driver, and DRI support is for the ATI Rage 128 series of hardware.

Also, the Roswell beta, does not have the new required XFree86 4.1.0 DRM
support in the kernel yet, although the current rawhide kernel does have
the new DRM in it now.

Sorry, I can't do anything about the Riva 128.  ;o(

Note You need to log in before you can comment on or make changes to this bug.