Bug 514992 - dbus: rejected send message, sender pulseaudio
dbus: rejected send message, sender pulseaudio
Status: CLOSED DUPLICATE of bug 513579
Product: Fedora
Classification: Fedora
Component: bluez (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-31 15:11 EDT by Stephen
Modified: 2009-08-07 09:59 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-07 09:59:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen 2009-07-31 15:11:05 EDT
Description of problem:

I have the following error in /var/log/messages immediately after login:


dbus: Rejected send message, 2 matched rules; type="method_call", sender=":1.27" (uid=42 pid=1839 comm="/usr/bin/pulseaudio --start --log-target=syslog ") interface="org.bluez.Manager" member="ListAdapters" error name="(unset)" requested_reply=0 destination="org.bluez" (uid=0 pid=1567 comm="/usr/sbin/bluetoothd "))

pulseaudio[1839]: bluetooth-util.c: Error from ListAdapters reply: org.freedesktop.DBus.Error.AccessDenied




Version-Release number of selected component (if applicable):

Just updated F11:

gnome-bluetooth-libs-2.27.5-1.fc11.i586
pulseaudio-module-bluetooth-0.9.15-14.fc11.i586
gnome-bluetooth-2.27.5-1.fc11.i586
bluez-libs-4.42-1.fc11.i586
bluez-gstreamer-4.42-1.fc11.i586
bluez-cups-4.42-1.fc11.i586
bluez-4.42-1.fc11.i586
python-slip-dbus-0.1.15-3.fc11.noarch
ndesk-dbus-0.6.1a-4.fc11.i586
dbus-glib-0.80-2.fc11.i586
dbus-1.2.12-2.fc11.i586
ndesk-dbus-glib-0.4.1-4.fc11.i586
dbus-libs-1.2.12-2.fc11.i586
dbus-x11-1.2.12-2.fc11.i586
dbus-python-0.83.0-5.fc11.i586
pulseaudio-utils-0.9.15-14.fc11.i586
pulseaudio-libs-0.9.15-14.fc11.i586
pulseaudio-0.9.15-14.fc11.i586
pulseaudio-libs-glib2-0.9.15-14.fc11.i586
pulseaudio-module-bluetooth-0.9.15-14.fc11.i586
pulseaudio-module-x11-0.9.15-14.fc11.i586
pulseaudio-module-gconf-0.9.15-14.fc11.i586
alsa-plugins-pulseaudio-1.0.20-2.fc11.i586
PolicyKit-gnome-0.9.2-3.fc11.i586
policycoreutils-2.0.62-12.12.fc11.i586
PolicyKit-0.9-6.fc11.i586
PolicyKit-gnome-libs-0.9.2-3.fc11.i586


Additional info:

I was looking in the log to see why right-click send-as via bluetooth wasn't working, and noticed what seems to be this unrelated error.  Not sure what the consequences of it are.  Bluetooth headsets? (I don't have one to test)
Comment 1 Bastien Nocera 2009-07-31 21:27:50 EDT
$ grep gdm /etc/passwd
gdm:x:42:42::/var/lib/gdm:/sbin/nologin

That's gdm's pulseaudio trying to talk to bluetoothd, but only the user's pulseaudio is allowed to talk to bluetoothd.

*** This bug has been marked as a duplicate of bug 513579 ***
Comment 2 Lennart Poettering 2009-08-07 09:51:36 EDT
Hmm, I really don't see what this has to do with 513579. That bug is about SELinux. THis one is about D-Bus policy files.

I am splitting this up again.

The question here is of course, should BT audio be available to the gdm session? i.e. should BT headsets work during login?
Comment 3 Bastien Nocera 2009-08-07 09:59:05 EDT
It's the same bug. gdm's PulseAudio isn't killed, therefore you get warnings about rejected D-Bus messages through auditd. It's the same bug.

*** This bug has been marked as a duplicate of bug 513579 ***

Note You need to log in before you can comment on or make changes to this bug.