Bug 51502 - Rubberbanding on desktop with background image corrupts image.
Summary: Rubberbanding on desktop with background image corrupts image.
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: nautilus   
(Show other bugs)
Version: roswell
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-11 04:39 UTC by Ed McKenzie
Modified: 2007-04-18 16:35 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-16 19:30:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ed McKenzie 2001-08-11 04:39:26 UTC
With a scaled background image, rubberbanding icons on the desktop damages
the background.  The residual bits of image are unscaled.

Comment 1 Ed McKenzie 2001-08-11 04:41:19 UTC
This is easiest to reproduce with centered/scaled images larger than the desktop.

Comment 2 Glen Foster 2001-08-13 19:07:08 UTC
We (Red Hat) should really try to fix this before next release.

Comment 3 Havoc Pennington 2001-08-16 19:30:38 UTC
I'm not sure if this is the same or different from the bug where occasionally the 
background is not set on the desktop window. The symptoms of not setting the
background will usually be that areas with no icons have a solid-color
background, while areas near or underneath icons do get the image background
drawn. It happens eventually if you sit in background-properties and change the
background enough times.

I haven't been able to find the cause of the problem yet.

Comment 4 Havoc Pennington 2002-03-01 21:17:00 UTC
Only critical fixes for GNOME 1.x at this point. Relevant code is entirely
different in GNOME 2 so the bug won't apply (though others doubtless will!)


Note You need to log in before you can comment on or make changes to this bug.