Bug 515029 - wpa_supplicant craps out under heavy load.
wpa_supplicant craps out under heavy load.
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: wpa_supplicant (Show other bugs)
11
All Linux
low Severity high
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-31 17:57 EDT by Justin P. Mattock
Modified: 2009-11-19 14:16 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-19 13:50:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Justin P. Mattock 2009-07-31 17:57:54 EDT
Description of problem: wpa_supplicant disconnects, and reconnects under heavy load, causing the system to become sluggish, and internet timeout.


Version-Release number of selected component (if applicable):
0.6.*
(whatever fedora 11 comes with)
How reproducible:
load a radio station online, then watch anything in flash longer than ten minuetes
(watch a movie on hulu).

Steps to Reproduce:
1.login
2.open mplayer play your favorit streamed radio.
3.open firefox watch a movie on hulu.
  
Actual results:
hulu stops playing radio stops playing,
system becomes sluggish.

Expected results:
watch a streamed movie, and if you would like mute the video, and play radio
(kind of like watch old silent flicks!)

Additional info:
temporary fix:
download the source code of wpa_supplicant and compile the source using
the default .config should work.
Comment 1 Justin P. Mattock 2009-11-16 12:27:22 EST
not sure where this is at. I guess you can close this, since there seems to be no comments/complaints on this bug. As for a fix like above I just recompile wpa_supplicant, and all is good.(keep in mind the.defconfig is as is, nothing added/or removed).
Comment 2 Dan Williams 2009-11-17 03:50:13 EST
This is probably more the driver than anything else.  Does the kernel 'dmesg' logs say anything interesting from the driver?
Comment 3 Justin P. Mattock 2009-11-17 13:04:25 EST
well, with the two machines I've seen this on both, 
one machine is a macbook pro(using ath9k) and the other is an imac using broadcom sta.

There is nothing in dmesg. the only way to really see anything
is to manually run wpa_supplicant in a terminal(no networkmanager/wicd...)
(usually will fire off under heavy load).
Comment 4 Dan Williams 2009-11-17 14:44:49 EST
When you say heavy load, you mean heavy network load, not heavy CPU load, right?

What is the supplicant output when this happens?  When you manually run the supplicant, can you run it iwth the "-dddt" option to increase the logging verbosity for me?
Comment 5 Justin P. Mattock 2009-11-17 15:31:31 EST
keep in mind I don't have the issue in front of me right now. But I do remember what wpa does.

basically I would do this:(in a terminal)
wpa_supplicant -Dwext -i wlan0 -c /etc/*
(wpa_supplicant starts, then I use /sbin/dhclient wlan0)

then wpa will print out connected.
then I turn on an internet radio station then open firefox ant turn on a video
i.g.normally go to hulu.com and watch a movie(while the radio is playing as well).

then after a few minuets I would see wpa_supplicant  in the terminal
saying disconnect/connect
(during that period, is when the music starts to die out, as well as the movie).
Comment 6 Dan Williams 2009-11-17 15:44:22 EST
Ok, if you get a chance to reproduce the issue, if you could use "-dddt" with the supplicant's command line, and also when you get the dropout, grab the last 20 or so lines of /var/log/messages for me.  Thanks!
Comment 7 Justin P. Mattock 2009-11-17 22:38:34 EST
sure..
right now I don't have fedora installed, but I do have the livecd,
What I can try is load the livecd hopefully get the wireless driver compiled
and then try and grab the debug message.
Comment 8 Dan Williams 2009-11-18 15:05:25 EST
Ok, let me know!
Comment 9 Justin P. Mattock 2009-11-18 18:19:42 EST
man I feel so stupid. just loaded the livecd got the wireless working with flash, and mplayer running, and to my surprise the system had no issues at all, leading me to believe that this was something done wrong on my behalf i.g. the only thing I can think of is my .config is missing/configured in a way to fire this off.

I apologize for filing this report without really testing this.
Comment 10 Dan Williams 2009-11-19 13:50:46 EST
No problem; I more suspect driver problems too though.  If this happens again, please reopen.  Thanks!
Comment 11 Justin P. Mattock 2009-11-19 14:16:27 EST
Thanks for being patient with me..

Note You need to log in before you can comment on or make changes to this bug.