Bug 51506 - RFE: robustify sshd restart with sshd -t
RFE: robustify sshd restart with sshd -t
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: openssh (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-11 07:07 EDT by Pekka Savola
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-11 07:07:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pekka Savola 2001-08-11 07:07:13 EDT
There have been some problems with 'sshd restart' etc. especially if config file 
is wrong (e.g. outdated sshd_config won't start with new sshd).  There are a few bugzilla 
reports on this.

If this something direly in need of getting more robust, you could consider applying:

20010806
 - OpenBSD CVS Sync 
   - stevesk@cvs.openbsd.org 2001/07/26 17:18:22
     [sshd.8 sshd.c]
     add -t option to test configuration file and keys; pekkas@netcore.fi
     ok markus@

Running 'sshd -t' before 'restart' and 'condrestart' in init.d/sshd script, and requiring it will pass 
before doing restart might reduce the cases where your connection is killed if new sshd is not restarted
due to some error.

(it's pretty late for this, and I'm not sure if this is viewed as something very important, but here it is anyway...)
Comment 1 Nalin Dahyabhai 2001-09-06 08:50:35 EDT
Doing so would only postpone the startup failure to next-boot, and also
potentially break from the restart-on-upgrade behavior most packages exchibit. 
As I have no strong feeling either way about this, I'm inclined to mark this bug
"deferred" and just go with what the upstream init script will do once the patch
works its way into a release.

If you believe that this can't wait, please reopen this bug.

Note You need to log in before you can comment on or make changes to this bug.