Bug 51508 - RUN_NONINTERACTIVE bug in colortoalpha plug-in
RUN_NONINTERACTIVE bug in colortoalpha plug-in
Product: Red Hat Linux
Classification: Retired
Component: gimp (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nils Philippsen
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2001-08-11 07:34 EDT by Alex Stewart
Modified: 2007-04-18 12:35 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-08-06 04:35:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Patcb to fix colortoalpha plug-in RUN_NONINTERACTIVE mode (347 bytes, patch)
2001-08-11 07:37 EDT, Alex Stewart
no flags Details | Diff

  None (edit)
Description Alex Stewart 2001-08-11 07:34:11 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.3-12 i686; en-US; 0.7)

Description of problem:
The colortoalpha plug-in cannot be invoked with the RUN_NONINTERACTIVE mode
(i.e. from script-fu).  It always fails with a PDB call error.

How reproducible:

Steps to Reproduce:
1. Open script-fu console
2. Invoke "(plug-in-colortoalpha RUN-NONINTERACTVE image layer color)"
(image, layer, and color values chosen are unimportant)
3. Watch it fail.

Additional info:

A patch which fixes the problem (against gimp-1.2.2) is attached.  I have
also submitted this patch to the plug-in author, but figured (particularly
with the new public beta) I'd let you guys know as well..
Comment 1 Alex Stewart 2001-08-11 07:37:35 EDT
Created attachment 27394 [details]
Patcb to fix colortoalpha plug-in RUN_NONINTERACTIVE mode
Comment 2 Nils Philippsen 2004-08-06 04:35:19 EDT
I guess this should be fixed in current GIMP ;-).

Note You need to log in before you can comment on or make changes to this bug.