Bug 515109 - alienarena sound initialization segfault
Summary: alienarena sound initialization segfault
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: alienarena
Version: 11
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Tom "spot" Callaway
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 530921 530922 531640 539711 542207 542289 544637 544934 546972 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-02 06:05 UTC by Andre Robatino
Modified: 2010-03-09 03:19 UTC (History)
16 users (show)

Fixed In Version: alienarena-7.32-2.fc11.1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-12-28 20:06:58 UTC


Attachments (Terms of Use)

Description Andre Robatino 2009-08-02 06:05:29 UTC
Description of problem:
alienarena-7.30-1.fc11.x86_64 crashes on startup.  The previous version did not.  Running from the command line gives

[andre@compaq-pc ~]$ alienarena-wrapper 
added /usr/share/alienarena/data1 to search paths
added /usr/lib64/alienarena/data1 to search paths
added ./data1 to search paths
using /home/andre/.codered/data1/ for writing
added /home/andre/.codered/data1 to search paths
added /usr/share/alienarena/arena to search paths
added /usr/lib64/alienarena/arena to search paths
using /home/andre/.codered/arena/ for writing
added /home/andre/.codered/arena to search paths
execing default.cfg
couldn't exec config.cfg
Console initialized.

------- sound initialization -------
Segmentation fault
[andre@compaq-pc ~]$

My system is a fully updated clean install of x86_64 F11.

Version-Release number of selected component (if applicable):
alienarena-7.30-1.fc11.x86_64

How reproducible:
always

Comment 1 Christophe Lambin 2009-08-02 12:27:58 UTC
Same on x86:
alienarena-7.30-1.fc11.i586

Comment 2 Andre Robatino 2009-08-02 22:23:17 UTC
I have the same behavior as before on an i686 machine with no sound devices currently plugged in.

Running

strace -o alienarena.txt -f alienarena-wrapper

the last part of the output is

3623  write(3, "\n------- sound initialization ---"..., 38) = 38
3623  open("/usr/lib64/alienarena/arena/libopenal.so", O_RDONLY) = -1 ENOENT (No such file or directory)
3623  open("/etc/ld.so.cache", O_RDONLY) = 4
3623  fstat(4, {st_mode=S_IFREG|0644, st_size=148809, ...}) = 0
3623  mmap(NULL, 148809, PROT_READ, MAP_PRIVATE, 4, 0) = 0x7feb30e95000
3623  close(4)                          = 0
3623  open("/lib64/tls/x86_64/libopenal.so", O_RDONLY) = -1 ENOENT (No such file or directory)
3623  stat("/lib64/tls/x86_64", 0x7fff993a0200) = -1 ENOENT (No such file or directory)
3623  open("/lib64/tls/libopenal.so", O_RDONLY) = -1 ENOENT (No such file or directory)
3623  stat("/lib64/tls", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
3623  open("/lib64/x86_64/libopenal.so", O_RDONLY) = -1 ENOENT (No such file or directory)
3623  stat("/lib64/x86_64", 0x7fff993a0200) = -1 ENOENT (No such file or directory)
3623  open("/lib64/libopenal.so", O_RDONLY) = -1 ENOENT (No such file or directory)
3623  stat("/lib64", {st_mode=S_IFDIR|0755, st_size=12288, ...}) = 0
3623  open("/usr/lib64/tls/x86_64/libopenal.so", O_RDONLY) = -1 ENOENT (No such file or directory)
3623  stat("/usr/lib64/tls/x86_64", 0x7fff993a0200) = -1 ENOENT (No such file or directory)
3623  open("/usr/lib64/tls/libopenal.so", O_RDONLY) = -1 ENOENT (No such file or directory)
3623  stat("/usr/lib64/tls", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
3623  open("/usr/lib64/x86_64/libopenal.so", O_RDONLY) = -1 ENOENT (No such file or directory)
3623  stat("/usr/lib64/x86_64", 0x7fff993a0200) = -1 ENOENT (No such file or directory)
3623  open("/usr/lib64/libopenal.so", O_RDONLY) = -1 ENOENT (No such file or directory)
3623  stat("/usr/lib64", {st_mode=S_IFDIR|0755, st_size=126976, ...}) = 0
3623  munmap(0x7feb30e95000, 148809)    = 0
3623  --- SIGSEGV (Segmentation fault) @ 0 (0) ---
3623  +++ killed by SIGSEGV +++

and it turns out that /usr/lib64/libopenal.so is owned by the openal-devel package.  Installing this package allows alienarena to run with segfaulting.  Should this be a dependency?

Comment 3 Andre Robatino 2009-08-02 22:24:28 UTC
Sorry, I meant to say "without segfaulting".

Comment 4 Andre Robatino 2009-08-03 08:22:02 UTC
Even though it runs without segfaulting if openal-devel is installed, there is no sound.  Running alienarena-wrapper from the command line shows the following:

------- sound initialization -------
/usr/lib64/libopenal.so.0: undefined symbol: alSource3i
/usr/lib64/libopenal.so.0: undefined symbol: alSourceiv
/usr/lib64/libopenal.so.0: undefined symbol: alGetSource3i
Sound failed: Unable to start OpenAL.
Game will continue without sound.

Comment 5 Tom "spot" Callaway 2009-08-03 12:50:16 UTC
Wow, okay, that's weird. I'll have to figure out what in the world is going on here... my primary hard disk just died on me, but I should be able to look into this in the next day or so.

Comment 6 Jason Haar 2009-08-12 05:03:05 UTC
This is a "me too"

Fully patched FC11 system, I start alienarena and it segfaults. strace led me to take a punt and symlink /usr/lib/libopenal.so.0 to /usr/lib/libopenal.so

That fixed the segfault, but (as above) I end up with "Game will continue without sound"

Sounds like the alienarena binary was built against a different version of openal?

I have openal-0.0.9-0.17.20060204cvs.fc11.i586 with alienarena-7.30-1.fc11

Jason

Comment 7 Tom "spot" Callaway 2009-08-12 15:44:54 UTC
So, there are two problems here.

1. Alienarena tries to dlopen "libopenal.so", which only lives in openal-devel. It is easy enough to fix it to dlopen the proper library, which leads to problem 2:

2. Alienarena is expecting a much newer revision of openal than exists in Fedora. An updated openal (openal-soft) just went into rawhide, but it isn't in Fedora 10 or 11. In order for this package to work (and I've confirmed that it does work in rawhide with the newer openal-soft), we need openal-soft to be built and pushed as an update for Fedora 10 and 11.

I've CC'd the openal and openal-soft maintainers (and Hans, just for good measure), who will hopefully let me know whether we can expect openal-soft to go into F10/F11. If not, I think we'll have to roll back this package to the last major version, which would... well, suck.

Comment 8 Thomas Kowaliczek 2009-08-12 21:56:50 UTC
I can make an OpenAL-Soft package for F10/F11.
But than must the alienarena recompiled with openal-soft because opeal-soft lib is libopenal.so.1 not libopenal.so.0.

Comment 9 Tom "spot" Callaway 2009-08-13 14:21:12 UTC
(In reply to comment #8)
> I can make an OpenAL-Soft package for F10/F11.
> But than must the alienarena recompiled with openal-soft because opeal-soft lib
> is libopenal.so.1 not libopenal.so.0.  

That is understood. Just let me know when the packages are built and pushed as updates so I can do the alienarena rebuilds.

Comment 10 Thomas Kowaliczek 2009-08-13 21:38:42 UTC
First i must contact all packager that use openal then i can make the package.

Comment 11 Hans de Goede 2009-08-14 06:48:50 UTC
(In reply to comment #10)
> First i must contact all packager that use openal then i can make the package.  

Thomas, aren't the new openal-soft packages parallel installable to the
old openal packages? In that case I see no reason to coordinate this with
the packagers of other openal using packages. Once openal-soft hits F-11 / F-10,
they can choose to rebuild their packages to make the switch or just leaves things
as is, right ?

Comment 12 Thomas Kowaliczek 2009-08-14 09:47:35 UTC
I think that:
Obsoletes: 	openal <= 0.0.10
Provides: 	openal = %{version}
Will replace openal?

Comment 13 Hans de Goede 2009-08-14 09:53:04 UTC
(In reply to comment #12)
> I think that:
> Obsoletes:  openal <= 0.0.10
> Provides:  openal = %{version}
> Will replace openal?  

Right, but the library has a different soname right? So there is no reason for the
obsoletes, the 2 packages should be installable parallel without problems
(atleast the main parts, the -devel parts is a different story).

Comment 14 Thomas Kowaliczek 2009-08-14 10:52:10 UTC
OpenAL-Soft is an update package for OpenAL.

Comment 15 Hans de Goede 2009-08-14 11:47:33 UTC
I know that openal-soft is intended to replace openal eventually, but given that it has a different soname and a different package name, the 2 can be installed
in parallel and your mail to the devel list gave me the impression that was the whole idea (for now until all packages are switched).

I got the impression from your mail that it would be good to move packages using openal over to openal-soft before F-12, but that that was not absolutely necessary as they would keep functioning with the old openal too (for now).

This is also what I /  we propose for F-11 and F-10 have a parallel installable openal-soft for alienarena (and maybe other packages who want to move) and keep the old openal around, so no obsoletes.

Comment 16 Tom "spot" Callaway 2009-08-14 13:44:44 UTC
For what it's worth, I agree with Hans. Having it replace openal in F-12 and forward is correct, but we simply need it as an option in F-10/F-11.

Comment 17 Thomas Kowaliczek 2009-08-14 13:58:36 UTC
i will build it but now i must wait for my f10/f11 cvs branch add on the cvs for it :)

Comment 18 Thomas Kowaliczek 2009-08-16 08:26:56 UTC
Now you can find openal-soft in testing repro please rebuild it and push it into testing.

Comment 19 Hans de Goede 2009-08-16 09:30:47 UTC
(In reply to comment #18)
> Now you can find openal-soft in testing repro please rebuild it and push it
> into testing.  

Yes and this one has the obsoletes for openal which it should not have!

I know your English isn't the best, but please try to understand, were not going
to blindly rebuild all openal using packages for F-11 and F-10. Instead the
F-10 and F-11 openal-soft should NOT have the Obsoletes for regular
openal (and a conflicts for openal-devel), like the initial versions for F-12
used to have.

So please remove (unpush) the current openal-soft from F-10 / F-11 updates
testing and do a new version without the Obosoletes / Provides for regular openal
(and with a conflicts for openal-devel instead).

Thank You!

Regards,

Hans

Comment 20 Thomas Kowaliczek 2009-08-16 12:01:54 UTC
For F-10 and F-11 it is in submitting for Stable with conflicts but in rawhide with ob...

I hope now is all okay :)

Comment 22 Hans de Goede 2009-08-16 18:45:16 UTC
(In reply to comment #20)
> For F-10 and F-11 it is in submitting for Stable with conflicts but in rawhide
> with ob...
> 
> I hope now is all okay :)  

All packages look good now, thanks!

Comment 23 Tom "spot" Callaway 2009-08-17 01:25:16 UTC
Please request buildsystem tags for these updates so I can build against them.

Comment 24 Thomas Kowaliczek 2009-08-21 10:05:16 UTC
What´s the status here? OpenAL-Soft is in F-10/F-11

Comment 25 Hans de Goede 2009-08-21 11:40:57 UTC
(In reply to comment #23)
> Please request buildsystem tags for these updates so I can build against them.

Spot, Thomas pushed the updates directly to stable, so you should be able to build against openal-soft now, without needing any tagging.

Comment 26 Fedora Update System 2009-08-21 14:32:30 UTC
alienarena-7.30-2.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/alienarena-7.30-2.fc10

Comment 27 Fedora Update System 2009-08-21 14:32:35 UTC
alienarena-7.30-2.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/alienarena-7.30-2.fc11

Comment 28 Tom "spot" Callaway 2009-08-21 14:34:19 UTC
Okay, I have created the updates for this. Please, if you have reported this issue, go and download this update and test it. If it resolves this issue for you, please give a karma vote on the update, so I will know I didn't break anything else. :)

Comment 29 Bob Arendt 2009-08-22 19:31:31 UTC
Thanks - works for me, with the new openal-soft packages also pending in koji.  Reported positive karma in koji.

Comment 30 Fedora Update System 2009-08-25 04:24:58 UTC
alienarena-7.30-2.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 31 Fedora Update System 2009-08-25 04:36:49 UTC
alienarena-7.30-2.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 32 Sandro Mani 2009-10-28 23:05:37 UTC
*** Bug 531640 has been marked as a duplicate of this bug. ***

Comment 33 Andre Robatino 2009-10-28 23:16:27 UTC
This bug was fixed.  If it's reappeared in Rawhide, either this bug should be reopened, or bug #531640 shouldn't be marked as a duplicate.

Comment 34 John Ruemker 2009-12-25 23:40:32 UTC
This issue still exists in the latest F12 packages:

> rpm -q alienarena openal-soft
alienarena-7.32-1.fc12.x86_64
openal-soft-1.10.622-2.fc12.x86_64
> alienarena
added /usr/share/alienarena/data1 to search paths
added /usr/lib64/alienarena/data1 to search paths
added ./data1 to search paths
using /home/user/.codered/data1/ for writing
added /home/user/.codered/data1 to search paths
added /usr/share/alienarena/arena to search paths
added /usr/lib64/alienarena/arena to search paths
using /home/user/.codered/arena/ for writing
added /home/user/.codered/arena to search paths
execing default.cfg
couldn't exec config.cfg
Console initialized.

------- sound initialization -------
Segmentation fault (core dumped)


alienarena[28202]: segfault at 2 ip 00000030b2c474b1 sp 00007fff6b1a5840 error 4 in libc-2.11.so[30b2c00000+16f000]

Comment 35 Thomas Kowaliczek 2009-12-26 02:35:44 UTC
I don´t know but can you choose in the settings witch sound backed you prefer?

Ala Alsa, OSS oder PulseAudio when yes please test it with Alsa and PulseAudio.

@Maintainer please report the to the Upstream and let me know what they think about that please.

Comment 36 Fedora Update System 2009-12-26 14:56:42 UTC
openal-soft-1.10.622-3.3793919892e6d61e5fec3abeaaeebc3f2332be13git.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/openal-soft-1.10.622-3.3793919892e6d61e5fec3abeaaeebc3f2332be13git.fc12

Comment 37 Thomas Kowaliczek 2009-12-26 16:00:58 UTC
#544637 bug report with backtrace

Comment 38 Thomas Kowaliczek 2009-12-26 16:01:22 UTC
https://bugzilla.redhat.com/show_bug.cgi?id=544637

Comment 39 Thomas Kowaliczek 2009-12-26 16:45:03 UTC
That bug is not an openal-soft bug i have talked with an openal-soft dev and he find the problem in alienarena code and he will report that bug.
When i have more infos i will post it here.

Comment 41 Thomas Kowaliczek 2009-12-26 23:20:29 UTC
The bug will fixed in 7.33. I´m closing the bug.

Comment 42 Hans de Goede 2009-12-28 09:12:24 UTC
(In reply to comment #41)
> The bug will fixed in 7.33. I´m closing the bug.  

Actually we already have a fix for this in our packages, but with a small
bug where we dlopenened openal.so.x.y instead of just openal.so.x, causing
pretty much the same crash when openal got rebased to a newer upstream, changing
the y in openal.so.x.y .

We already have this small bug in our fix fixed in rawhide, and I'm now building an F-12 update with this fixed too. So expect updated packages fixing this soon.

Note though, that even with this fixed, alienarena won't work for me, as it hangs on startup while initializing sound, this is with openal-soft-1.10.622-2.fc12,
quake3 has the same issue.

openal-soft-1.10.622-3.3793919892e6d61e5fec3abeaaeebc3f2332be13git.fc12 fixes these hangs for me, so should probably be pushed to updates stable soon, as it seems to be a better version to use then openal-soft-1.10.622-2.fc12 . Also the
openal-soft-1.10.622-3.3793919892e6d61e5fec3abeaaeebc3f2332be13git.fc12 version
seems to only have been build for fc12, meaning that we now have a broken upgrade path. I'll file a bug against openal-soft for this to make sure this gets build for development/rawhide too.

Comment 43 Fedora Update System 2009-12-28 10:18:48 UTC
alienarena-7.32-2.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/alienarena-7.32-2.fc12

Comment 44 Fedora Update System 2009-12-28 20:06:54 UTC
alienarena-7.32-2.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 45 Tom "spot" Callaway 2009-12-30 01:21:32 UTC
*** Bug 544637 has been marked as a duplicate of this bug. ***

Comment 46 Tom "spot" Callaway 2009-12-30 01:22:43 UTC
*** Bug 542289 has been marked as a duplicate of this bug. ***

Comment 47 Tom "spot" Callaway 2009-12-30 01:23:21 UTC
*** Bug 542207 has been marked as a duplicate of this bug. ***

Comment 48 Tom "spot" Callaway 2009-12-30 01:24:01 UTC
*** Bug 546972 has been marked as a duplicate of this bug. ***

Comment 49 Tom "spot" Callaway 2009-12-30 01:24:33 UTC
*** Bug 539711 has been marked as a duplicate of this bug. ***

Comment 50 Tom "spot" Callaway 2009-12-30 01:26:29 UTC
*** Bug 530921 has been marked as a duplicate of this bug. ***

Comment 51 Tom "spot" Callaway 2009-12-30 01:26:59 UTC
*** Bug 530922 has been marked as a duplicate of this bug. ***

Comment 52 Tom "spot" Callaway 2009-12-30 01:28:07 UTC
*** Bug 544934 has been marked as a duplicate of this bug. ***

Comment 53 scumbag 2010-03-05 01:28:44 UTC
Looks like this problem still happen in some systems.

I have a segmentation fault with "sound initialization"

$rpm -q alienarena openal-soft
alienarena-7.32-1.fc11.i586
openal-soft-1.11.753-1.fc11.i586

I think that the alienarena-7.32-2 bugfix never appear in Fedora 11 updates.

Comment 54 Tom "spot" Callaway 2010-03-05 14:05:11 UTC
Good catch! The update is building now, will be submitted shortly.

Comment 55 Fedora Update System 2010-03-05 18:52:56 UTC
alienarena-7.32-2.fc11.1 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/alienarena-7.32-2.fc11.1

Comment 56 Fedora Update System 2010-03-09 03:19:02 UTC
alienarena-7.32-2.fc11.1 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.