Bug 515129 - Unable to use sata disks
Unable to use sata disks
Status: CLOSED DUPLICATE of bug 499733
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-08-02 08:49 EDT by W Agtail
Modified: 2009-08-10 05:56 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-10 05:56:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Various anaconda logs in tar ball. (200.00 KB, application/x-tar)
2009-08-02 08:49 EDT, W Agtail
no flags Details
anaconda.log extracted from the tarball (6.68 KB, text/plain)
2009-08-04 04:33 EDT, Radek Vykydal
no flags Details
storage.log extracted from the tarball (8.04 KB, text/plain)
2009-08-04 04:34 EDT, Radek Vykydal
no flags Details
syslog extracted from the tarball (39.97 KB, text/plain)
2009-08-04 04:35 EDT, Radek Vykydal
no flags Details

  None (edit)
Description W Agtail 2009-08-02 08:49:07 EDT
Created attachment 355940 [details]
Various anaconda logs in tar ball.

Description of problem:
While attempting to install from rawhide, the GUI installer does not include any disks to use.

Version-Release number of selected component (if applicable):
Today's rawhide.

How reproducible:
Always

Steps to Reproduce:
1. PXE install
2. Take all default options.
3.
  
Actual results:
No disks are selectable from "select the drive(s) to use for this installation"

Expected results:
Being able to use 2 sata disks.

Additional info:
Please refer to attached logs from /tmp.
Comment 1 Radek Vykydal 2009-08-04 04:33:32 EDT
Created attachment 356121 [details]
anaconda.log extracted from the tarball
Comment 2 Radek Vykydal 2009-08-04 04:34:22 EDT
Created attachment 356122 [details]
storage.log extracted from the tarball
Comment 3 Radek Vykydal 2009-08-04 04:35:11 EDT
Created attachment 356123 [details]
syslog extracted from the tarball
Comment 4 Adam Williamson 2009-08-07 13:10:53 EDT
We believe this happened because your disks were part of a BIOS RAID array, and you disabled the RAID functionality in your BIOS without first destroying the array. Is this correct?

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 5 Hans de Goede 2009-08-10 05:56:58 EDT
There has been a behavioural change between F-10 and F-11 where in F-10 drives
which contain invalid / stale dmraid (BIOS RAID) metadata / which were part of
an incomplete BIOS RAID set would be just seen as the raw disks, where as F-11
these drives are ignored.

In F-10 in cases where dmraid was detected unwantedly (in case of a complete
set, but being disabled in the BIOS for example), the BIOS RAID detection could
be avoided with nodmraid. In F-11 this option currently does not work, this is
bug 499733. Once 499733 is fixed you can workaround your issue using the
nodmraid installer cmdline option.

Note that a better solution would be to remove the unwanted BIOS RAID metadata
from the disks, this can be done using "dmraid -x", be sure to make backups
before doing this! "dmraid -x" should leave your data intact, but better safe
then sorry.

Also only do this if you really want your disks to not be part of a BIOS RAID
set, if for example windows is currently using the disks as a BIOS RAID set you
do not want to do this!

*** This bug has been marked as a duplicate of bug 499733 ***

Note You need to log in before you can comment on or make changes to this bug.