Bug 51513 - console logins broke with pam 0.75-8
console logins broke with pam 0.75-8
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: pam (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-11 09:54 EDT by Ward Fenton
Modified: 2007-04-18 12:35 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-11 09:54:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ward Fenton 2001-08-11 09:54:14 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)

Description of problem:
After upgrading to pam 0.75-8 I could not login at the console. 
Immediately after typing username and return, screen would redraw 
and "login" prompt would reappear. Could still login via ssh remotely. 
Also booting single user worked, so did starting network and sshd from 
single user prompt followed by ssh login locally.

console logins worked once again after returning to previous version.

How reproducible:
Always

Steps to Reproduce:
1.install latest pam rpms
2.switch virtual terminals and try to login
3.or reboot and try to login at console
	

Actual Results:  local console logins failed without providing password 
prompt.

Expected Results:  normal logins

Additional info:

pam 0.75-8 from rawhide for august 10, 2001 installed onto beta3 box 
tracking latest rawhide.
Comment 1 Bill Nottingham 2001-08-12 01:11:47 EDT
Fixed in -9.

Note You need to log in before you can comment on or make changes to this bug.