Bug 515145 - System hangs when generating SSH2 DSA key
System hangs when generating SSH2 DSA key
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openssh (Show other bugs)
rawhide
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Jan F. Chadima
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 531738
  Show dependency treegraph
 
Reported: 2009-08-02 13:49 EDT by Joachim Frieben
Modified: 2009-10-29 10:34 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 531738 (view as bug list)
Environment:
Last Closed: 2009-10-29 07:45:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Joachim Frieben 2009-08-02 13:49:10 EDT
Description of problem:
After installing a system from the current "rawhide" tree, the boot procedure always hangs at launching sshd when the latter tries to create the SSH2 DSA key. The last message reads:

  "Generating SSH2 DSA host key:"

The system will be stuck at this point unless the user enters ctrl-c which will cause this step to be aborted ("[FAILED]"). Hereafter, the system boots up as expected.

Version-Release number of selected component (if applicable):
openssh-server-5.2p1-17.fc12.i686

How reproducible:
Always.

Steps to Reproduce:
1. Restart system.
  
Actual results:
System hangs at step "Generating SSH2 DSA host key:".

Expected results:
SSH2 DSA host key gets created for once and for all.

Additional info:
- SELinux mode is "permissive".
- F11 used to behave correctly in this respect.
- http://www.smolts.org/client/show/pub_4cc8ec74-04a2-4b0c-88c3-6dce6d7b1d31
- Relevant segment from /etc/rc.d/init.d/sshd reads:

  if [ ! -s $DSA_KEY ]; then
	echo -n $"Generating SSH2 DSA host key: "
	if $KEYGEN -q -t dsa -f $DSA_KEY -C '' -N '' >&/dev/null; then
		chmod 600 $DSA_KEY
		chmod 644 $DSA_KEY.pub
		if [ -x /sbin/restorecon ]; then
		    /sbin/restorecon $DSA_KEY.pub
		fi
		success $"DSA key generation"
		echo
	else
		failure $"DSA key generation"
		echo
		exit 1
	fi
  fi
Comment 1 Jan F. Chadima 2009-09-30 07:44:02 EDT
I cannot reproduce it, is there any other condition (memory, cpu,... ) which cause it?
Comment 5 Joachim Frieben 2009-10-29 07:45:46 EDT
Sorry for not having reported yet that after a recent "rawhide" install from scratch on said IBM ThinkPad T23, the issue did not occur anymore.
Comment 6 Jan F. Chadima 2009-10-29 10:34:21 EDT
Repaired in F12 and F13 as well.

Note You need to log in before you can comment on or make changes to this bug.