Bug 515158 - bugzilla-3.2.4-1.el5 breaks existing installations
Summary: bugzilla-3.2.4-1.el5 breaks existing installations
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: bugzilla
Version: el5
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Itamar Reis Peixoto
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-02 23:43 UTC by Richard Shaffer
Modified: 2010-09-24 15:38 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-09-24 15:38:07 UTC
Type: ---


Attachments (Terms of Use)

Description Richard Shaffer 2009-08-02 23:43:21 UTC
Description of problem:
I have a CentOS 5.3 installation with bugzilla, and updating against the EPEL repo breaks it.

Version-Release number of selected component (if applicable):
3.2.4-1.el5

How reproducible:
This must affect all RHEL 5 and CentOS 5 installations.

Steps to Reproduce:
1. Upgrade or install bugzilla-3.2.4-1.el5 from EPEL.
2. Run /usr/share/bugzilla/checksetup.pl.
  
Actual results:
checksetup.pl reports that it requires some newer versions of Perl modules than what EPEL or CentOS provide:  CGI 3.21, Email::MIME 1.861, Email::MIME::Modifier 1.442, and DBD::mysql 4.00.

My host has perl-5.8.8-18.el5_3.1, perl-Email-MIME-1.859-1.el5, perl-Email-MIME-Modifier-1.441-1.el5, and perl-DBD-MySQL-3.0007-2.el5 installed.  While I do not have access to RHN, I checked out the SRPMs at http://ftp.redhat.com/pub/redhat/linux/enterprise/5Server/en/os/SRPMS/, and I don't see newer versions there.  Naturally, updated packages are not available in EPEL, either.

My host previously had bugzilla-3.0.2-0.el5.noarch installed.  Because the database schema has changed between 3.0 and 3.2, the installation at this point is unusable until checksetup.pl can successfully be run to update the database tables.  checksetup.pl cannot be run until the required Perl modules are installed.

Expected results:
checksetup.pl should run without errors, updating the database schema where required.

Additional info:
I can work around the problem by either downgrading to the previous version of the bugzilla package (3.0.2-0.el5.noarch), or hacking up the version checks in /usr/share/bugzilla/Bugzilla/Install/Requirements.pm and /usr/share/bugzilla/Bugzilla/Constants.pm to accept the versions on my host.

Small rant:
While I realize that Fedora projects are experimental, it does not seem very responsible to publish an update that is a minor version upgrade without doing a better job of testing on supported platforms.  At a minimum, testing for this package might have included installing the package, running checksetup.pl, and verify that basic functionality is there (i.e. can create a Bugzilla account and log a bug).  A security update is of rather limited use if it renders the installation unusable.

Comment 1 Itamar Reis Peixoto 2009-08-04 03:29:41 UTC
the fedora epel packages are maintaned by volunteer's (me , you, and others)

I don't have a centos box to make test's, but I will fix this issue soon.

thanks for reporting this bug.

Comment 2 Itamar Reis Peixoto 2009-08-04 04:36:54 UTC
Can you test this version and tell me if it's working ?

http://koji.fedoraproject.org/koji/taskinfo?taskID=1578175

I have patched

/usr/share/bugzilla/Bugzilla/Install/Requirements.pm 
and
/usr/share/bugzilla/Bugzilla/Constants.pm

with your instructions to be compatible with centos/rhel;

Comment 3 Itamar Reis Peixoto 2009-08-04 04:41:47 UTC
*** Bug 515250 has been marked as a duplicate of this bug. ***

Comment 4 Fedora Update System 2009-08-04 04:47:49 UTC
bugzilla-3.2.4-2.el5 has been submitted as an update for Fedora EPEL 5.
http://admin.fedoraproject.org/updates/bugzilla-3.2.4-2.el5

Comment 5 Fedora Update System 2009-08-04 04:47:53 UTC
bugzilla-3.2.4-2.el4 has been submitted as an update for Fedora EPEL 4.
http://admin.fedoraproject.org/updates/bugzilla-3.2.4-2.el4

Comment 6 Richard Shaffer 2009-08-04 04:52:58 UTC
I installed the bugzilla-3.2.4-2.el5.noarch package from http://koji.fedoraproject.org/koji/buildinfo?buildID=125480 on my host, and am able to run checksetup.pl, and verified that my Bugzilla installation still works.  (Can log in and query for bugs.)

Much thanks for your effort.

-Richard

Comment 7 Noa Resare 2009-08-04 06:54:59 UTC
Itamar, the issue I report in bug #515250 is unaffected by the changes in bugzilla-3.2.4-2.el4, I have downloaded bugzilla-3.2.4-2.el4.noarch.rpm and
tried to install it with the same error as previously:

[noa@johanna slask]$ LANG=C rpm -ivh bugzilla-3.2.4-2.el4.noarch.rpm 
error: Failed dependencies:
        perl(Email::Address) is needed by bugzilla-3.2.4-2.el4.noarch
        perl(Email::MIME) is needed by bugzilla-3.2.4-2.el4.noarch
        perl(Email::MIME::Modifier) is needed by bugzilla-3.2.4-2.el4.noarch
        perl(Email::Send) is needed by bugzilla-3.2.4-2.el4.noarch
        perl(Template::Stash) is needed by bugzilla-3.2.4-2.el4.noarch


I really do think that the issue in bug #515250 (deps missing when trying to install rpm) is separate to the issue described in this report (checksetup.pl fails to execute).

Comment 8 Fedora Update System 2009-08-18 00:26:20 UTC
bugzilla-3.2.4-2.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Mark Chappell 2010-09-24 15:38:07 UTC
While the el4 issue is still open, my reading of this bug is that the missing deps el5 issue has now been corrected, as such I'm closing off this bug.  Note: #515250 was reopened and un-duplicate-ed


Note You need to log in before you can comment on or make changes to this bug.