Bug 515410 - f12 anaconda mouse was not initialized during installation on stage 2
Summary: f12 anaconda mouse was not initialized during installation on stage 2
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gtk2
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 514274 (view as bug list)
Depends On:
Blocks: F12Beta, F12BetaBlocker
TreeView+ depends on / blocked
 
Reported: 2009-08-04 06:25 UTC by Liam Li
Modified: 2013-01-10 05:19 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-08-12 21:02:36 UTC


Attachments (Terms of Use)

Description Liam Li 2009-08-04 06:25:16 UTC
Description of problem:
f12 anaconda mouse was not initialized during installation on stage 2

Version-Release number of selected component (if applicable):
anaconda 12.7

How reproducible:
100%

Steps to Reproduce:
1.start install with f12 alpha build DVD
2.anaconda was started on stage 2
3.no mouse was found, have to install with keyboard
  
Actual results:


Expected results:

mouse should be initialized successfully
Additional info:

Comment 1 Andy Lindeberg 2009-08-04 14:49:55 UTC

*** This bug has been marked as a duplicate of bug 513879 ***

Comment 2 James Laska 2009-08-04 19:29:33 UTC
I don't think this is a duplicate.  At least the symptoms are different.

 * In bug#513879 ... the theme is incorrect and the mouse cursor icon is the generic X
 * In this bug ... the theme is correct and there is *no* mouse cursor

I've removed the duplicate tracking for now ... I could be wrong, but this failure presents  much differently.

Comment 3 Andy Lindeberg 2009-08-04 19:38:19 UTC
Are you sure? The reporter says nothing about the theme, and the first step of the problems in 513879 is that the mouse doesn't appear... but once you click the button and hit enter to go to the next screen, it appears as an X. I'm pretty sure this is a dupe...

Comment 4 James Laska 2009-08-05 15:05:26 UTC
After IRC discussion, these issues are different, but similar.  DUPLICATing these issues for now and we can break the bind should one issue remain.

*** This bug has been marked as a duplicate of bug 513879 ***

Comment 5 Adam Williamson 2009-08-06 06:10:35 UTC
Worth noting that the mouse is actually functional throughout install. The cursor is simply invisible. It _works_, though. If you move the mouse around, you can see things become highlighted, and you can click them. You just can't see the cursor.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 6 David Pravec 2009-08-06 15:38:45 UTC
i started seeing the cursor few screens after the start of stage 2, as an x (default x mouse cursor)

Comment 7 Adam Williamson 2009-08-06 20:13:27 UTC
The appearance of the cursor is quasi-random, as far as I can tell - I've done the install twice, the first time it showed up just two or three screens into stage 2, the second time it was much later.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 8 Adam Williamson 2009-08-07 15:48:18 UTC
Jesse Keating is very firm that this is not a dupe of 513879, and I do not believe it is either. They're also not 'similar', GTK+ theme has nothing to do with cursors. I'm de-duping this.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 9 Adam Williamson 2009-08-07 15:50:07 UTC
Jesse also notes the causes are not similar or even related:

<f13> for the GTK theme, we just simply weren't getting the theme files in install.img due to a incomplete upd-instroot run
<f13> the missing cursor is due to improper discovery of the cursor theme

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 10 Andy Lindeberg 2009-08-07 16:16:01 UTC
I'm still not convinced that they don't have the same root cause, since they both appeared at the exact same time, but I'll leave it unduped for now.

Comment 11 Jesse Keating 2009-08-07 17:04:43 UTC
 in the case of the missing gtk theme, the script that copies files around exited prematurely and we just simply didn't get some of the files we planned on in the case of the missing cursor, we weren't even planning on getting the right files the detection of what cursor files to get is done wrong, being accidentally correct in the past.

These are two distinct issues.

A patch to correctly discover the required cursor theme has been posted and is being discussed, but has not yet been accepted.

Comment 12 Chris Lumens 2009-08-07 19:59:18 UTC
ajax committed a fix for this and I've already rebuilt with it.

Comment 13 Andy Lindeberg 2009-08-10 14:35:34 UTC
*** Bug 514274 has been marked as a duplicate of this bug. ***

Comment 14 Andy Lindeberg 2009-08-10 14:36:19 UTC
According to Jesse, this is still a problem. Back to new.

Comment 15 Chris Lumens 2009-08-11 17:06:50 UTC
According to ajax, this is a gtk bug.  Reassigning, but we need to ask him to attach more detail here.

Comment 16 Jesse Keating 2009-08-11 17:44:45 UTC
We've got a "workaround" in rawhide right now, that would suffice for the Alpha, so I'm moving this over to the Beta tracker.

Comment 17 Matthias Clasen 2009-08-12 21:02:36 UTC
Its fixed in the latest gtk builds.


Note You need to log in before you can comment on or make changes to this bug.