Bug 515441 - Can't select local CD/DVD after provide a wrong NFS location during install of F12 alpha
Can't select local CD/DVD after provide a wrong NFS location during install o...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Radek Vykydal
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F12Blocker/F12FinalBlocker
  Show dependency treegraph
 
Reported: 2009-08-04 05:46 EDT by Liam Li
Modified: 2009-10-21 21:49 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-21 21:49:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
nfs error (85.90 KB, image/png)
2009-08-04 05:46 EDT, Liam Li
no flags Details
anaconda dump (197.57 KB, text/plain)
2009-08-24 05:17 EDT, Liam Li
no flags Details
tmp directory (410.00 KB, application/x-tar)
2009-08-24 05:30 EDT, Liam Li
no flags Details

  None (edit)
Description Liam Li 2009-08-04 05:46:17 EDT
Created attachment 356130 [details]
nfs error

Description of problem:
Can't select local CD/DVD after provide a wrong NFS location during install of F12 alpha

Version-Release number of selected component (if applicable):
anaconda 12.7

How reproducible:

100%
Steps to Reproduce:
1. install F12 alpha with nfs ,but load with local F12 alpha DVD
2. after get ip address, anaconda will pop out a warning box to show an error occurred,click ok, will prompt to edit repository, select CD/DVD in repository type
3. a unhandled exception will happend,see attached image. I can not record these unhandled information,because anaconda's save button doesn't work,it's another bug.
  
Actual results:


Expected results:


Additional info:
Comment 1 Andy Lindeberg 2009-08-04 10:54:59 EDT
We need the traceback from this. Can you scroll down so that the "self.ayum = AnacondaYum(anaconda)" line is at the top of the box, and take another screenshot?
Comment 2 Kamil Páral 2009-08-06 10:57:01 EDT
I don't know if my bug is a duplicate, but very probably it may be the same bug:
https://bugzilla.redhat.com/show_bug.cgi?id=516053
I have the logs you need.
Comment 3 Liam Li 2009-08-06 21:58:28 EDT
Kamil Páral ,I think we got the same issue. Both of us install f12 via NFS,but when we provide wrong NFS address,we will get an exception. So Andy Lindeberg ,please refer to Kamil Páral's bug 516053 as well
Comment 4 James Laska 2009-08-07 12:10:32 EDT
Discussed during F12-Alpha blocker bug meeting and decided to move this issue to blocks:F12Blocker.  Should new information come in on this report, it will be reassessed.
Comment 5 Andy Lindeberg 2009-08-07 12:13:10 EDT
It doesn't look like you both got the same exception, so I don't think it's the same bug. Could be related, though.
Comment 6 Chris Lumens 2009-08-19 13:19:22 EDT
If you can try this again and attach /tmp/anacdump.txt to this bug, it'd be very helpful.  Thanks.
Comment 7 Liam Li 2009-08-24 05:16:49 EDT
this time I got the anaconda dump,but did not found /tmp anacdump.txt ,I packaged the /tmp directory and attached here
Comment 8 Liam Li 2009-08-24 05:17:31 EDT
Created attachment 358426 [details]
anaconda dump
Comment 9 Liam Li 2009-08-24 05:30:04 EDT
Created attachment 358429 [details]
tmp directory
Comment 10 Liam Li 2009-08-24 05:45:10 EDT
this was tested on anaconda 12.15 f12 alpha rc2, test result is the same as previous test
Comment 11 Radek Vykydal 2009-10-07 04:44:24 EDT
This should be fixed in version 12.35 of anaconda.
Comment 12 James Laska 2009-10-21 11:48:59 EDT
(In reply to comment #11)
> This should be fixed in version 12.35 of anaconda.  

Liam, are you able to verify the reported issue is fixed?
Comment 13 Liam Li 2009-10-21 21:49:57 EDT
tested version 12.37, issue fixed,now close rawhide

Note You need to log in before you can comment on or make changes to this bug.