Bug 515444 - Anaconda can not save detailed exception during f12 installation
Summary: Anaconda can not save detailed exception during f12 installation
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: All
OS: Linux
low
high
Target Milestone: ---
Assignee: Chris Lumens
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F12Alpha, F12AlphaBlocker
TreeView+ depends on / blocked
 
Reported: 2009-08-04 09:57 UTC by Liam Li
Modified: 2009-08-06 14:51 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-08-06 14:30:29 UTC


Attachments (Terms of Use)
error occurred (85.90 KB, image/png)
2009-08-04 09:57 UTC, Liam Li
no flags Details
edit repository select box (58.52 KB, image/png)
2009-08-04 09:59 UTC, Liam Li
no flags Details

Description Liam Li 2009-08-04 09:57:05 UTC
Created attachment 356131 [details]
error occurred

Description of problem:
Anaconda can not save detailed exception, but pops up a box on which none button works during f12 installation

Version-Release number of selected component (if applicable):


How reproducible:
100%


Steps to Reproduce:
1.install F12 alpha with nfs ,but load with local F12 alpha DVD
2.after get ip address, anaconda will pop out a warning box to show an error
occurred,click ok, will prompt to edit repository, select CD/DVD in repository
type
3.a unhandled exception will happend,see attached image. click save to save detailed exception,a box will pop up,but none button of this box works. see attached images.
  
Actual results:


Expected results:


Additional info:

Comment 1 Liam Li 2009-08-04 09:59:04 UTC
Created attachment 356133 [details]
edit repository select box

Comment 2 Liam Li 2009-08-04 10:00:57 UTC
> 3.a unhandled exception will happend,see attached image. click save to save
> detailed exception,a box will pop up,but none button of this box works. see
> attached images.
> 
the box is "Edit Repository" box, "cancel" and "OK" button does not work
see second attached image

Comment 3 Chris Lumens 2009-08-06 14:30:29 UTC
This appears to be due to missing glade files from python-meh in the installer image.  This will be fixed in the next build of anaconda.  Thanks for the bug report.

Comment 4 James Laska 2009-08-06 14:51:22 UTC
This bug is already fixed in git and destined for the next anaconda build.  However, after discussing with Chris Lumens, we've agreed to add this to F12Alpha for tracking to ensure that the Alpha is able to capture and present exception handling to the user.


Note You need to log in before you can comment on or make changes to this bug.