Bug 51550 - mini commander applet dies on long command name
Summary: mini commander applet dies on long command name
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gnome-applets   
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
low
medium
Target Milestone: ---
Assignee: Mark McLoughlin
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-12 10:38 UTC by Kjartan Maraas
Modified: 2007-03-27 03:47 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-17 00:23:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Kjartan Maraas 2001-08-12 10:38:12 UTC
Description of Problem:

The mini commander applet has problems with empty commands

How Reproducible:

Every time

Steps to Reproduce:
1. add mini_commander_applet
2. place cursor in the window
3. press and hold enter

Actual Results:

The applet hangs, making it impossible to remove it from the panel
killall mini_commander_applet is needed.

Expected Results:

No hang.

Additional Information:

This has been fixed in a newer release of gnome-applets. This release also
fixes a buffer overrun in the applet since it uses a static buffer of 500
chars and doesn't check if the user types in more than that

Comment 1 Glen Foster 2001-08-13 19:10:24 UTC
This defect is considered SHOULD-FIX for Fairfax.

Comment 2 Havoc Pennington 2002-04-09 19:42:33 UTC
Doesn't die on enter for me anymore, but does die if I put in a really long
command name.

Comment 3 Kjartan Maraas 2002-06-17 00:23:26 UTC
Even after switching to the latest gnome-applets? I'd say close this.

Comment 4 Havoc Pennington 2002-06-17 01:24:05 UTC
Okie, no doubt fixed in gnome 2 anyhow.


Note You need to log in before you can comment on or make changes to this bug.