Bug 515537 - yum update throws " Segmentation fault /usr/sbin/redhat_lsb_trigger.x86_64"
yum update throws " Segmentation fault /usr/sbin/redhat_lsb_trigger.x86_64"
Status: CLOSED DUPLICATE of bug 514760
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Andreas Schwab
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-08-04 13:17 EDT by Valdis Kletnieks
Modified: 2009-08-05 03:12 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-05 03:12:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Valdis Kletnieks 2009-08-04 13:17:01 EDT
Description of problem:
During a 'yum update', I saw this go by:

  Cleanup        : glibc-headers-2.10.90-11.x86_64                        32/40 
  Cleanup        : glibc-2.10.90-11                                       33/40 
/usr/src/redhat/tmp/rpm-tmp.5O63Hm: line 3: 18935 Segmentation fault      /usr/sbin/redhat_lsb_trigger.x86_64
  Cleanup        : glibc-2.10.90-11                                       34/40 
/usr/src/redhat/tmp/rpm-tmp.SZUXba: line 3: 18940 Segmentation fault      /usr/sbin/redhat_lsb_trigger.x86_64
  Cleanup        : ghostscript-8.64-11.fc12.x86_64                        35/40

Not sure how lsb_trigger got invoked, because:

% rpm -q --scripts glibc
postinstall program: /usr/sbin/glibc_post_upgrade.x86_64
postuninstall program: /sbin/ldconfig
postinstall program: /usr/sbin/glibc_post_upgrade.i686
postuninstall program: /sbin/ldconfig

Also, am fuzzy on why trigger.x86_64 got invoked during the i686 cleanup..

Version-Release number of selected component (if applicable):
glibc-2.10.90-12.x86_64
glibc-2.10.90-12.i686

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Andreas Schwab 2009-08-05 03:12:51 EDT

*** This bug has been marked as a duplicate of bug 514760 ***

Note You need to log in before you can comment on or make changes to this bug.