Bug 515586 - Kopete:New Messages from changed resource arrive in new tab/window
Summary: Kopete:New Messages from changed resource arrive in new tab/window
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kdenetwork
Version: 11
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Than Ngo
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-04 20:19 UTC by Aniket
Modified: 2009-09-01 18:07 UTC (History)
8 users (show)

Fixed In Version: 4.3.0-2.fc10
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-01 18:06:06 UTC
Type: ---


Attachments (Terms of Use)

Description Aniket 2009-08-04 20:19:53 UTC
Description of problem:
If I am chatting with somebody using Kopete through jabber protocol (GTalk) and if he/she changes resource (switch from gmail to orkut or google talk application or Pidgin), the new messages from him/her are shown in new tab (or window). This behaviour is very annoying.

Version-Release number of selected component (if applicable):
kdenetwork-4.2.4-4.fc11.x86_64

How reproducible:
Always

Steps to Reproduce:
1.Chat with a Jabber/Gtalk contact
2.Let him change resource
3.
  
Actual results:
New chats arrive in new tab or window

Expected results:
The new chats should continue in same tab/window.  

Additional info:
This bug has been discussed on kopete-devel at 
http://www.mail-archive.com/kopete-devel@kde.org/msg15006.html

There are patches mentioned in the thread too. 

These are the relevant bug reports on KDE Bugzilla.

 https://bugs.kde.org/show_bug.cgi?id=111537
 https://bugs.kde.org/show_bug.cgi?id=142650
 https://bugs.kde.org/show_bug.cgi?id=175078
 https://bugs.kde.org/show_bug.cgi?id=194808

Its has been mentioned that the patches will make it to KDE 4.4. I request the package maintainers at fedora to please integrate these patches in current kdenetwork versions for fedora 10 and 11. It will enhance Kopete user experience very much as a lot of KDE users have complained about this bug and even for me , I have moved to Pidgin only due to this behaviour in Kopete , which is otherwise a very good messenger client.

Comment 1 Rex Dieter 2009-08-04 20:27:04 UTC
I have strong trepidations usurping upstream opinion here, if that is the case.  I'd venture this is due at least to string freeze, since this adds a new ui option.

Comment 2 Aniket 2009-08-04 21:27:31 UTC
Yes, you are right there, but otherwise is it possible to incorporate the patches with slight modifications? , so that the patches which change the UI (ie give user option to enable/disable this grouping) are not incorporated and apply the other patches to force the messages from same contact into same window/tab ( like Pidgin's behaviour). 

I know its not correct to force an option on users, but from the bug reports, its really clear that most users see this as a bug or undesired behaviour.

Comment 3 Rex Dieter 2009-08-04 23:19:54 UTC
Be that as it may, this is a conversation best had with upstream developers, not downstream distributors.

Comment 4 Kevin Kofler 2009-08-04 23:59:13 UTC
Good luck, given upstream's draconian freeze policy. I don't see why we couldn't backport this in our packages. In fact I'd like to see more backports, to bring features which are already ready for consumption to our users faster.

Comment 5 Aniket 2009-08-05 04:02:44 UTC
Well exactly my thoughts. KDE 4.4 is like atleast 4 months from now. Its very unfortunate if we have to hold back this useful patch from our users. And taking the middle path I suggested (without modifying the UI) seems to be a good way to achieve what I am proposing while still retaining the UI string freeze.

Comment 6 Than Ngo 2009-08-21 08:57:27 UTC
The patch introduces only one new string and if this feature is really important we should backport it to our package.

Of course, it's optimal if we could make a patch without modifying the UI.

Comment 7 Than Ngo 2009-08-24 11:40:49 UTC
i backported the patch without modifying the UI to our kde-4.3.0. The fix is included in kdenetwork-4_3_0-2_fc12. It will be included in next KDE update for F11/F10.

Comment 8 Aniket 2009-08-24 18:15:52 UTC
I will test it as soon as the package is built for F11 in Koji. Right now I can only see F12 package.

Comment 9 Than Ngo 2009-08-25 13:44:54 UTC
you can download from http://koji.fedoraproject.org/koji/buildinfo?buildID=129122

Comment 10 Fedora Update System 2009-08-25 13:56:22 UTC
kdenetwork-4.3.0-2.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/kdenetwork-4.3.0-2.fc11

Comment 11 Fedora Update System 2009-08-25 13:57:07 UTC
kdenetwork-4.3.0-2.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/kdenetwork-4.3.0-2.fc10

Comment 12 Aniket 2009-08-25 18:55:38 UTC
Thanks a lot Ngo  for working on this bug. I tested it today and it works very well.

Comment 13 Aniket 2009-08-26 19:10:20 UTC
Can we close this bug now?
Please excuse me for my ignorance but I am not familiar with the whole process and when to close a bug and who should close it.

Comment 14 Kevin Kofler 2009-08-26 20:42:52 UTC
It will be closed automatically when the updates go stable.

Comment 15 Fedora Update System 2009-08-27 02:08:13 UTC
kdenetwork-4.3.0-2.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kdenetwork'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-9017

Comment 16 Fedora Update System 2009-08-27 02:16:39 UTC
kdenetwork-4.3.0-2.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kdenetwork'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-9034

Comment 17 Fedora Update System 2009-09-01 18:06:01 UTC
kdenetwork-4.3.0-2.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 18 Fedora Update System 2009-09-01 18:07:39 UTC
kdenetwork-4.3.0-2.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.